Subject: [pim] Ask a question about behavior of PIM and IGMP

From: "biker" <[email-masked]>
Date: Tue, 24 Jun 2003 23:52:40 +0800

Hi all,
    We are developing a layer3 switch product. We encounter a problem. Is behavior and configuration of PIM and IGMP based on "Interface"(vlan, port, etc)? or based on subnet? or others?
    I had studied a lot of documents. I find many company use "Interface-based". But I can't find any idea from formal documents(RFC,...).
    May you give some advice or tell me which document have mentioned this.
    
    Following is example for this question.

For example:
switch configuration:
Two vlan:
    Vlan 1, Vlan 2

Four subnet:
(10.1.1.254, 255.255.255.0) associated to vlan1
(10.1.2.254, 255.255.255.0) associated to vlan1
(10.1.3.254, 255.255.255.0) associated to vlan2
(10.1.4.254, 255.255.255.0) associated to vlan2

Base on "Interface":
Our configuration must based vlan.
for example:
User can configure by subnet. It mean user can configure vlan 1's PIM and IGMP configuration. And behavior is based on subnet. It mean switch must choose one subnet to send PIM and IGMP packets. This subnet will be spokesman of vlan1.
Switch will treat (10.1.1.254, 255.255.255.0) and (10.1.2.254, 255.255.255.0) as same multicast domain.

Based on "subnet":
User can configure by subnet. It mean user can configure (10.1.1.254, 255.255.255.0)'s PIM and IGMP configuration. And behavior is based on subnet. It mean (10.1.1.254, 255.255.255.0) may send out all PIM and IGMP packets. And (10.1.2.254, 255.255.255.0) can do same thing. 
Switch will treat (10.1.1.254, 255.255.255.0) and (10.1.2.254, 255.255.255.0) as different domain.

Thanks,

/Biker

---

From: John Zwiebel <[email-masked]>
Date: Tue, 24 Jun 2003 09:22:00 -0700

FWIW:

Think about who the PIM hellos will be received by in both examples.
You only want one DR elected on a "physical subnet"

I interpret your "interface-based" example to mean a single VLAN.
A single VLAN would be equivalent to a "physical subnet".

If you were to configure two /24 addresses on a router interface,
only the highest IP address would be elected the DR.  (But you
will be asking for trouble because unicast routing is going to be
a problem.  It has been recommended that you "don't do this".)

On Tuesday, June 24, 2003, at 08:52 AM, biker wrote:

> Hi all,
>     We are developing a layer3 switch product. We encounter a problem. 
> Is behavior and configuration of PIM and IGMP based on 
> "Interface"(vlan, port, etc)? or based on subnet? or others?
>     I had studied a lot of documents. I find many company use 
> "Interface-based". But I can't find any idea from formal 
> documents(RFC,...).
> User can configure by subnet. It mean user can configure vlan 1's PIM 
> and IGMP configuration. And behavior is based on subnet. It mean 
> switch must choose one subnet to send PIM and IGMP packets. This 
> subnet will be spokesman of vlan1.
> User can configure by subnet. It mean user can configure (10.1.1.254, 
> 255.255.255.0)'s PIM and IGMP configuration. And behavior is based on 
> subnet. It mean (10.1.1.254, 255.255.255.0) may send out all PIM and 
> IGMP packets. And (10.1.2.254, 255.255.255.0) can do same thing.

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "Riyaz, Mohamed." <[email-masked]>
Date: Tue, 24 Jun 2003 22:02:33 +0530

The same case happens for IGMP aswell. IGMP messages will be sent by the
Querier
to 224.0.0.x address with TTL=1. So the IGMP messages being sent from the
querier
won't reach the other subnet ( assuing your 10.1.1.254/24 is primary
interface, the IGMP
messages won't reach 10.1.2.254/24, as its a different subnet and needs to
routed )

Correct me if I've gone wrong

Cheers
-MR

MOHAMED RIYAZ
E mail : [email-masked]
Ph : +91 80 5116 6203

I may not be there yet, but I'm closer than I was yesterday.
----- Original Message -----
From: "John Zwiebel" <[email-masked]>
To: "biker" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, June 24, 2003 9:52 PM
Subject: Re: [pim] Ask a question about behavior of PIM and IGMP

FWIW:

---

From: "Riyaz, Mohamed." <[email-masked]>
Date: Tue, 24 Jun 2003 22:02:32 +0530

Cheers
-MR

MOHAMED RIYAZ

----- Original Message -----
From: "John Zwiebel" <[email-masked]>
To: "biker" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, June 24, 2003 9:52 PM
Subject: Re: [pim] Ask a question about behavior of PIM and IGMP

FWIW:

---

From: "biker" <[email-masked]>
Date: Wed, 25 Jun 2003 11:44:25 +0800

Thanks,

Our switch support multi-netting. In our original design, we treat 10.1.1.254 and 10.1.2.254 as same. If we treat 10.1.1.254 and 10.1.2.254 are different, they may have duplicate packets in some case.

For example:
Two Router connect to same lan(LAN1) in vlan1. PIM and IGMP is running in these routers.

R_A: 
    vlan1: (10.1.1.254, 255.255.255.0), (10.1.2.253, 255.255.255.0)
    there have other vlan connect to other router.

R_B:
    vlan1: (10.1.1.253, 255.255.255.0), (10.1.2.254, 255.255.255.0)
    there have other vlan connect to other router.

For source 10.100.1.1, R_A and R_B had equal cost to this source. 

There are two host(10.1.1.1 and 10.1.2.1) join 224.1.1.1.

When 10.100.1.1 send multicast traffic to 224.1.1.1, there will have duplicate multicast traffic in LAN1. Bcz 10.1.1.254 is assert winner for (10.1.1.0, 255.255.255.0) and 10.1.2.254 will be assert winner for (10.1.2.0, 255.255.255.0). It mean R_A and R_B will forward this multicast traffic to LAN1 at same time. It will cause duplicate traffic. But host in LAN1 just need one copy of multicast traffic. And we think DVMRP will have same problem.

So we decide to use "interface-based"(In our product, only vlan). It mean our switch only send out one control packet and one copy of multicast traffic in any vlan. And I had read other vendor's manual(cisco, juniper, extreme,...). They all use "interface-based". 
But our customer insist use "subnet-based" configuration and behavior. I think it may cause trouble in future.

I can't find any formal documents discuss how to handle multi-netting issue in multicast related protocol(IGMP, DVMRP, PIM, ....). 

ps: I had studied IGMP, MROUTE, DVMRP and PIM mib. They use ifIndex as key of InterfaceTable. And ifIndex is imported from IF-MIB. And we don't know whether subnet(10.1.1.253, 255.255.255.0) can be interface in IF-MIB.

Please give me some advices,

Thanks,

/Biker
  ----- Original Message ----- 
  From: Riyaz, Mohamed. 
  To: biker 
  Sent: Wednesday, June 25, 2003 12:23 AM
  Subject: Re: [pim] Ask a question about behavior of PIM and IGMP

  Hi

  Could you tell how are you assigning two distinct Ip addresses for one VLAN ?. Does your switch support multi-netting ?. And to answer your question : PIM and IGMP send control messages per interface. But I see a security loop hole here. If say your primary interface is 10.1.1.254/24 and the Ip 10.1.2.254/24 is also associated to it, the multicast packets are getting onto 10.1.2.254 subnet un-necessarily. 

  Thanks
  -MR

  MOHAMED RIYAZ

    ----- Original Message ----- 
    From: biker 
    To: [email-masked] 
    Cc: [email-masked] 
    Sent: Tuesday, June 24, 2003 9:22 PM
    Subject: [pim] Ask a question about behavior of PIM and IGMP

    Hi all,

    For example:
    switch configuration:
    Two vlan:
        Vlan 1, Vlan 2

    Four subnet:

    Base on "Interface":

    Based on "subnet":

    Thanks,

    /Biker