Subject: [pim] Multicast Border Router behavior

From: Madhu Reddy <[email-masked]>
Date: Tue, 10 Jun 2003 13:54:06 -0700 (PDT)

Hi,
I would like to understand the behavior of a multicast
border router. I have gone through RFC2715 and could
not get answers to these questions. It's probably a
little bit of architectural/design question as well. 
I would appreciate if someone can shed light on this.

Consider the following setup:

       PIM      DVMRP
    A ------ B ------ C 
        if1       if2

B is the border router in question.
The PIM component owns interface if1 and DVMRP owns
the interface if2. B also has interfaces if3 running
PIM and if4 running DVMRP.

PIM uses the unicast routing table and DVMRP uses its
own table for RPF checks. 

Q) If A and C want traffic for (S,G), but PIM and
DVMRP both disagree on where the RPF interface is (say
PIM thinks it is if3 and DVMRP thinks it is if4),
whose RPF should be picked? In other words, should the
TIB entry be 

(S,G) iif3 {if1, if2} OR 
(S,G) iif4 {if1, if2} 

Does it matter? It's probably a misconfiguration
anyway if the same route is pointing in two different
directions in the two tables, but how should it be
handled? Is this something that can be resolved
through a preference like in unicast routing
protocols? If it is, aren't there issues with it? (PIM
picks if3 as RPF, but DVMRP has a higher preference,
so if4 is picked. Should PIM send a Prune on if3
then?)Do any vendors support this? Thanks.

Madhu
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Wed, 11 Jun 2003 07:30:28 +0100 (BST)

Hi,
   According to the RPF 2715 session 2 (Rule1, 2 and 3), i think we can have only one (S,G) route on the Forwarding table, If the data starts flowing on the incoming inferface (PIM interface), then that particular (S,G) route will be installed in the forwarder. If iam receiving the data packet on the other interface (DVMRP interface), as you said it should trigger a prune on PIM interface.

   But what i feel good thing to do is, have both the (S,G) routes in the forwarding table (CAM), the key for the CAM lookup should be atleast <group_addr, src_addr, incoming_interface>, which will fetch us the exact (S,G) route depending on the incoming interface. This will accutally prevent joining and pruning the interface in the case of under lying unicast route flapping.
  Note: The above suggesion is valid only when your forwarding CAM is flexible enough to do a lookup on the key <group_addr, src_addr, incoming_interface>.
 
Regards,
Jags

Madhu Reddy <[email-masked]> wrote:
Hi,

PIM DVMRP
A ------ B ------ C 
if1 if2

(S,G) iif3 {if1, if2} OR 
(S,G) iif4 {if1, if2} 

Madhu
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
Catch all the cricket action. Download Yahoo! Score tracker