Subject: [pim] PIM-SM Fragment BSM implementation

From: "bharat_joshi" <[email-masked]>
Date: Thu, 12 Jun 2003 20:16:38 +0530

Hi,

I was doing some PIM-SM testing with Cisco router and pimd (linux m/c).

pimd (Linux m/c) doesn't support fragment of BSMs. I saw this in source code.

Cisco does support fragmentation of BSMs but it sets the fragTag value to zero in all the cases.

Cisco doesn't change the fragTag value in its periodic BSMs also. Its always set to zero.

I am using the following release:

Cisco Internetwork Operating System Software 
IOS (tm) 2500 Software (C2500-IS-L), Version 12.2(1), RELEASE SOFTWARE (fc2)

has anybody seen this? or am I missing something??

and can anybody tell me if any free utility available which support fragment BSMs?

Thanks & Regards,
Bharat Joshi

------------------------
Infosys Technologies Ltd.,
Bangalore, India
Tel 91 80 5116 6526

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Dharti Dhami <[email-masked]>
Date: Thu, 12 Jun 2003 09:55:59 -0700 (PDT)

Hi Bharat,

> IOS (tm) 2500 Software (C2500-IS-L), Version 12.2(1), RELEASE SOFTWARE (fc2)

It is fixed in 12.2(12.13)

Thanks,
Dharti