Subject: RE: [pim] PIM in Linux 2.4

From: "Gessler Gerhard" <[email-masked]>
Date: Tue, 2 Sep 2003 09:01:48 +0200

Hi,

have you checked the TTL of the packets from your local network? If TTL == 1 than your linux box will not route the packets, but silently drop them.

Regards,

	Gerhard

--------------------------------------------
Gerhard Geßler

Communication Networks, IABG mbH
Einsteinstr. 20
85521 Ottobrunn, Germany

Telefon: +49 89 6088 - 2021
Fax: +49 89 6088 - 2845

E-Mail: [email-masked] 

  > -----Original Message-----
  > From: Guilherme Cox [mailto:[email-masked]] 
  > Sent: Tuesday, September 02, 2003 12:49 AM
  > To: [email-masked]
  > Subject: [pim] PIM in Linux 2.4
  > 
  > 
  > Hi,
  > 
  > I am trying to set-up pimd in my network and I want some help.
  > 
  > I have three network interfaces:
  > 
  > eth0 - My local network
  > eth1 - Satellite Link  ( ViaSat router )
  > eth2 - Internet Link   ( Cisco router - Multicast disable )
  > 
  > I am receiving multicast packets from eth1 and I need to 
  > route them to eth0. It seems to be a very easy task, but I 
  > really can not understand what it is not working.
  > 
  > I compiled linux kernel 2.4 with all the requirements to 
  > Multicast routing. I compiled pimd-2.1.0-alpha29.18
  > 
  > When I run pimd in debug mode (all), I can see the group 
  > 228.1.1.1 but the packets don't come to me.
  > 
  > Anybody have any tips or suggestions to me?
  > 
  > Thanks and sorry my english mistakes,
  > 
  > .cox
  > 
  > _______________________________________________
  > pim mailing list
  > [email-masked] http://catarina.usc.edu/mailman/listinfo/pim
  > 

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "bharat_joshi" <[email-masked]>
Date: Thu, 4 Sep 2003 04:46:30 +0530

Hi,

Please check if you have enabled ip_forwarding for the Box.

I think it will not forward IP packets if ip_forwarding is not 1.

~Bharat

-----Original Message-----
From:	Guilherme Cox [mailto:[email-masked]]
Sent:	Tue 9/2/2003 4:19 AM
To:	[email-masked]
Cc:	
Subject:	[pim] PIM in Linux 2.4

Hi,

eth0 - My local network

I am receiving multicast packets from eth1 and I need to route them to eth0.
It seems to be a very easy task, but I really can not understand what it is
not working.

I compiled linux kernel 2.4 with all the requirements to Multicast routing.
I compiled pimd-2.1.0-alpha29.18

When I run pimd in debug mode (all), I can see the group 228.1.1.1 but the
packets don't come to me.

.cox