Subject: RE: [pim] Assert Message

From: Bandi Sarveshwar-G19441 <[email-masked]>
Date: Thu, 4 Sep 2003 19:19:16 +0530

Just for clarification, does the draft say this explicitly? I looked for it but couldnt find it.

-----Original Message-----
From: Nicholas, Jonathan [mailto:[email-masked]]
Sent: Thursday, September 04, 2003 6:39 PM
To: kishore kishore; [email-masked]
Subject: RE: [pim] Assert Message

If I understand your question right, the answer is no.  

A downstream router (i.e. could_assert = FALSE), does not send a Prune
unless OIF(S,G) is NULL.  When an upstream router (the Assert Loser) sends a
Prune, the downstream router will send a Join to let the Assert Winner know
that there are still downstream members of the group.

The Assert Loser sends a Prune to prevent propogation of messages onto a net
where all the routers are upstream routers.

I hope that clarifies things.

Jonathan Nicholas

> -----Original Message-----
> From: kishore kishore [mailto:[email-masked]]
> Sent: Thursday, September 04, 2003 8:30 AM
> To: [email-masked]
> Subject: [pim] Assert Message
> 
> 
> 
> In PIM-DM draft (draft-ietf-pim-dm-new-v2-03.txt) .
> I would like to know if there's a need to send a prune message by the 
> downsteam router to the Assert winner when a prefered Assert or State 
> refresh packet is received (on the upstream interface or RPF 
> interface) and 
> the Assert state being in No_info state. Where the downstream router 
> (coudl_assert = False) is interested in receiving the data traffic.
> 
> Cause the downstream router(could_assert = false) shall send 
> a join message 
> to counter the prune message sent by the upstream assert 
> loser(could_assert 
> = true)  to the assert winner so that the data traffic is not 
> disrupted.
> 
> Thanks in adnvance.
> 
> Kishore
> 
> _________________________________________________________________
> Express yourself with MSN Messenger 6.0 -- download now! 
> http://www.msnmessenger-download.com/tracking/reach_general
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> http://catarina.usc.edu/mailman/listinfo/pim
> 

************************************
If this email is not intended for you, or you are not responsible for
the delivery of this message to the addressee, please note that this
message may contain ITT Privileged/Proprietary Information.  In such
a case, you may not copy or deliver this message to anyone.  You should
destroy this message and kindly notify the sender by reply email.
Information contained in this message that does not relate to the
business of ITT is neither endorsed by nor attributable to ITT.
************************************

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Thu, 4 Sep 2003 11:05:22 -0700

Since the dense-assert question went by...

I'd like to get some feedback on what is driving continued
dense-mode development.  I'm not judging it one way or the other,
but rather am interested in determining the applications
that may be expected to use this service, and why dense --
vs. ssm or bidir -- is more appropriate.

I'd like to point out problems with ttl=1 packets where
routers which might be expected to assert won't because they
first decrement the ttl, discover it is 0, recognize the
packet isn't for one of the assigned IP addresses and then
throw it away.  (I don't recall if this is addressed in the
new spec.)

So, this ttl problem kind of limits the usefulness of certain
types of expanding ring searches.

Again, I'm not saying that this shouldn't be "fixed" by the
vendors, I bring it up for interoperability and because its
something that can be easily overlooked making an expected
service rather useless.

So, who is using dense and why is it "better".

Thanks