Subject: [pim] PIM in Linux 2.4

From: "Guilherme Cox" <[email-masked]>
Date: Mon, 1 Sep 2003 19:49:29 -0300

Hi,

I am trying to set-up pimd in my network and I want some help.

I have three network interfaces:

eth0 - My local network
eth1 - Satellite Link  ( ViaSat router )
eth2 - Internet Link   ( Cisco router - Multicast disable )

I am receiving multicast packets from eth1 and I need to route them to eth0.
It seems to be a very easy task, but I really can not understand what it is
not working.

I compiled linux kernel 2.4 with all the requirements to Multicast routing.
I compiled pimd-2.1.0-alpha29.18

When I run pimd in debug mode (all), I can see the group 228.1.1.1 but the
packets don't come to me.

Anybody have any tips or suggestions to me?

Thanks and sorry my english mistakes,

.cox

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Dan He <[email-masked]>
Date: Wed, 03 Sep 2003 11:26:38 +0100

Hello Cuilherme,

I had a similar scenerios as you have. I had set up a linux router
with pimd. I was working well. what I was doing is described as following:

(1) check your linux 2.4 box. is it really multicast enable?
when you are starting your linux, you can see a prompt that is

Linux IP multicast router 0.06 plus PIM-SM

I am sure in Linux 2.4.19 that the first linux version I set up a work
pimd was a packing bug. it was not multicast enable(at least for my source),
i.e. you cann't see the above message at the stage of your Linux booting.
Now I am using Linux 2.5.64. it works on pimd.
(pls check linux source at /usr/src/linux/net/ipmr.c if you couldn't get that
message)

(2) pimd configuration
reading the document at README.config, it is short but quite helpful.
in my case, I have three interfaces:
eth0 my local network, ip address: 10.10.1.1
eth1 wireless network ip address: 192.168.7.13
eth2 local network ip address: 10.10.2.1

I specified one of my interfaces as cand_rp and cand_bootstrap_router. so the
file
pimd.conf looks like this:

cand_rp 10.10.1.1 time 30 priority 20
cand_bootstrap_router 10.10.1.1 priority 5

if you don't want that, you can comment out them(see README.config)

(3) your clients configuration
I had three clients. their IP addresses are specified below:
client 1: 10.10.1.2  windows 2000
client 2: 10.10.2.2  linux 2.4
client 3: 192.168.7.175 wireless laptop.
I add 10.10.1.1 as the router for 10.10.1.2
add 10.10.2.1 as a router for 10.10.2.2
thus you can ping from 10.10.2.2 to 10.10.1.2.
if so, you have readly set up a linux router. and once you start pimd on
10.10.1.1 laptop, you can test your mbone tools on your clients.

is it helpful? If I was wrong, forgive me my momery..

Cheers,

Dan