Subject: Re: [pim] I

From: Benjamin Black <[email-masked]>
Date: Wed, 28 Jan 2004 00:05:10 -0800

certainly, but not quite the point.  a single PIM message can be larger 
than 2^16 bytes, which won't fit in a single IP datagram.  assuming you 
were communicating across a link that had an MTU of 2^16, such a PIM 
message would _still_ be too large to fit in a single IP datagram.  in 
this case the PIM message would be fragmented across multiple IP 
datagrams which would not themselves be fragmented.

here's a picture:

[ really big PIM message that is like 200,000 bytes ]
[ 65535 byte IP packet ] <-- PIM message above won't fit here

ben

On Jan 27, 2004, at 11:54 PM, "" <[email-masked]> wrote:

>
> Hi,
>
> IP actually does reassembly before it gives it to PIM and
> PIM receives the complete packet intact.I have seen it work!
>
> So, I don`t understand the need for a fragmentation flag!
>
> Thanks,
> Arut
>
>
>
>
>  --- On Tue 01/27, Benjamin Black < [email-masked] > wrote:
> From: Benjamin Black [mailto: [email-masked]]
> To: [email-masked]
>      Cc: [email-masked], [email-masked]
> Date: Tue, 27 Jan 2004 19:54:05 -0800
> Subject: Re: [pim] PIM BSM fragmentation
>
> put a slightly different way:<br><br>PIM can generate a message larger 
> than the maximum size for a single IP <br>packet, so it must be able 
> to reassemble things when a single PIM <br>message is fragmented over 
> multiple IP packets.<br><br><br>ben<br><br>On Jan 27, 2004, at 5:25 
> PM, John Zwiebel wrote:<br><br>><br>> On Jan 27, 2004, at 5:16 PM, "" 
> <[email-masked]> wrote:<br>><br>>><br>>> I would like to know why 
> fragmentation support (read fragmentation <br>>> tag) is required at 
> PIM level when IP is already doing it.<br>>><br>><br>> Because if IP 
> does it, it may not include all the source for a given <br>> group 
> within the same<br>> packet.<br>><br>><br>> 
> _______________________________________________<br>> pim mailing 
> list<br>> [email-masked]<br>> 
> https://www1.ietf.org/mailman/listinfo/pim<br>><br>><br><br>
>
> _______________________________________________
> Join Excite! - http://www.excite.com
> The most personalized portal on the Web!
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim
>
>

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Benjamin Black <[email-masked]>
Date: Wed, 28 Jan 2004 00:05:10 -0800

here's a picture:

ben