Subject: Re: [pim] PIM BSM fragmentation

From: Benjamin Black <[email-masked]>
Date: Tue, 27 Jan 2004 19:54:05 -0800

put a slightly different way:

PIM can generate a message larger than the maximum size for a single IP 
packet, so it must be able to reassemble things when a single PIM 
message is fragmented over multiple IP packets.

ben

On Jan 27, 2004, at 5:25 PM, John Zwiebel wrote:

>
> On Jan 27, 2004, at 5:16 PM, "" <[email-masked]> wrote:
>
>>
>> I would like to know why fragmentation support (read fragmentation 
>> tag) is required at PIM level when IP is already doing it.
>>
>
> Because if IP does it, it may not include all the source for a given 
> group within the same
> packet.
>
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim
>
>

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Benjamin Black <[email-masked]>
Date: Tue, 27 Jan 2004 19:54:05 -0800

ben

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 2 Feb 2004 11:57:04 -0800

>> message is fragmented over multiple IP packets.

    No, PIM cannot. And a PIM implementation should not or else IP will either
    1) drop the packet or 2) erroneously truncate the packet.

    Since PIM has no explicit capability in general to fragment packets and
    it is an IP client protocol, it follows the maximum packet size oft IP
    which is 0xffff.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 2 Feb 2004 11:57:04 -0800

Dino

---

From: Benjamin Black <[email-masked]>
Date: Mon, 2 Feb 2004 18:01:23 -0800

Perhaps that information should be added to future revisions of the 
specs.

Ben

---

From: Benjamin Black <[email-masked]>
Date: Mon, 2 Feb 2004 18:01:23 -0800

Ben