Subject: [pim] CRP election

From: "" <[email-masked]>
Date: Thu, 11 Mar 2004 03:19:56 -0500 (EST)

Hi,

I need some clarifications regarding CRP election:

- CRP ADV messages are sent to BSR
- BSR builds BSMs and sends it to the PIM routers

My question is:

Should the BSR do the CRP election and decide which
RP is best for a particular group or should it send
all CRP addresses for each group in the BSM and allow
the PIM routers to decide on the RP?

Thanks,
Arut

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Thu, 11 Mar 2004 11:22:49 +0100

> the PIM routers to decide on the RP?

The BSR is free to use miscellaneous policies to determine which should
be announced. I think it's pretty common for all to be announced though.
Also note that PIM routers might receive several RPs for same group.
There are then several mechanisms to determine which to use, including
hashing to get load-sharing.

Stig

---

From: Stig Venaas <[email-masked]>
Date: Thu, 11 Mar 2004 11:22:49 +0100

Stig