Subject: Re: [pim] CRP election

From: "" <[email-masked]>
Date: Thu, 11 Mar 2004 23:52:02 -0500 (EST)

PIM docs (RFC/DRAFT) say that a group should have a single RP for
the same administrative domain.If this is true should we ensure 
that the RP-SET has a one-one mapping (i.e every group has only 
one RP)in the BSM.Also, should the BSR store the complete RP info
for each group (recvd. in CRP-ADV messages)?
Why is it that BSM format defines RP-LIST?

RP address 1..m
     The address of the Candidate RPs, for the corresponding group
     prefix.  The format for these addresses is given in the Encoded-
     Unicast address in [3].

Reference:

draft-ietf-pim-sm-bsr-03.txt

Thanks,
Arut

 --- On Thu 03/11, Stig Venaas < [email-masked] > wrote:
From: Stig Venaas [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Thu, 11 Mar 2004 11:22:49 +0100
Subject: Re: [pim] CRP election

On Thu, Mar 11, 2004 at 03:19:56AM -0500, [email-masked] wrote:<br>> <br>> Hi,<br>> <br>> I need some clarifications regarding CRP election:<br>> <br>> - CRP ADV messages are sent to BSR<br>> - BSR builds BSMs and sends it to the PIM routers<br>> <br>> My question is:<br>> <br>> Should the BSR do the CRP election and decide which<br>> RP is best for a particular group or should it send<br>> all CRP addresses for each group in the BSM and allow<br>> the PIM routers to decide on the RP?<br><br>The BSR is free to use miscellaneous policies to determine which should<br>be announced. I think it's pretty common for all to be announced though.<br>Also note that PIM routers might receive several RPs for same group.<br>There are then several mechanisms to determine which to use, including<br>hashing to get load-sharing.<br><br>Stig<br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 12 Mar 2004 12:32:10 +0530

Hi Arut,
           "PIM docs (RFC/DRAFT) say that a group should have a single RP
for
the same administrative domain."..
This means single RP for a particular group per admin domain but doesn't
restrict the same router to become RP for some other groups.....as a matter
of fact a single router generally becomes RP for several groups and to make
this happen, the router advertises itself as CRP for a group-range e.g.
225.0.0.0/8, entire 225 group range

for more details....look into the BSR document carefully...

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, March 12, 2004 10:22 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [pim] CRP election

RP address 1..m

Reference:

Thanks,
Arut

On Thu, Mar 11, 2004 at 03:19:56AM -0500, [email-masked] wrote:<br>> <br>>
Hi,<br>> <br>> I need some clarifications regarding CRP election:<br>>
<br>> - CRP ADV messages are sent to BSR<br>> - BSR builds BSMs and sends it
to the PIM routers<br>> <br>> My question is:<br>> <br>> Should the BSR do
the CRP election and decide which<br>> RP is best for a particular group or
should it send<br>> all CRP addresses for each group in the BSM and
allow<br>> the PIM routers to decide on the RP?<br><br>The BSR is free to
use miscellaneous policies to determine which should<br>be announced. I
think it's pretty common for all to be announced though.<br>Also note that
PIM routers might receive several RPs for same group.<br>There are then
several mechanisms to determine which to use, including<br>hashing to get
load-sharing.<br><br>Stig<br>

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 12 Mar 2004 12:32:10 +0530

Hi Arut,

regards,
Prashant

-----Original Message-----

RP address 1..m

Reference:

Thanks,
Arut

---

From: John Zwiebel <[email-masked]>
Date: Fri, 12 Mar 2004 07:12:58 -0800

Just to add to the confusion...

The RP is just an address and should no longer be considered
a -single- router.  There are implementations of anycast-rp which
use only PIM and do not require MSDP.

Basically, any member of the anycast group which receives a
pim register from a first-hop router, will forward that register
to the other members of the anycast group.

Once every member of the RP anycast group has the (S,G) everything
works just like MSDP anycast.

So, when talking about an RP, realize that you're talking about
an address being used as an RP not a specific router.

---

From: John Zwiebel <[email-masked]>
Date: Fri, 12 Mar 2004 07:12:58 -0800

---

From: Stig Venaas <[email-masked]>
Date: Fri, 12 Mar 2004 16:34:43 +0100

> use only PIM and do not require MSDP.

Let me add some more (:

The different PIM specs differ on how to pick the RP when the BSR
announces RPs with overlapping ranges (so that for a given group,
certain rules must be applied to decide which).

Also, for bidir PIM, the RP address doesn't even need to belong to
a router.

Stig

---

From: Stig Venaas <[email-masked]>
Date: Fri, 12 Mar 2004 16:34:43 +0100

Let me add some more (:

Stig