Subject: RE: [pim] Group prefix

From: "Ganapathasaa" <[email-masked]>
Date: Fri, 12 Mar 2004 11:34:22 +0900

Hi,
 
I guess, you are asking about the group address and mask length(group prefix) that is supplied with Cand-RP for announcing its candidacy. Basically this feature allows any Cand-RP to limit the range of group addresses for which it can act as RP. If there are two Cand-RPs RP1 and RP2 with group prefix 224/4 and 224.10.10.10/32 respectively, RP2 is willing to handle PIM join reaquest and multicast traffic for the group address 224.10.10.10 only, where as RP1 is ready to serve as RP for all the multicast group range. 
 
Hope that would clear doubt.
 
cheers,
Ganapath

	-----Original Message----- 
	From: ([email-masked]) [mailto:[email-masked]] 
	Sent: Fri 3/12/2004 10:16 AM 
	To: [email-masked] 
	Cc: 
	Subject: [pim] Group prefix

	Hi, 

	I would like to know why a group mask is used when we don`t do 
	subnetting etc. as is done in unicast. 

	Thanks, 
	Arut 

	_______________________________________________ 
	Join Excite! - http://www.excite.com 
	The most personalized portal on the Web! 

	_______________________________________________ 
	pim mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/pim 

-----------------------------------
Engineer, Protocol Team/R&D Center
Corecess Inc,
500-2, Sangdaewon-Dong, Jungwon-Ku,
Seongnam-city, Kyungki-do,
Korea, 462-120
Tel) 82-31-739-6907
Fax) 82-31-739-6899
www.corecess.com
-----------------------------------

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 12 Mar 2004 12:16:09 +0530

In short, Group/Group-mask - means CRP for a set of groups and hence the CRP can serve the entire "group range" given by the group prefix. 

This can eventually help in load balancing among CRP's, plus reduction in traffic due to  information carried by control packets....
e.g. 
G/mask (where mask = 4 or 8 or 24)  is always optimal than g1,g2,g3,.....gn/32 , where g1-gn is a subset of G/mask.
&
CRP election mechanism can elect distinct RP's for each for g1/32 and g2/32 groups although both the groups may be  subsets of G1 & G2 group ranges.

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Ganapathasaa
Sent: Friday, March 12, 2004 8:04 AM
To: [email-masked]; [email-masked]
Subject: RE: [pim] Group prefix

Hi,

cheers,
Ganapath
-----Original Message----- 
From: ([email-masked]) [mailto:[email-masked]] 
Sent: Fri 3/12/2004 10:16 AM 
To: [email-masked] 
Cc: 
Subject: [pim] Group prefix

Hi, 

-----------------------------------Engineer, Protocol Team/R&D CenterCorecess Inc,500-2, Sangdaewon-Dong, Jungwon-Ku,Seongnam-city, Kyungki-do,Korea, 462-120Tel) 82-31-739-6907Fax) 82-31-739-6899www.corecess.com-----------------------------------

---

From: Prashant Jhingran <[email-masked]>
Date: Fri, 12 Mar 2004 12:16:09 +0530

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Ganapathasaa
Sent: Friday, March 12, 2004 8:04 AM
To: [email-masked]; [email-masked]
Subject: RE: [pim] Group prefix

Hi,

cheers,
Ganapath
-----Original Message----- 
From: ([email-masked]) [mailto:[email-masked]] 
Sent: Fri 3/12/2004 10:16 AM 
To: [email-masked] 
Cc: 
Subject: [pim] Group prefix

Hi,