Subject: Re: [pim] CRP election

From: "" <[email-masked]>
Date: Sun, 14 Mar 2004 21:28:22 -0500 (EST)

Hi all,

According to draft-ietf-pim-sm-bsr-03.txt section 4.1:

 RP address 1..m
     The address of the Candidate RPs, for the corresponding group
     prefix.  The format for these addresses is given in the Encoded-
     Unicast address in [3].

Why is it that more than one RP is allowed for a group range?

Thanks,
Arut

 --- On Fri 03/12, John Zwiebel < [email-masked] > wrote:
From: John Zwiebel [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked], [email-masked], [email-masked]
Date: Fri, 12 Mar 2004 07:12:58 -0800
Subject: Re: [pim] CRP election

Just to add to the confusion...<br><br>The RP is just an address and should no longer be considered<br>a -single- router.  There are implementations of anycast-rp which<br>use only PIM and do not require MSDP.<br><br>Basically, any member of the anycast group which receives a<br>pim register from a first-hop router, will forward that register<br>to the other members of the anycast group.<br><br>Once every member of the RP anycast group has the (S,G) everything<br>works just like MSDP anycast.<br><br>So, when talking about an RP, realize that you're talking about<br>an address being used as an RP not a specific router.<br><br>On Mar 11, 2004, at 11:02 PM, Prashant Jhingran wrote:<br><br>> Hi Arut,<br>>            "PIM docs (RFC/DRAFT) say that a group should have a single <br>> RP<br>> for<br>> the same administrative domain."..<br>> This means single RP for a particular group per admin domain but <br>> doesn't<br>> restrict the same router to become RP for some other groups.!
 ....as a <br>> matter<br>> of fact a single router generally becomes RP for several groups and to <br>> make<br>> this happen, the router advertises itself as CRP for a group-range e.g.<br>> 225.0.0.0/8, entire 225 group range<br>><br>> for more details....look into the BSR document carefully...<br>><br>> regards,<br>> Prashant<br>><br>> -----Original Message-----<br>> From: [email-masked] [mailto:[email-masked]]On Behalf Of<br>> [email-masked]<br>> Sent: Friday, March 12, 2004 10:22 AM<br>> To: [email-masked]; [email-masked]<br>> Cc: [email-masked]<br>> Subject: Re: [pim] CRP election<br>><br>><br>><br>> PIM docs (RFC/DRAFT) say that a group should have a single RP for<br>> the same administrative domain.If this is true should we ensure<br>> that the RP-SET has a one-one mapping (i.e every group has only<br>> one RP)in the BSM.Also, should the BSR store the complete RP info<br>> for each group (recvd. in CRP-ADV messages)?<br>> Why is it that BSM format d!
 efines RP-LIST?<br>><br>> RP address 1..m<br>>      The address of the
 Candidate RPs, for the corresponding group<br>>      prefix.  The format for these addresses is given in the Encoded-<br>>      Unicast address in [3].<br>><br>> Reference:<br>><br>> draft-ietf-pim-sm-bsr-03.txt<br>><br>> Thanks,<br>> Arut<br>><br>><br>><br>><br>><br>>  --- On Thu 03/11, Stig Venaas < [email-masked] > wrote:<br>> From: Stig Venaas [mailto: [email-masked]]<br>> To: [email-masked]<br>>      Cc: [email-masked]<br>> Date: Thu, 11 Mar 2004 11:22:49 +0100<br>> Subject: Re: [pim] CRP election<br>><br>> On Thu, Mar 11, 2004 at 03:19:56AM -0500, [email-masked] wrote:<br>> <br>> <br>><br>> Hi,<br>> <br>> I need some clarifications regarding CRP election:<br>><br>> <br>> - CRP ADV messages are sent to BSR<br>> - BSR builds BSMs and <br>> sends it<br>> to the PIM routers<br>> <br>> My question is:<br>> <br>> Should the <br>> BSR do<br>> the CRP election and decide which<br>> RP is best for a particular <br>> group or<br>> should it send<br>> all CRP a!
 ddresses for each group in the BSM and<br>> allow<br>> the PIM routers to decide on the RP?<br><br>The BSR is free <br>> to<br>> use miscellaneous policies to determine which should<br>be announced. I<br>> think it's pretty common for all to be announced though.<br>Also note <br>> that<br>> PIM routers might receive several RPs for same group.<br>There are then<br>> several mechanisms to determine which to use, including<br>hashing to <br>> get<br>> load-sharing.<br><br>Stig<br><br>><br>> _______________________________________________<br>> Join Excite! - http://www.excite.com<br>> The most personalized portal on the Web!<br>><br>> _______________________________________________<br>> pim mailing list<br>> [email-masked]<br>> https://www1.ietf.org/mailman/listinfo/pim<br>><br>><br>> _______________________________________________<br>> pim mailing list<br>> [email-masked]<br>> https://www1.ietf.org/mailman/listinfo/pim<br><br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Sun, 14 Mar 2004 18:58:57 -0800

> Why is it that more than one RP is allowed for a group range?

http://ietf.org/internet-drafts/draft-ietf-pim-anycast-rp-00.txt

---

From: John Zwiebel <[email-masked]>
Date: Sun, 14 Mar 2004 18:58:57 -0800

---

From: Stig Venaas <[email-masked]>
Date: Mon, 15 Mar 2004 06:05:31 +0100

> Why is it that more than one RP is allowed for a group range?

Didn't you ask more or less same question a few days ago?

A hash function is mentioned in the draft, this is used for load-
balancing. But for a good description of the rules, see section
4.8.1 on group-to-rp mapping in draft-ietf-pim-sm-v2-new-09.txt

Stig

---

From: Stig Venaas <[email-masked]>
Date: Mon, 15 Mar 2004 06:05:31 +0100

Stig