Subject: [pim] Very simple pimd multicast configuration

From: Famille Béasse <[email-masked]>
Date: Sun, 9 May 2004 17:10:49 +0200

Hi,

Can someone can help-me to make a very simple multicast configuration.

Here is my test configuration  (With just one Router):

Server ----------------Multicast Router ----------------------Client
[192.168.1.1        192.168.1.250]   [192.168.0.250         192.168.0.1]

Netmask is 255.255.255.0
/proc/sys/net/ipv4/ip_forward is set to1
Router is Linux Fedora Core 1 With Pimd-2.1.0-alpha29-18
IP_Multicast PIM-SM etc is activate by default in kernel.

My router is ok for unicast. I can communicate from server to client.

But When i want to make Multicast from Server to Client, traffic is not
forward by the router.When i do a "ping -t 5 224.0.0.1" on Linux Client,
packets are not forwards to Linux Server and vice-versa.

What tools can i use to see if configuration is OK ?
What's about pimd.conf configuration file ?

When i do a "ip mroute show" there is nothing to see is it normal ?

Do you have any idea.
Thanks for your help.

Best regards

Christophe Béasse
France

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: [email-masked]
Date: Mon, 10 May 2004 18:51:56 -0700 (PDT)

First of all, you're using group addr 224.0.0.1 for testing.
It is a very special group, which, along with all of 224.0.0.0/24 
will not be forwarded by any multicast router. 
It's reserved for link-local multicast, 
for protocol hellos and such, that are to be sent with TTL=1. 

However, I can't tell what else is wrong, if you're using other
valid multicast data groups too. At least, the first thought is
to point out the invalid group usage above.

- Paras.

---

From: [email-masked]
Date: Mon, 10 May 2004 18:51:56 -0700 (PDT)

- Paras.

---

From: Prashant Jhingran <[email-masked]>
Date: Tue, 11 May 2004 09:44:07 +0530

hi,
    Also not very sure how Ping can work with a multicast address , because
multicast fwd entries will be created only on request in case of PIM-SM.
You may however try a utility called "mping" instead of normal "ping".

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, May 11, 2004 7:22 AM
To: Famille B閍sse .huawei.com
Cc: [email-masked]
Subject: Re: [pim] Very simple pimd multicast configuration

- Paras.

> Christophe B閍sse

---

From: Prashant Jhingran <[email-masked]>
Date: Tue, 11 May 2004 09:44:07 +0530

hi,

regards,
Prashant

-----Original Message-----

- Paras.