Subject: [pim] Changes from -09 to -10 in PIM-SM spec

From: Bill Fenner <[email-masked]>
Date: Sun, 18 Jul 2004 23:03:18 -0700 (PDT)

Folks,

  Here is the list of changes to the PIM spec between -09 and -10.
These were mostly made in response to messages on the mailing list
and in response to Last Call comments.  There are change bars in
both the text and postscript versions (the postscript ones are more
accurate).

  I think there are still some security-related issues pending;
Hugh said that he would follow up on the list.

  Bill

Definitions:
- Slight clarification of DR description

Protocol Overview:
- Mention that shared tree might have undesirable latency as well as
  undesirable bandwidth overhead
- Clarify that the point-to-point links being covered are transit links.
- Add automatic (e.g., embedded-RP) discovery to how routers learn
  address of RP.

Protocol Specification:
- Moved PMBR description to Appendix.

General Purpose State:
- Modified "Gen ID" to "GenID"

(*,G) State:
- Added AssertWinner and AssertWinnerMetric to descriptions

(S,G) State:
- Added AssertWinner and AssertWinnerMetric to descriptions
- Changed "SPT bit" to "SPTbit"
- Added PMBR state at RP

State Summarization Macros:
- Remove "link-local" from definition of primary IP address definition
- Typo fix: "start machine" -> "state machine"

Data Packet Forwarding Rules:
- Changed "SPT bit" to "SPTbit"
- Added "and iif == RPF_interface(S)" to conditional in
  "On receipt of data from S to G on interface iif" pseudocode

Last-hop switchover to the SPT:
- Added a note that starting the KAT accomplishes the switch

Setting and Clearing the (S,G) SPTbit:
- Add "I_Am_Assert_Loser(S,G,iif)" to the conditional for setting the
  SPTbit to prevent black holes (from James Lingard and others)
- Changed "SPT bit" to "SPTbit"

Designated Routers (DR) and Hello Messages:
- Clarified that DR functionality happens on every link

Sending Hello Messages:
- Turned "PIM-Hello" into "PIM Hello"

Reducing Prune Propagation Delay:
- Renamed "LAN delay" to "Propagation Delay"
- Renamed "Propagation_Delay" to "Effective_Propagation_Delay"
- Allowed Effective_Propagation_Delay to use this router's value of
  Propagation_Delay(I)
- Renamed "Override Delay" to "Override Interval"
- Renamed "Override_Interval" to "Effective_Override_Interval"
- Allowed Effective_Override_Interval to use this router's value of
  Override_Interval(I)

Sending Register Messages from the DR:
- Changed "Path-MTU" to "Path MTU"
- Clarified that the header sizes should be considered when fragmenting
- Use the ICMPv6 "Packet too Big" term instead of the v4 "Fragmentation
  Required"
- Clarified that the TTL is decremented before entering the register
  tunnel when forwarding.

Receiving Register Messages at the RP:
- Clarify that a packet not actually sent to one of my addresses may be
  a spoofing attempt so should be dropped.
- Added PMBR functionality
- Fixed swapped timer values when sentRegisterStop == TRUE
- Clarified the decapsulate and forward with a note
- Clarified that the TTL is decremented when leaving the register
  tunnel when forwarding.

Receiving (*,*,RP), (*,G) and (S,G) Join/Prune Messages:
- State machine: don't cancel Prune-Pending timer when entering a
  state in which it's insignificant
- Clarify that accepting a zero source address on a p2p link is for
  backwards compatibility

Receiving (S,G,rpt) Join/Prune Messages:
- Replaced "n/a" and "error" entries from state machine tables with "-"
  like other state machines.

Sending (*,G)/(S,G) Join/Prune Messages:
- Clarify that an interface entering or leaving immediate_olist is
  not the only reason that JoinDesired(*,G)/(S,G) may change values.

PIM Assert Messages:
- Spell out AH for IPsec
- "Receive Preferred Assert with RPTbit clear and AssTrDes (S,G,I)"
  becomes "Receive Acceptable Assert ..."

(S,G) Assert Message State Machine:
- Only set the SPTbit if UpstreamJPState(S,G) is true to prevent
  black holes (from James Lingard and others).

(*,G) Assert Message State Machine:
- Clarify that when there is no source address in an Assert,
  there is no (S,G) Assert State Machine
- "Receive Preferred Assert with RPTbit set and AssTrDes (*,G,I)"
  becomes "Receive Acceptable Assert ..."

AssertCancel Messages:
- AssertCancel(*,G) gets a source of zero, not RP(G)

Assert State Macros:
- Changed "SPT bit" to "SPTbit"

PIM Multicast Border Router Behavior:
- Moved to Appendix A

PIM Bootstrap and RP Discovery:
- Don't say that PMBRs are always the border, since that's not how things
  ended up getting deployed.
- Define Embedded-RP
- Don't MUST that RP addresses be reachable, since that's an operational
  concern, the protocol/implementation can't verify it.

Source-Specific Multicast:
- Specify current IPv6 SSM range

PIM Packet Formats:
- Move checksum padding out of IPv6 section where it accidentally
  ended up.
- Clarify that the Register message length is 8.
- Add destination address to the list of things that must be checked

Hello Message Format:
- Renamed LAN Delay field to Propagation_Delay
- Describe Propagation_Delay and Override_Interval more completely.
- Require the "Address List" option for IPv6

Register Message Format:
- Replace "null registers" with "Null-Registers"

Group Set Source List Rules:
- Fix so that Join(S,G,rpt)/Prune(S,G) is ? and
  Prune(S,G,rpt)/Prune(S,G) is yes.

Assert Message Format:
- Changed "SPT bit" to "SPTbit"

Timer Values:
- Changed "LAN_delay_default" to "Propagation_delay_default"
- Changed Propagation_Delay(I) and Override_Interval(I) to
  Effective_*
- Added requirement that Register_Probe_Time be less than half
  of Register_Suppression_Time

PIM Address Family:
- Clarify that values 128-250 are PIM-specific.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: PrashantJhingran 70625 <[email-masked]>
Date: Mon, 19 Jul 2004 22:01:31 -0700

Hi,
    I would like to make a small comment on 09 draft although I am a bit late for the same.
---Section 4.10 "Pim Packet Formats" 
   says that the ....
   Graft messages are sent (in PIM-DM protocol) as multicast packets with destination address as All Pim Routers address.

The Graft messages in various situations (as described in the PIM-DM 05 draft) are sent as Unicast packets with the destination address as the Upstream Router's address, hence this part may also be updated.

kind regards,
Prashant

----- Original Message -----
From: Bill Fenner <[email-masked]>
Date: Sunday, July 18, 2004 11:03 pm
Subject: [pim] Changes from -09 to -10 in PIM-SM spec

> - Clarify that the point-to-point links being covered are transit 
> links.- Add automatic (e.g., embedded-RP) discovery to how routers 
> learn  address of RP.
> 
> Protocol Specification:
> - Clarified that the header sizes should be considered when 
> fragmenting- Use the ICMPv6 "Packet too Big" term instead of the 
> v4 "Fragmentation
>  Required"
> - Don't say that PMBRs are always the border, since that's not how 
> things  ended up getting deployed.
> - Define Embedded-RP
> - Don't MUST that RP addresses be reachable, since that's an 
> operational  concern, the protocol/implementation can't verify it.
>