Subject: [pim] Can RP skip sending Register-Stop messages?

From: "Manish Gupta (BBS)" <[email-masked]>
Date: Fri, 30 Jul 2004 11:06:25 -0400

Hello

    I have a pim-sm question specific to the following topology. I will
    appreciate if somebody could clarify my doubts about the workings
    of the pim-sm protocol.

    Topology:

      -#1-- [ box-RP ] --#2----
     |                         |
     |                         |
   [Box-Rcvr]-----#3------[Box-Sndr]
     |                         |
     |                         |
     (R)                      (S)

   TimeLine (skipping many steps):

   0. (R) starts up

   1. [Rcvr] sends (*,G) Joins to [RP]

      RP creates an (*,G) entry.

   2. (S) starts

   3. [Sndr] sends packet from (S) to [RP] wrapped in Register packet.

   4. On receiving Register Packet, [RP] tries to switch-over to
      SPT. To do this, [RP] sends a SG_Join to [Sndr].

   5. On receiving JSG_Join from SG [Sndr] can setup the forwarding
      path to RP.

   Question:
     Does [RP] still needs to send a  Register-Stop to [Sndr]?

     On [Sndr] if there is an SG path pointing to RP, why does it need
     to receive an explicit Register-Stop message from [RP]?
     It can forward the SG packet natively based on the SG_Join it
     has received. NO?

   Much thanks in advance.
   manish

ps: please let me know if this is not the right place to post such
      questions.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Christopher Thomas Brown <[email-masked]>
Date: Fri, 30 Jul 2004 11:57:34 -0400

Comments at bottom.

On Fri, 30 Jul 2004 11:06:25 EDT
>     Does [RP] still needs to send a  Register-Stop to [Sndr]?

Yes.

>     It can forward the SG packet natively based on the SG_Join it

It needs the register stop message to stop forwarding the data out
the register tunnel. The scenario you present is an edge case that
the finite state machines do not optimize, that is the RP is adjacent
to the first hop router so that the first hop could tell that the RP
was joined to the SPT. However, imagine a slightly more complex scenario
with an additional router between the first hop and the RP.

      -#1-- [ box-RP ] --#2----[Box-Middle]-----(R2)
     |                         | #4         #5
     |                         |
   [Box-Rcvr]-----#3------[Box-Sndr]
     |                         |
     |                         |
     (R)                      (S)

Now let's posit that the RP does not switch to the SPT and that
[box-middle] does switch. If [box-sndr] does not keep sending
register packets then [box-rcvr] and thus R does not receive data.

The PIM spec tries to keep things as simple as possible for what
is a complex protocol. Edge case optimizations like this are
typically avoided.

Chris

---

From: "Manish Gupta (BBS)" <[email-masked]>
Date: Fri, 30 Jul 2004 12:15:56 -0400

Thanks for clarifying this.

regards
manish

---

From: Prashant Jhingran <[email-masked]>
Date: Sat, 31 Jul 2004 10:46:56 +0800

Hi Maneesh,
           Just to sum up what others have commented.
Register-Stop  is an indication from RP to SDR that RP no longer wants
register packets from SDR for that particular S,G (S can be a wild card
as well).
Now the reasons can be:
a) RP is not interested in S,G coz no receivers fro this G
b) RP has started receiving S,G packets via SPT.

Regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Manish Gupta (BBS)
Sent: Friday, July 30, 2004 11:06 PM
To: [email-masked]
Subject: [pim] Can RP skip sending Register-Stop messages?

Hello

    Topology:

   0. (R) starts up

   2. (S) starts

   Question:

   Much thanks in advance.
   manish