Subject: RE: [pim] PIM assert function

From: Ian <[email-masked]>
Date: Mon, 22 Nov 2004 10:23:07 +0000

Hello,

Can I please seek some clarification on this high quality reply from Prashant. 

My question is how could an assert ever occur in PIM-SM, since once a PIM DR
router on a LAN is elected, any other PIM-SM routers on the LAN should never
forward multicast traffic onto that LAN.  My understanding is that an assert
would be sent in response to the PIM DR receiving a multicast stream on its
outgoing interface for that stream, and since no other routers are forwarding
traffic since they haven't sent joins, an assert won't happen.

I am obviously missing a key point here, but I can't see it yet.  Please provide
guidance.

Many Thanks
Ian

Quoting Prashant Jhingran <[email-masked]>:

> Hello Kumar,
> 
> Welcome to the group.
> 
> Let me briefly explain you the following points about a DR:
> 
> 1. The concept of DR and DR election is important in case of PIM-SM and
> not PIM-DM.
> 
> 2. You are correct when you say "So DR in this case is responsible for
> generating Join after it receives igmp join" but incorrect when you say
> "...or pim join from its downstream terminals".
> -- DR election is necessary for electing a DR on a LAN, a router which
> is responsible for initiating  PIM trees (PIM-SM) as a result of IGMP
> reports. Hence in PIM-SM a DR starts acting as a forwarder on the LAN.
> However, the DR may loose an Assert election and therefore the winner
> may become the forwarder on the LAN.
> --In case of PIM-DM, its the assert mechanism which decides the
> forwarder on the LAN and DR election has nothing to do with the
> forwarder in DM.
> 
> 3. The concept of DR is once again is of no use when it comes to
> exchange of join/prune messages between the PIM routers. 
> --If you think over this point then you may come to a conclusion that
> Assert mechanism is required due to the above reason and also that
> Assert mechanism is an efficient way of deciding  the forwarder on the
> LAN.
> 
> Hope this may clear your doubts.
> 
> Regards,
> Prashant Jhingran
> 
> Huawei Technologies 
> Beijing, China
> Ph# 00-86-10-82882837  (O)  
> 
> "You see, all the problems in the world are created by those who want
> 'perfection.' " -- Sri Sri Ravi Shankar  www.artofliving.org  
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Kumar P
> Sent: Monday, October 04, 2004 2:29 PM
> To: [email-masked]
> Subject: [pim] PIM assert function
> 
> 
> 
> Hello All,
> 
> I am new to PIM, want someboby clear my following doubt.
> 
> It is mentioned in the PIM draft that assert condition is likely to
> happen in multi-access environment where in there are more than one
> upstream routers present and have different opinion on reaching RP or
> Source, hence generate Join according and end up in receiving multiple
> streams of same data.
> 
> Draft also mentions that there should only one forwarder in such
> environments, which is nothing but DR in this case. So DR in this case
> is responsible for generating Join after it receives igmp join or pim
> join from its downstream terminals. My doubt is when there is single
> DR(hence forwarder) on this multi-access media, how does the other
> routers send join towards RP or Source when ther are not responsible for
> the same.
> 
> When a router doesn't send Join message also doesn't forward the
> multicast streams. Please clarify this.
> 
> TIA,
> Kumar
> 
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Shankar Vasudevan <[email-masked]>
Date: Mon, 22 Nov 2004 14:14:56 -0500

Hello Ian,

   The routers on a LAN, "SHOULD" forward traffic when they receive a 
"Join" from a downstreaam
neighbor, irrespective of whether its a DR oro not. The PIM joins are 
not sent only to the DR. The Join is sent to the nbr
which is chosen by a router's unicast route towards a RP / Source.

    LAN need not be always in the edge alone. a LAN could be present 
somewhere as a intermediate and in those scenarios
Assert comes into picture, because two downstream routers may have a 
different route towards a RP / Source.

Best Regards,
Shankar

---

From: Kumar P <[email-masked]>
Date: Mon, 22 Nov 2004 20:00:45 -0800 (PST)

Hi,
please see my response below,

Shankar Vasudevan <[email-masked]> wrote:

Hello Ian,

>>>ok thats right, but the question is why does the other router present on >>>the same LAN generate Join message towards RP/Source and pull the >>>traffic in first place. If it doesn't generate join in that way then there wont be >>>any assert in future.

>>>will you please explain how assert happens in edge LANs first. Because >>>my idea is, DR in edge LAN is the one who initiates the tree from sending >>>join towards its appropriate upstream neighbor towards RP/Source. In this >>>situation I fail to understand, why does the others(non DRs) present on the >>>same LAN care to send Join when they are not supposed to? 

Best Regards,
Shankar

Ian wrote:

>Quoting Prashant Jhingran 

		
---------------------------------
Do you Yahoo!?
 Discover all that’s new in My Yahoo!