Subject: [pim] PIM Register & Register-Stop process

From: "Nikhil Ninan" <[email-masked]>
Date: Wed, 1 Feb 2006 13:35:19 -0000

Hello,

         My next question, this is the situation:          

When a source DR gets multicast packets it encapsulates them and sends it to
the RP by unicast. The RP will check, if there doesn't exist receivers for
the group, will send a Register-Stop message and also starts within itself
for the group. The source DR as to keep sending null-register packets to the
RP before the timer expires thereby maintaining the state for the group. Now
if a receiver joins the group the RP will send a (S, G, spt) Join to the
source DR. Now the source DR sends multicast data to the RP, which in turn
will forward it to the receiver's DR through the (*, G, rpt) Join that the
receiver's DR had sent earlier. Once the Receiver's DR learns the address of
the source, it sends a (S, G, spt) Join directly to the source DR and the
source DR will forward multicast traffic directly to the receiver's DR.

1.)     Now does the receiver's DR send the prune to the RP tree first? And
when does the source DR send a prune to the RP?

2.)     Now if this was the only receiver for the group & the traffic is
flowing through the source tree then what states will be maintained by the
RP for the group, assuming that the source is transmitting??

3.)     And does the RP know that there is direct forwarding of traffic
between the source DR and receiver DR?

4.)     Is the multicast data forwarded to the RP always encapsulated, even
if the RP sends (S, G, spt) Join to the source DR as above???

Cheers

Nikhil

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "David McWalter" <[email-masked]>
Date: Wed, 1 Feb 2006 14:00:11 -0000

1) This is in the overview, section 3.  The DR waits for the SPT data before pruning off the RPT.
..  When the first traffic starts to arrive from the SPT, the DR or
upstream router starts to drop the packets for G from S that arrive via
the RP tree.  In addition, it sends an (S,G) Prune message towards the
RP.  This is known as an (S,G,rpt) Prune.  ...
 
2) The RP will have keepalive timer KAT(S,G) from the Register messages, plus (*,G,I) and (S,G,rpt,I) state on the downstream interface from the Join(*,G) and Prune(S,G,rpt) it has received, and continues to receive periodically.
 
3) No.  PIM is pretty much hop-by-hop.  PIM routers don't try to work out the state of remote routers across the network; just adjacent ones.
 
4) No.  If the RP joins the SPT, it gets multicast data hop-by-hop just like anyone else.  When it gets the Prune(S,G,rpt), it'll leave the SPT again and not forward any (S,G) data at all.
 
Try searching for this stuff in the PIM spec.  It's all in there.
http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-11.txt
 
DMcW.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Nikhil Ninan
Sent: 01 February 2006 13:35
To: [email-masked]
Subject: [pim] PIM Register & Register-Stop process
Importance: High

Hello,

When a source DR gets multicast packets it encapsulates them and sends it to the RP by unicast. The RP will check, if there doesn't exist receivers for the group, will send a Register-Stop message and also starts within itself for the group. The source DR as to keep sending null-register packets to the RP before the timer expires thereby maintaining the state for the group. Now if a receiver joins the group the RP will send a (S, G, spt) Join to the source DR. Now the source DR sends multicast data to the RP, which in turn will forward it to the receiver's DR through the (*, G, rpt) Join that the receiver's DR had sent earlier. Once the Receiver's DR learns the address of the source, it sends a (S, G, spt) Join directly to the source DR and the source DR will forward multicast traffic directly to the receiver's DR.

1.)     Now does the receiver's DR send the prune to the RP tree first? And when does the source DR send a prune to the RP?

2.)     Now if this was the only receiver for the group & the traffic is flowing through the source tree then what states will be maintained by the RP for the group, assuming that the source is transmitting??

3.)     And does the RP know that there is direct forwarding of traffic between the source DR and receiver DR?

4.)     Is the multicast data forwarded to the RP always encapsulated, even if the RP sends (S, G, spt) Join to the source DR as above???

Cheers

Nikhil