Subject: [pim] Minor comment plus question on draft-ietf-pim-anycast-rp-06.txt

From: Dave Price <[email-masked]>
Date: Tue, 07 Feb 2006 10:41:24 +0000

Dear All,

First, minor comment.  There is a typo in 3.0
where half way down it says "Ancyast-RP" and not "Anycast-RP".

Second, question.

The ID does not explicitly consider the position
where the DR for a source is actually one of the RPs themselves.

E.g. in section 3.0, perhaps RP1 is indeed itself the DR for S1.
I think this all still works o.k. though, RP1 would
presumably still send the PIM-register to the RPA and
thus intercept it itself and behave as described
as though it had arrived from another DR.

I suppose the only potential problem is if it checked the source
of the PIM-register and then acted as though it had arrived
"from another RP" in the set... 

Dave Price
	---------------------------------------------------------
	| David Price, Computer Science				|
	|							|
	|  Computer Science, University of Wales, Aberystwyth,	|
	|  Penglais Campus, Aberystwyth, Ceredigion, SY23 3DB	|
	|                                                       |
	| Email: [email-masked] WWW: http://www.aber.ac.uk/~dap |
	|  Phone: +44 1970 622428   FAX: +44 1970 622455	|
	---------------------------------------------------------

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 7 Feb 2006 10:39:12 -0800

>> where half way down it says "Ancyast-RP" and not "Anycast-RP".

    Fixed. But not sure this justifies another rev of the spec. I'll let the
    working group chairs decide.

>> as though it had arrived from another DR.

    Right, but the main PIM spec presumes this. This isn't anything speific
    to Anycast-PIM.

>> "from another RP" in the set... 

    Yes, most implementations, the DR will send the PIM register to the RP
    address, which is itself. The packet is looped back into an input queue
    and processed like it came from another system. The same goes for the
    Register-Stop message that it returns to itself.

Thanks,
Dino

---

From: Mike McBride <[email-masked]>
Date: Tue, 7 Feb 2006 11:52:48 -0800 (PST)

>    working group chairs decide.

Probably not, but thanks for doing it anyway, will make the iesg process 
proceed that much more smoothly.

mike

---

From: Mike McBride <[email-masked]>
Date: Tue, 7 Feb 2006 11:52:20 -0800 (PST)

mike