Subject: RE: [pim] Working Group Last Call: PIM MIB

From: "David McWalter" <[email-masked]>
Date: Thu, 9 Feb 2006 17:43:37 -0000

Hi Christopher.

As far as I know, sparse-dense means 'PIMv1'.  Here's the IANA definition:
http://www.iana.org/assignments/ianaiprouteprotocol-mib

We're no longer doing PIMv1.  PIM-MIB is for PIMv2, and so makes no mention of sparse-dense.

So asm != sparse-dense.  PIM-MIB is clear on this point:
            asm(3)       Any Source Multicast (ASM), with PIM Sparse
                         Mode.

PIM DM was experimental, and I don't think the PIM WG has any plans to do anything more with DM.

The *minimal* support for DM in PIM-MIB is an exception we are making, because this appears very easy and people tell me there are significant benefits for them.

Cheers,
DMcW.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christopher Thomas Brown
Sent: 09 February 2006 17:21
To: [email-masked]
Subject: Re: [pim] Working Group Last Call: PIM MIB

Lori Mickelson initiated a hyperspace jump with:
> Hi Dave and John,
> 
> Ok. so if PIM mode is a property of the group, how do you get a particular
> group to be used with dense mode?   If we could get an entry into
> the pimGroupMappingEntry table with a mode of dense, this would explain
> things for me, but I don't see anywhere in this MIB that allows
> configuration for a particular group to be dense mode.  I'm obviously
> missing something here.

In 'sparse-dense' a group is sparse if an RP is known for the group;
otherwise it is dense.  This shouldn't be something that is directly
settable on the group object. Its a dynamic property.

> pimStarGPimMode and pimSGPimMode are read-only and pimStaticRPPIMMode
> only specifies ssm, asm or bidir as options.
> 
> Also, you only list { ssm(2), asm(3) } for pimSGPimMode.  Shouldn't you
> add dm(5) to the list as well since you do include several DM only
> objects in this table.

If I'm not mistaken tehn asm = sparse-dense.

I'm getting the feeling that maybe the working group should publish
a document (informational?) on sparse-dense.  There are implementations
of PIM out there where sparse and dense are mutually exclusive on an
interface.

Chris

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Christopher Thomas Brown" <[email-masked]>
Date: Thu, 9 Feb 2006 14:37:18 -0500

> http://www.iana.org/assignments/ianaiprouteprotocol-mib

The two leading brands of router vendors (and probably others) implement a
hybrid sparse-dense with PIMv2.  In this mode a group is sparse (or
Bi-dir) if an RP is known for the group; otherwise, it is dense.

> We're no longer doing PIMv1.  PIM-MIB is for PIMv2, and so makes no mention of sparse-dense.

Yeah, but several vendors implement a sparse-dense. Which was my main
point. Should the WG document this type of use at least as informational?

>             asm(3)       Any Source Multicast (ASM), with PIM Sparse

I don't think the bare word 'asm' should be used here. Dense and DVMRP are
ASM protocols as well. Even though you explicitly define it you will
have people like me that glance over it and get confused when seeing a
word like 'asm'. Maybe renaming 'ssm' to 'sparse-ssm' and 'asm' to
'sparse-asm' make things clearer and consistent?

> The *minimal* support for DM in PIM-MIB is an exception we are making, because this appears very easy and people tell me there are significant benefits for them.

The benefit is that its better than writing an enterprise mib for dm. :)

Chris