Subject: [pim] PIM Hello Messages

From: "Nikhil Ninan" <[email-masked]>
Date: Wed, 1 Feb 2006 12:03:57 -0000

Hello,

          I have a query on PIM Hello Messages:

If a PIM router does not receive a Hello Message from one of its neighbors
within the "hello_period" will it drop the router's address from its list of
neighbors or will it wait for the router to miss a few more "hello_period"
's before it completely removes the router from the list.

Any feedback on this would be very useful.

Cheers

Nikhil

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "David McWalter" <[email-masked]>
Date: Wed, 1 Feb 2006 12:37:02 -0000

Hi Nikhil.
 
A PIM router waits longer than the hello_period before removing its adjacency with a neighbor.
-  Periodic Hellos are sent every hello_period seconds (30s by default).
-  Adjacencies are removed when the neighbor liveness timer expires (105s by default).
 
See sections 4.3.1, 4.3.2 and 4.11 of the PIM spec for details.
http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-11.txt
 
Hope that's helpful.
DMcW.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Nikhil Ninan
Sent: 01 February 2006 12:04
To: [email-masked]
Subject: [pim] PIM Hello Messages
Importance: High

Hello,

If a PIM router does not receive a Hello Message from one of its neighbors within the "hello_period" will it drop the router's address from its list of neighbors or will it wait for the router to miss a few more "hello_period" 's before it completely removes the router from the list.

Cheers

Nikhil