Subject: [pim] Join message suppression

From: Nikhil Ninan <[email-masked]>
Date: Tue, 06 Jun 2006 11:33:46 +0100

Hello there,
 Could someone explain to me what "disable Join message suppression" 
means. this is used with neighbor.tracking_support, under reducing Prune 
Propagation Delay on LANs.
cheers
Nikhil

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "David McWalter" <[email-masked]>
Date: Tue, 6 Jun 2006 13:47:23 +0100

Hi again Nikhil.

Disabling join suppression (on a particular interface) means that joins are sent even if other routers on the same LAN have recently sent a matching join to an upstream router.  Usually, such matching joins would be suppressed.

This hits scalability - imagine 100s of routers sending identical periodic joins across a LAN to the same upstream box.  We usually want all these duplicate control flows suppressed.  Usually join suppression is the way to go, so join suppression can only be disabled on a LAN if all routers can agree to explicit tracking.  (Section 4.3.3 Suppression_Enabled(I)).

Disabling join suppression means that the upstream router needs to explicitly track which downstream routers are joined to it.  This is a trade-off between state (including the many join retransmits) and prune propagation delay.

(If join suppression is enabled, prunes can take quite a while to propagate up the tree, because at each LAN the upstream node must wait for possible prune overrides before forwarding the prune upstream.  Disabling join suppression and tracking all joins/prunes on a per-downstream-router basis removes this need, so prunes can be forwarded upstream more quickly.)

That should explain the link between all the data in the LAN Prune Delay Hello option (4.9.2 OptionType 2), and between the macros and timers in section 4.3.3.

Hope that helps.
Dave McW.

-----Original Message-----
From: Nikhil Ninan [mailto:[email-masked]]
Sent: 06 June 2006 11:34
To: [email-masked]
Subject: [pim] Join message suppression

Hello there,