Subject: [pim] PIM-SM over IPv6 support in cisco

From: "varun srivastava" <[email-masked]>
Date: Mon, 17 Jul 2006 10:50:02 +0530

Hi ,
 I have one cisco specific query. In cisco 7200 IOS 12.3(14T)
Topology src-a ------ rtr-a ------ cisco ------- rtb-b
if I'm sending ipv4 (S[src-a],G) join from rtr-b to cisco  then it
creates a (S,G) state and send a (S,G)  join to rtr-a, but if I'm doing
same thing over ipv6 cisco accepts the packet but doesn't send and
create (S,G) join to rta-a ... does cisco mentioned above have full
support for (S,G) ?
 debug messages after receiving Join (S,G) packets are as follows.

15:05:05: IPv6 PIM: Received J/P on FastEthernet3/0 from FE80:1::10
target: FE80:1::20 (to us)
15:05:05: IPv6 PIM: J/P entry: Join root: 2FFE:2:0:1::1 group:
FF02:1::2 flags:  S
15:05:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel2,
changed state to up
15:05:08: IPv6 PIM: Interface Tunnel2 is marked passive, not enabled
15:05:08: IPv6 PIM: Interface Tunnel2 changed state to up
15:05:08: IPv6 PIM: Interface Tunnel2 is marked passive, not
enabledConnection closed by foreign host.

Regards
varun

On 7/11/06, Stig Venaas <[email-masked]> wrote:
> varun srivastava wrote:
> > Hi Nidhi,
> > I don't want to use any IGP . So in absence of IGP what are the options
> > left ?
>
> Point is that router-b must do RPF on the BSR address in the BSM, so
> router-b needs a route for the global address used as BSR address.
>
> If you have global addresses on link between router-a and router-b, then
> you should be ok (e.g. you use a /64 prefix for the link, and then by
> configuring the interfaces, router-b will have a route for router-a's
> address, they are both in the same /64).
>
> You might also add a static route on router-b, but the sane thing (IMO),
> is to just do what I said above.
>
> Stig
>
> > My basic questions is :- if I am already advertsing relationship
> > between router-a link local address and router-a global address in
> > hello message then why an extra route entry [either thru IGP or static
> > route] is needed to ask router to fwd router-a global address packets
> > to router-a link local address?
> > --
> > varun
> >
> > On 7/11/06, Nidhi Bhaskar <[email-masked]> wrote:
> >
> >> > Hi,
> >> > I have following queries regarding using PIM-SM over IPv6.
> >> > consider the following topology
> >> >
> >> > <router-a>BSR/RP------------<router-b>----------<host-b>
> >> >
> >> > 1) In PIM BSR message from router-a I keep source address as link
> >> > local ipv6 address in ipv6 header, and I'm using one global ipv6
> >> > address to advertise as BSR address (as link local scope can not be
> >> > advertised as global BSR). is this is correct ?
> >>
> >> That is correct.
> >>
> >> > 2) In this case I think we need to advertise global ipv6 address of
> >> > router-a in Hello message under option type 24. Now I think this
> >> > advertising of global ipv6 address as secondary address for the link
> >> > local address should be enough. But when I'm sending Join/Prune
> >> > packets from host-b to router-b with RP address as global ipv6 address
> >> > of router-a then router-b is failing RPF  check as it is not getting
> >> > any link for global ipv6 address of router-a. Can you suggest what
> >> > extra should be done ?
> >>
> >> That is odd. What IGP are you running ? You shouldn't RPF fail on
> >> router-b for a directly connected IPv6 address. I suspect something
> >> may be broken in unicast routing. Make sure the interface on which you
> >> have the global RP address configured is also enabled for your v6
> >> unicast routng protocol.
> >>
> >> Nidhi.
> >>
> >> > Note: router-b is cisco 7200 and if I explicitly add static route for
> >> > router-a global ipv6 address then every thing works fine , so I guess
> >> > problem is dynamic mapping of secondary global address to primary link
> >> > local address of router-a.
> >> >
> >> > waiting for early help
> >> > Regards
> >> > Varun
> >> >
> >> > _______________________________________________
> >> > pim mailing list
> >> > [email-masked]
> >> > https://www1.ietf.org/mailman/listinfo/pim
> >> >
> >> >
> >>
> >
> > _______________________________________________
> > pim mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pim
>
>

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "varun srivastava" <[email-masked]>
Date: Tue, 18 Jul 2006 14:24:31 +0530

Hi ,
 Please answer query asked by me in following mail. It is urgent .
Regards
Varun

---

From: Stig Venaas <[email-masked]>
Date: Tue, 18 Jul 2006 22:58:48 +0200

> Please answer query asked by me in following mail. It is urgent .

I'm on vacation and should probably do other things. I don't know why 
this is so urgent, I've got lots of mails from you on this issue now...

Anyway, it appears you are using a link-local group, in which case it's 
correct for the cisco to ignore the join.

Stig

---

From: "varun srivastava" <[email-masked]>
Date: Wed, 19 Jul 2006 13:04:17 +0530

Hi Stig,
 I'm really sorry for disturbing you in your vacation. But thanks alot
for your help. I wish you have a very exciting vacations :-)
Regards
Varun

---

From: "varun srivastava" <[email-masked]>
Date: Thu, 20 Jul 2006 20:37:09 +0530

Hi Stig/Nidhi,
 I sill doubt that cisco IOS 12.3(14T) has SSM support .
As I'm unable to get equivalent command for
ipv4 mld ssm-group enable
for ipv6 mld.
Regards
Varun

---

From: Patrick Grossetete <[email-masked]>
Date: Thu, 20 Jul 2006 17:44:13 +0200

Hi Varun,

         Several SSM commands for MLD were introduced on 12.4(2)T as 
documented in
http://wwwin-itg.cisco.com/ucdit/cc/td/doc/product/software/ios123/123cgcr/ipv6_r/ipv6_06g.htm#wp1940231
http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_configuration_guide_chapter09186a00801d6618.html#wp1290106

Regards
Patrick