Subject: [pim] Query regarding ASSERT

From: neeraj prasad <[email-masked]>
Date: Tue, 1 Aug 2006 09:36:03 -0700 (PDT)

Hi,
   
  The PIM draft mentions that ASSERT is required on multi-acess LANs. When we use the word LAN we implicity mean that the interface connected to the LAN is a broadcast type interface like Ethernet. If we have a PPP interface which is in 'oif' interface for lets say(*,G) Join and an IP multicast data packet is received on this 'oif', should PIM router ASSERT on this interface.
   
  The network topology is
   
  S1--------T1--------D1,D2--------T2
   
  s1 is configured to be RP
   
  I send one (*,G) Join from T2
   
  I then send IP multicast data packet from T2 destined to group G.
   
  Should router assert on D2 ??
   
  D1 and D2 are PPP interface lets say they are POS?
   
  Please clarify.
   
  Regards,
  Neeraj.

---------------------------------
How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Wed, 2 Aug 2006 09:59:23 -0700

Since its a p2p link, what would you expect to gain by asserting?

On Aug 1, 2006, at 9:36 AM, neeraj prasad wrote:

> Hi,
>
> The PIM draft mentions that ASSERT is required on multi-acess LANs.  
> When we use the word LAN we implicity mean that the interface  
> connected to the LAN is a broadcast type interface like Ethernet.  
> If we have a PPP interface which is in 'oif' interface for lets say 
> (*,G) Join and an IP multicast data packet is received on this  
> 'oif', should PIM router ASSERT on this interface.
>
> The network topology is
>