Subject: Re: [pim] WGLC pim-rpf-vector

From: Yakov Rekhter <[email-masked]>
Date: Mon, 01 Oct 2007 06:49:27 -0700

Ice,

> >>
> >> As it is now its up to the implementor to decide.
> >
> > Which means that the routers just ignore the F bit. Correct ?
> >
> > It would be useful to spell out that if a router supports a particular
> > TLV, (e.g., the RPF Vector TLV) then the router MUST ignore the value
> > of the F bit carried by the TLV.
> 
> This is how it is documented in the attributes draft:
> 
> F bit, Forward Unknown TLV.  If this bit is set the TLV is forwarded
>     regardless if the router understands the Type.
> 
> Meaning, if the TLV is unknown, you forward if this bit is set.
> 
> I think it is obvious that if the TLV is known, this bit has no  
> relevance.

While this may be "obvious", I think the spec clarify would be
improved by explicitly spelling out that if the TLV is known, the
F bit MUST be ignored.

Yakov.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 1 Oct 2007 15:56:14 +0200

Yakov,

> improved by explicitly spelling out that if the TLV is known, the

Ok, will add it.

Thx,

Ice.

---

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Wed, 10 Oct 2007 14:38:41 -0700

Ice,

When you submit the updated draft, which addresses the many comments,
we'll issue another WGLC. Let's try to get this done before Vancouver.

thanks everyone for the careful read,
mike 

-----Original Message-----
From: IJsbrand Wijnands [mailto:[email-masked]] 
Sent: Monday, October 01, 2007 6:56 AM
To: Yakov Rekhter
Cc: Mike McBride (mmcbride); [email-masked]
Subject: Re: [pim] WGLC pim-rpf-vector 

Yakov,

> improved by explicitly spelling out that if the TLV is known, the F 
> bit MUST be ignored.

Ok, will add it.

Thx,

Ice.