Subject: [pim] A problem about multicast flooding

From: zhoudi <[email-masked]>
Date: Tue, 10 Aug 2010 10:46:27 +0800

Hi,
   We'v found a problem in our network deployment.
   When there are one or more switches between multicast source 
and PIM first hop router, the multicast streams will tranfer through
these switches from source to DR, even if there is no request from 
receivers. This often leads to waste of switches' cache and link bandwidth
when the multicast streams are not actually required.
   The following is an example.
   
                ++++++++++
                + PIM DR +
                ++++++++++
                +         + 
       ++++++++++             +
       + switch +                  +
       ++++++++++                      +
        +     +                            +
      +        +                               +    
 ++++++++++    +++++++++++++++++++++++++++++       +++++++++++++++++++++++++++++     
 + source +    + other application client1 +       + other application client2 +
 ++++++++++    +++++++++++++++++++++++++++++       +++++++++++++++++++++++++++++

    In such a common deployment, the client1 and client2 are communicating, 
such as some vedio application. If the switch is always forwarding streams 
which not requested, these streams will waste the cache of switch's port 
connecting PIM DR and the cache shared by all of the switch's ports. They 
will also waste the bandwidth of the switch's port connecting PIM DR.
    If there are many sources, the multicast streams will flood to all PIM 
first hop routers. This is horrible. After all, the bandwidth of one high 
definition video stream may be up to 16Mbps, so five such stream can consume
80Mbps. 
   Unlike VOD or conference，this problem is serious when there are much 
more sources than receivers. This application has some characters as follows：
1. The sources are much more than receivers. 
2. Each source may be requested simultaneously by some receivers at some time. 
3. Most sources  is NOT requested at most time.
4. Receivers maybe exist between source and PIM first hop router, or exist 
   behind the PIM first hop router.
   
   So, in such a deployment, it is not acceptable to afford plenty of bandwidth 
for all the sources to send multicast streams, as well as the cache of switch.
   If we can control the switch just to forward the requested stream, and control
the streams just stop at the exact switch, it will be perfect. It does not need to suppress the source.
 
   If replacing the switch with PIM router, these stream will not flood if not 
required. But in the deployment where there are many sources, it is not acceptable
to put an PIM Router beside each source. Because it will lead to waste of ip address seriously and bring about so many ip segments.

   I hope someone would be interested this problem. 
   Any question and advice is welcome. Thanks.
                                   
Regards!
                                       Sincerely yours,ZhouDi

---

From: Indranil Bhattacharya <[email-masked]>
Date: Tue, 10 Aug 2010 12:22:52 +0530

Hi ZhouDi,

              This is the behavior for all switches. Data will be forwarded
to all mrouter ports. To stop this flooding, we will need some kind of a
signalling mechanism which makes the switch aware of the interest. Please
note that FHR can not do this signalling. The onus is on LHR and this will
be a unicast message.

               Else, pim snooping can be deployed on the switch and FHR can
be configured to send PIM message to the switch.

               These are some preliminary ideas that I have. Please let me
know your thoughts.

Thanks,
Indranil

2010/8/10 zhoudi <[email-masked]>

> 3. Most sources  is* NOT* requested at most time.
> to put an PIM Router beside each source. Because it will lead to waste of
> ip address seriously and bring about so many ip segments.
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>
>

---

From: zhoudi <[email-masked]>
Date: Tue, 10 Aug 2010 15:48:12 +0800

Hi Indranil，
     My solution is just like yours.
     The key points of my solution are as follows:
    
1. when the first hop PIM router receives a multicast stream, it judges whether the
    (S,G)has out interfaces. If the (S,G)has no out interface, then the PIM router
    send out an 'unicast PIM prune message' towards multicast source. 
2. the switches run PIM snooping and IGMP snooping. When it  receives PIM prune
   message, and it finds that the upstream neighbor address of the message is not in the 
   PIM neighbor  lists, then it creates a (S,G) entry with a pruned port and a upstream port, 
   but with NULL upstream neighbor.  The pruned port has a lifetime which is 1/3 of (S,G) 
   entry's lifetime.
   ----- here the PIM snooping function is proved and  is compatible with traditional PIM 
   snooping function.
3. By the information from IGMP-snooping entry and PIM-snooping  entry, the switch can 
   decide if it should forward the unicast PIM prune message. 
4. When the switch receives an IGMP membership report, it shall forward the message 
    through router ports and upstream port.
5. When the first hop PIM router creates an out interface for a (S,G)entry with null out interface,
   it shall send 'unicast PIM join message' towards source.

Many details are omitted. But you can know how the protocol work.
Any advice and question is welcome.    

Regards
ZhouDi
  ----- Original Message ----- 
  From: Indranil Bhattacharya 
  To: zhoudi 
  Cc: [email-masked] ; [email-masked] ; Leonard Giuliano ; Hui Deng 
  Sent: Tuesday, August 10, 2010 2:52 PM
  Subject: Re: [pim] A problem about multicast flooding

  Hi ZhouDi,

                This is the behavior for all switches. Data will be forwarded to all mrouter ports. To stop this flooding, we will need some kind of a signalling mechanism which makes the switch aware of the interest. Please note that FHR can not do this signalling. The onus is on LHR and this will be a unicast message. 

                 Else, pim snooping can be deployed on the switch and FHR can be configured to send PIM message to the switch.

                 These are some preliminary ideas that I have. Please let me know your thoughts.

  Thanks,
  Indranil

    Hi,
       
                    ++++++++++
                    + PIM DR +
                    ++++++++++
                    +         + 
           ++++++++++             +
           + switch +                  +
           ++++++++++                      +
            +     +                            +
          +        +                               +    

     

    Regards!
                                           Sincerely yours,ZhouDi

---

From: Indranil Bhattacharya <[email-masked]>
Date: Tue, 10 Aug 2010 15:08:19 +0530

Hi ZhouDi,

              Inline please.

Thanks,
Indranil

>     send out an 'unicast PIM prune message' towards multicast source.
#Indranil# FHR sends this message only if it is connected to a switch.

>    decide if it should forward the unicast PIM prune message.
#Indranil# To whom does the switch forward this message? It is connected to
source.

>     through router ports and upstream port.
#Indranil# This is already being done in all switches.

>    it shall send 'unicast PIM join message' towards source.
#Indranil# Only if connected to a switch. Otherwise basic pim protocol will
be affected.

> *From:* Indranil Bhattacharya <[email-masked]>
> *To:* zhoudi <[email-masked]>
> *Cc:* [email-masked] ; [email-masked] ; Leonard Giuliano <[email-masked]>; Hui
> Deng <[email-masked]>
> *Sent:* Tuesday, August 10, 2010 2:52 PM
> *Subject:* Re: [pim] A problem about multicast flooding
>
> Hi ZhouDi,
>
>> 4. Receivers maybe exist between source and PIM first hop router, orexist

---

From: zhoudi <[email-masked]>
Date: Tue, 10 Aug 2010 18:32:10 +0800

Hi Indranil，
     Thanks for your advice.
     My relpy and question are following your advice.
     Thanks.

Regards
ZhouDi
  ----- Original Message ----- 
  From: Indranil Bhattacharya 
  To: zhoudi 
  Cc: [email-masked] ; [email-masked] ; Leonard Giuliano ; Hui Deng 
  Sent: Tuesday, August 10, 2010 5:38 PM
  Subject: Re: [pim] A problem about multicast flooding

  Hi ZhouDi,

                Inline please.

  Thanks,
  Indranil

    Hi Indranil，

  #Indranil# FHR sends this message only if it is connected to a switch. 
  #ZhouDi# This function may be started by network manager or may run automaticly if it
  can detect it is connected to a switch by other protocol. Thanks.

  #Indranil# To whom does the switch forward this message? It is connected to source.
  #ZhouDi# Forwarding the unicast message to source by looking up the MAC table. There may be 
  more than one switch between the source and PIM FHR.

  #Indranil# Only if connected to a switch. Otherwise basic pim protocol will be affected.
  #ZhouDi# Why? Please.Thanks.

    Regards
    ZhouDi
      ----- Original Message ----- 
      From: Indranil Bhattacharya 
      To: zhoudi 
      Cc: [email-masked] ; [email-masked] ; Leonard Giuliano ; Hui Deng 
      Sent: Tuesday, August 10, 2010 2:52 PM
      Subject: Re: [pim] A problem about multicast flooding

      Hi ZhouDi,

      Thanks,
      Indranil

        Hi,
           
                        ++++++++++
                        + PIM DR +
                        ++++++++++
                        +         + 
               ++++++++++             +
               + switch +                  +
               ++++++++++                      +
                +     +                            +
              +        +                               +    

         

        Regards!
                                               Sincerely yours,ZhouDi

---

From: Indranil Bhattacharya <[email-masked]>
Date: Tue, 10 Aug 2010 16:13:25 +0530

Inline please.

Thanks,
Indranil

>  *Sent:* Tuesday, August 10, 2010 5:38 PM
>   #Indranil# If upstream nbr address is 0.0.0.0 then we do not send any
> pim j/p packet. So I was suggesting to provide a nob to turn this feature on
> instead of making it a default pim behavior.
>
> #Indranil# Are you planning to put this in a draft?

>>               This is the behavior for all switches. Data will be
>> forwarded to all mrouter ports. To stop this flooding, we will need some
>> kind of a signalling mechanism which makes the switch aware of the interest.
>> Please note that FHR can not do this signalling. The onus is on LHR and this
>> will be a unicast message.
>>
>>                Else, pim snooping can be deployed on the switch and FHR
>> can be configured to send PIM message to the switch.
>>
>>> to put an PIM Router beside each source. Because it will lead to waste
>>> of ip address seriously and bring about so many ip segments.
>>>

---

From: zhoudi <[email-masked]>
Date: Tue, 10 Aug 2010 18:56:24 +0800

I get it now. Thanks.
Yes, I plan to put this in a draft and welcome you to be my co-author.
Do you have any advice?

  ----- Original Message ----- 
  From: Indranil Bhattacharya 
  To: zhoudi 
  Cc: [email-masked] ; [email-masked] ; Leonard Giuliano ; Hui Deng 
  Sent: Tuesday, August 10, 2010 6:43 PM
  Subject: Re: [pim] A problem about multicast flooding

  Inline please.

  Thanks,
  Indranil

    Hi Indranil，
         Thanks for your advice.

    Regards
    ZhouDi
      ----- Original Message ----- 
      From: Indranil Bhattacharya 
      To: zhoudi 
      Cc: [email-masked] ; [email-masked] ; Leonard Giuliano ; Hui Deng 
      Sent: Tuesday, August 10, 2010 5:38 PM
      Subject: Re: [pim] A problem about multicast flooding

      Hi ZhouDi,

                    Inline please.

      Thanks,
      Indranil

        Hi Indranil，

      #Indranil# Only if connected to a switch. Otherwise basic pim protocol will be affected.
      #ZhouDi# Why? Please.Thanks.
      #Indranil# If upstream nbr address is 0.0.0.0 then we do not send any pim j/p packet. So I was suggesting to provide a nob to turn this feature on instead of making it a default pim behavior. 
  #Indranil# Are you planning to put this in a draft?

        Regards
        ZhouDi
          ----- Original Message ----- 

          Hi ZhouDi,

          Thanks,
          Indranil

            Hi,
               
                            ++++++++++
                            + PIM DR +
                            ++++++++++
                            +         + 
                   ++++++++++             +
                   + switch +                  +
                   ++++++++++                      +
                    +     +                            +
                  +        +                               +    

             

            Regards!
                                                   Sincerely yours,ZhouDi

---

From: Indranil Bhattacharya <[email-masked]>
Date: Tue, 10 Aug 2010 16:37:47 +0530

Thank you ZhouDi for your invitation. I do not have any advice at present. I
will think more on it and will let you know if I get anything else.

Regards,
Indranil

>   *Sent:* Tuesday, August 10, 2010 6:43 PM
>>> *Cc:* [email-masked] ; [email-masked] ; Leonard Giuliano<[email-masked]>; Hui