Subject: [pim] RFC4601bis - optional features

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 23 Mar 2011 22:46:59 -0400

As stated in a separate email, we're trying to identify some optional features that should be removed in order for the PIM specification to advance to Draft Standard (from the current Proposed Standard).

The following is a list of candidates. We need input from both vendors' and operators' input on:

   - whether there are interoperable & deployed implementations
   - whether there is sufficient operational experiences with

   - are there other candiates that do not meet the above requirements?

We have some comments/questions put next to the candidates:

1. (*,*,RP) and Border bit for PIM registers
    - most likely this has not been inplemented, or with sufficient operational experiences
    - what about other documents that refer to this?

2. Explicit tracking
    - there could be some implementations and deployment; but how common is it?
    - might be a useful feature to keep

3. Group to RP mappings
       - Hashing implementations
             - BSR only
             - Static as well   - main question: is this used/needed?
             - Not at all
       - Consider removing most group to RP mapping text and refer to the new RFC

Thanks.
Jeffrey, Rishabh，Vero

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 23 Mar 2011 20:27:56 -0700

I vote for making all shared tree operations optional. Only (S,G)
operations shuold be mandatory (PIM-SSM).

;-)) sorry. Could not resist.

On Wed, Mar 23, 2011 at 10:46:59PM -0400, Jeffrey (Zhaohui) Zhang wrote:
> Jeffrey, Rishabh?$B!$Vero
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Yiqun Cai <[email-masked]>
Date: Wed, 23 Mar 2011 21:50:55 -0700

On 3/23/11 7:46 PM, "Jeffrey (Zhaohui) Zhang" <[email-masked]> wrote:

> As stated in a separate email, we're trying to identify some optional features
> that should be removed in order for the PIM specification to advance to Draft
> Standard (from the current Proposed Standard).
> 

I would vote to remove the above.

>     - there could be some implementations and deployment; but how common is

Well,  it is hard to evaluate how common is "common".

>     - might be a useful feature to keep

As you said this is "implementation", so it might not be suitable to stay
within protocol specification?  Just my humble $0.02.

>        - Consider removing most group to RP mapping text and refer to the new

We never seem to be able to make our mind on this.

Anyway,  one data point,  IOS does *not* hash on statically configured RP.
I'm not aware of any other implementations that do so,  or any deployment
that uses it.

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 24 Mar 2011 01:32:14 -0400

Regards,
Jeff

> I would vote to remove the above.
+1
> that uses it
neither does SEOS

---

From: "NAPIERALA, MARIA H (ATTSI)" <[email-masked]>
Date: Thu, 24 Mar 2011 11:10:56 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jeffrey (Zhaohui) Zhang
> Sent: Wednesday, March 23, 2011 10:47 PM
> To: 'Stig Venaas'; 'Vero Zheng'; 'Rishabh Parekh (riparekh)';
> [email-masked]
> Subject: [pim] RFC4601bis - optional features> 

2. Explicit tracking
>     - might be a useful feature to keep

Yes, it is a useful feature and should not be removed.

Maria