Subject: [pim] draft-ietf-pim-hello-intid-00 wglc

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Fri, 20 May 2011 10:59:11 -0700

Today begins a two week wglc for draft-ietf-pim-hello-intid-00. Please
review the draft. Then indicate to us if its worthy, or not, of being
sent to the iesg.

http://www.ietf.org/id/draft-ietf-pim-hello-intid-00.txt

thanks,
mike

---

From: Bharat Joshi <[email-masked]>
Date: Mon, 23 May 2011 21:24:09 +0530

Hi Stig,

     I have few suggestions below, almost all minors on this draft.

Mike,
    I think this is ready for the next level.

Thanks,
Bharat

• Should we use "interface id" or "interface identifier" in Abstract?

• In following sentence in Introduction:

The identifiers can optionally be generated so that they are unique within, e.g., an administrative  domain.

will 'such that' instead of 'so that' be better?

• Should we move the second part of introduction to another section called 'Use cases'?

• In following statement:

   It is assumed that different protocols may have different minimum requirements for stability and uniqueness, but that they have no  maximum requirement. 

Can we use 'Interface identifier' as follows:

   It is assumed that different protocols may have different minimum requirements for stability and uniqueness of the interface identifier, but that they have no  maximum requirement. 

• Following statement:

If an interface goes down and up, the router SHOULD use the same Identifier.

to

If an interface goes down and comes up, the router SHOULD use the same Identifier.

• In Message format, can we move explanation of 'Router Identifier' before 'Local Interface Identifier' to keep it consistent with format?

• Should not PIM-Port be normative reference for this work?

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mike McBride (mmcbride) [[email-masked]]
Sent: Friday, May 20, 2011 11:29 PM
To: [email-masked]
Subject: [pim] draft-ietf-pim-hello-intid-00 wglc

thanks,
mike
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Stig Venaas <[email-masked]>
Date: Mon, 23 May 2011 10:36:26 -0700

On 5/23/2011 8:54 AM, Bharat Joshi wrote:
[...]
> • Should not PIM-Port be normative reference for this work?

Thanks, I think I agree with your comments. Apart from this one. This
is independent of PORT in the sense that it can be used when an ID is
required for other protocols. Supporting PORT is not a requirement to
implement this. Hence it does not need to reference PORT. This is also
why it was split out.

However, the PORT draft will need to have a normative reference to
this one, as PORT relies on this.

Stig

---

From: Bharat Joshi <[email-masked]>
Date: Tue, 24 May 2011 08:49:51 +0530

Hi Stig,

       I was thinking that this draft is using only one use case and that is of PORT and if this draft becomes an RFC before PORT and then PORT makes some changes and do not use interface identifier at all (its a hypothetical situation which won't happen here though) then it will not be good. That is why I raised this concern.

       As we are sure in this case that the above situation won't arise, I think it is fine to keep it as informative reference as well.

Regards,
Bharat
________________________________________
From: Stig Venaas [[email-masked]]
Sent: Monday, May 23, 2011 11:06 PM
To: Bharat Joshi
Cc: Mike McBride (mmcbride); [email-masked]
Subject: Re: [pim] draft-ietf-pim-hello-intid-00 wglc

Stig

---

From: Stig Venaas <[email-masked]>
Date: Fri, 27 May 2011 10:56:18 -0700

> http://www.ietf.org/id/draft-ietf-pim-hello-intid-00.txt

We only have one week left of the wglc, and only got one response
so far. Please let us know whether you think this document is ready,
or needs some changes.

Even if you are in favor, we need to hear your support,

Stig