Subject: [pim] Draft 'Explicit RPF Vector'

From: Bharat Joshi <[email-masked]>
Date: Tue, 23 Jul 2013 10:09:43 +0000

Hi Authors,

       I read through this draft. I think its ready to more to the next stage. However I have some small questions/suggestions below.

Regards,
Bharat

• In Introduction, last para, "that the Explicit RPF Vector join may" -> "that the PIM join may"

• In section 8, as mentioned before, metric may not be zero. Even then do we not want to use metric here? BTW, I wanted to understand why do you want to give special mention for this here. Even if metric is zero, PIM assert uses preference and IP address as well so whether we use metric or not, the outcome will remain same. Or am I missing something here?

• In section 8, in following sentence:

There is minor behavioral difference, the routing protocol's Metric that is included in the PIM Assert should be taken from the first Explicit vector in the list.

       Did you mean 'route metric' instead of routing protocol's Metric here. Also, sentence seems to suggest that routing protocol metric is available in the Explicit vector in the list. Can you please reword it accordingly?

• How does PIM prune override works? If override is supported, will all PIM routers that have joined a group will override this prune. I checked RFC 5384 and that does not mention this.

• Section 10, in title, 'Explicit Vector' -> 'Explicit RPF Vector'. Please fix this in the text of this section as well.

• Please read through Section 10 once. There is some conflict coming the way third sentence is framed. The second sentence using 'will not be able to remove' does not look correct.

• In section 12, "the RPF Vector attribute" -> "the Explicit RPF Vector attribute"

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Stig Venaas <[email-masked]>
Date: Mon, 29 Jul 2013 05:30:48 -0700

> • In section 8, as mentioned before, metric may not be zero. Even then do we not want to use metric here? BTW, I wanted to understand why do you want to give special mention for this here. Even if…

I'm also wondering about this. It seems to be standard behavior, and
then I don't think it's necessary to go into details here. That might
give the impression that something special is going on.

Stig

> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>