Subject: [pim] Some questions on RFC 6754

From: Bharat Joshi <[email-masked]>
Date: Mon, 8 Jul 2013 06:47:47 +0000

Hi,

      I was reading up RFC 6754 to understand the requirement and solution proposed for ECMP routes handling and I have some basic questions. It would be great if someone can asnwer them for me.

Regards,
Bharat

• In section 1, in sentence:

This document introduces the ECMP Redirect, a mechanism to improve the RPF procedure over ECMP.

     I did not get what does the term 'RPF procedure over ECMP' actually means? Can somebody please elaborate the same?

• In section 1, in sentence:

While implementations supporting ECMP have been deployed widely, the existing RPF selection methods have weaknesses

     Should 'RPF selection' be 'Upstream PIM neighbor selection'?

• In section 1, in sentence

For example, there is no straightforward way to tell two downstream routers to select either the same or different RPF neighbor routers for the same traffic flows.

     What are the conditions where downstream routers would want to choose two different RPF neighbors for the same traffic flows? I was thinking that we need some method like a hash to make sure that all downstream router uses the same upstream neighbor so that only one router forwards traffic for a given channel. This will also avoid need for assert messages in such scenarios.

• In Overview, in sentence

When the RPF neighbor router receives the Join message and finds that the receiving interface is one of the ECMP interfaces, it will check if the same flow is already being forwarded out of another ECMP interface.

     How does a upstream router figures out that the receiving interface is one of the ECMP interfaces for the downstream router?

     Also, it is not clear how the upstream route can check if the same flow is being forwarded out of another ECMP interfaces? Are these interfaces pointing to the same LAN?

      Let me try to put a figure and ask this.

       +------+          +-----+
        |  R1   |            |  R2 |
       +------+          +-----+
            |                     |
  +-----------------------------------+ 
            |                     |             
       +------+          +-----+
        |  R3   |            |  R4 |
       +------+          +-----+

In above configuration, how R1 would come to know if R3 has an ECMP route for a source/RP through both R1 and R2? Also, if there is a flow already exist through R2, how will R1 come that the flow is because of the ECMP route in R3 and R4?

Am I missing something here?

• Its not clear how will the routers (R1 to R4) create ECMP bundle? Is it that in this particular case, there will only be one interface in that ECMP bundle?

• It would have been great if a figure was used to describe the operations. I know its my limitation as I am not able to understand the text correctly.

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 18 Jul 2013 05:43:01 +0000

I did not see a response for this mail. Can authors or some others please respond to my questions?

Regards,
Bharat
________________________________________
From: Bharat Joshi
Sent: Monday, July 08, 2013 12:17 PM
To: [email-masked]
Subject: Some questions on RFC 6754

Hi,

Regards,
Bharat

       +------+          +-----+
        |  R1   |            |  R2 |
       +------+          +-----+
            |                     |