Subject: [pim] How to implement RPF lookup algorithm

From: Indranil Bhattacharya <[email-masked]>
Date: Mon, 23 Sep 2013 16:04:18 +0530

Hi,

   If in an implementation, route table manager returns all the ecmp
nexthops for a source or RP address to PIM then should one maintain all
those information in a RPF cache or should he calculate the best nexthop,
cache only that and discard the message? Can there be any advantage of
maintaining all the nexthops?

Thanks,
Indranil

---

From: Bharat Joshi <[email-masked]>
Date: Mon, 23 Sep 2013 10:56:49 +0000

Indranil,

       I think it is better to cache this information so that if the interface or the PIM neighbor that was selected for a channel goes down, this cache information can be looked up to find the next best suitable interface and PIM neighbor. This may reduce the overall time it takes to move this channel to another PIM neighbor. Please note that I am assuming that there are ways and means in place to keep this cached information upto-date with the forwarding table.

        Irrespective of how it is maintained internally, the external behaviour should be as defined in the RFC.

Regards,
Bharat Joshi
http://bite-the-bytes.blogspot.com/
________________________________________
From: [email-masked] [[email-masked]] on behalf of Indranil Bhattacharya [[email-masked]]
Sent: Monday, September 23, 2013 4:04 PM
To: [email-masked]
Subject: [pim] How to implement RPF lookup algorithm

Hi,

   If in an implementation, route table manager returns all the ecmp nexthops for a source or RP address to PIM then should one maintain all those information in a RPF cache or should he calculate the best nexthop, cache only that and discard the message? Can there be any advantage of maintaining all the nexthops?

Thanks,
Indranil

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***