Subject: [pim] Ben Campbell's Discuss on draft-ietf-pim-yang-12: (with DISCUSS)

From: Ben Campbell <[email-masked]>
Date: Tue, 09 Jan 2018 20:33:07 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-pim-yang-12: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pim-yang/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

[This is a DISCUSS-DISCUSS, since I don't know the answer to my question. I
expect to clear it after a little discussion. Likely at the first indication
that one or another ADs hold the clue that I am missing :-)  ]

Is it reasonable to have a Yang module for an experimental protocol in a
standards track RFC? What would that mean from a protocol maturity perspective?
(I refer to the module for dense-mode PIM (RFC 3973).

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 10 Jan 2018 00:05:37 -0800

On January 10, 2018 at 12:33:07 PM, Ben Campbell ([email-masked]) wrote:

Ben:

Hi!

Is it reasonable to have a Yang module for an experimental protocol in a
standards track RFC? What would that mean from a protocol maturity
perspective?
(I refer to the module for dense-mode PIM (RFC 3973).

Hmm… Good question!

I won’t claim to have the authoritative answer, but let me point to
precedence: rfc5060 (Protocol Independent Multicast MIB) is also a
Standards Track document which contains the MIB for PIM-DM, as well as SM,
etc., just like the YANG document does.

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 10 Jan 2018 00:17:55 -0800

Hi!

Thinking about it a little more…

In general, it is ok to have a standard track document refer to (and build
on) an experimental one…as long as there are no issues with the downref.  I
don’t think that it then implies any changes to the protocol maturity level.

Both rfc5060 and this document called out rfc3973 as a DownRef and there
were no objections during the IETF Last Call. PIM-DM is not the state of
the art in terms of multicast, but it is still used in some deployments so
it is important to have a YANG model.  Because of the rfc5060 precedence, I
think it’s ok to bundle the model in this document with the others.

Alvaro.

On January 10, 2018 at 4:05:37 PM, Alvaro Retana ([email-masked])
wrote:

Ben:

Hi!

Hmm… Good question!

Alvaro.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 10 Jan 2018 15:05:03 +0100

Hi,
> On January 10, 2018 at 12:33:07 PM, Ben Campbell ([email-masked] 
> <mailto:[email-masked]>) wrote:
>
> Ben:
>
> Hi!
>
> Standards Track document which contains the MIB for PIM-DM, as well as 
> SM, etc., just like the YANG document does.
I asked Dan Romascanu if there is a rule regarding MIB modules. His 
replay: "I do not believe (or remember) that there is any rule on this 
respect."

Now, wrt the solution, I wonder what would be the added value to flag 
the YANG module as Experimental.
In the world of automation, operators will not pay attention to it. 
Either the protocol is deployed and we need the YANG module, or it's not 
and it doesn't matter.
So I doubt that someone would update the RFC to go to Standard Track in 
the future ... unless there is something broken in the YANG module or 
it's not compliant with the new Standard Track protocol.

On the other end, I see 
https://datatracker.ietf.org/doc/draft-ietf-lisp-yang/

Regards, Benoit

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 10:11:27 -0600

> On Jan 10, 2018, at 2:17 AM, Alvaro Retana <[email-masked]> wrote:
> 
> Hi!
> 
> In general, it is ok to have a standard track document refer to (and build on) an experimental one…as long as there are no issues with the downref.  I don’t think that it then implies any changes to the protocol maturity level.

I agree that it’s sometimes okay, but it depends on context. In this particular context, we end up with a standard track Yang module for an experimental protocol. That seems odd to me. I don’t know if it’s a problem, but I’m not sure that it’s not. I think that’s worth some discussion.  That all being said, see my next comment…
> 
> Both rfc5060 and this document called out rfc3973 as a DownRef and there were no objections during the IETF Last Call. PIM-DM is not the state of the art in terms of multicast, but it is still used in some deployments so it is important to have a YANG model.  Because of the rfc5060 precedence, I think it’s ok to bundle the model in this document with the others.

I agree that 5060 gives us precedent to use this particular experimental dependency in exactly the same context as in this particular draft. I cleared my DISCUSS, and don’t plan to hold this particular document hostage to the aforementioned discussion.

Thanks!

Ben.

> 
> Alvaro.
> 
> On January 10, 2018 at 4:05:37 PM, Alvaro Retana ([email-masked]) wrote:
> 
>> I won’t claim to have the authoritative answer, but let me point to precedence: rfc5060 (Protocol Independent Multicast MIB) is also a Standards Track document which contains the MIB for PIM-DM, as well as SM, etc., just like the YANG document does.
>> 
>> Alvaro.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 10:14:39 -0600

> On Jan 10, 2018, at 8:05 AM, Benoit Claise <[email-masked]> wrote:
> 
> Hi,
> I asked Dan Romascanu if there is a rule regarding MIB modules. His replay: "I do not believe (or remember) that there is any rule on this respect."
> 
> Now, wrt the solution, I wonder what would be the added value to flag the YANG module as Experimental.
> In the world of automation, operators will not pay attention to it. Either the protocol is deployed and we need the YANG module, or it's not and it doesn't matter.

I think we can generalize that statement to any reference to an experimental protocol, whether it involves YANG or not :-) But in any case, it would not make sense to flag this draft as experimental, since it also includes YANG modules for standards track protocols.

> So I doubt that someone would update the RFC to go to Standard Track in the future ... unless there is something broken in the YANG module or it's not compliant with the new Standard Track protocol.
> 
> On the other end, I see https://datatracker.ietf.org/doc/draft-ietf-lisp-yang/
> 
> Regards, Benoit
>> 
>> Alvaro.
> 
>

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 14:54:29 -0600

> On Jan 10, 2018, at 2:05 AM, Alvaro Retana <[email-masked]> wrote:
> 

That point alone is enough for me to clear. We’ve normatively referenced that same experimental RFC in exactly the same context.

I think my “what does this mean” question still stands in the general case, so I will demote it to a comment.

Thanks!

Ben.

---

From: Warren Kumari <[email-masked]>
Date: Wed, 10 Jan 2018 18:02:19 -0500

> don’t think that it then implies any changes to the protocol maturity level.

I agree with Alvaro (and others!) -- I think having a Standards Track
MIB / YANG module / similar for an experimental protocol is somewhere
between perfectly fine and good.
Regardless of if the experiment passes or fails I'd like to have a
standard way of managing it -- even if an experiment "fails" in the
general sense, I may have deployed it in my own network, and may
continue running it for many years...

W

> were no objections during the IETF Last Call. PIM-DM is not the state of the
> art in terms of multicast, but it is still used in some deployments so it is
> important to have a YANG model.  Because of the rfc5060 precedence, I think
> it’s ok to bundle the model in this document with the others.
>
> Alvaro.
>
> precedence: rfc5060 (Protocol Independent Multicast MIB) is also a Standards
> Track document which contains the MIB for PIM-DM, as well as SM, etc., just
> like the YANG document does.
>
> Alvaro.

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf