Subject: Re: [pim] WGLC for draft-ietf-pim-msdp-yang-04

From: <[email-masked]>
Date: Wed, 5 Sep 2018 09:07:31 +0800 (CST)

Support as co-author.

IMO it is ready for publication. 

Please review it and tell us  if you have some suggestions.

Thanks!

Sandy

原始邮件

发件人：StigVenaas <[email-masked]>
收件人：[email-masked] <[email-masked]>
日 期 ：2018年08月28日 07:55
主 题 ：[pim] WGLC for draft-ietf-pim-msdp-yang-04

Hi

This is the second WGLC for this document. There was no feedback
during the first last call in February, but the document has been
revised and improved since then. Mike and I believe it is time for
another last call.

Please respond by September 10th whether you believe it is ready for
publication, and what issues you may have with the document.

Thanks,
Stig

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Holland, Jake" <[email-masked]>
Date: Wed, 5 Sep 2018 03:49:08 +0000

Hi Sandy,

Thanks for working on this. I read through it, and I saw a few points I thought I should mention.

1.
I noticed that this is Standards Track, but it has normative references to MSDP (RFC 3168), which is Experimental.

I remember seeing in https://tools.ietf.org/html/rfc4611#section-1.1 that a variance was required for a similar downref.

If I understand the process in https://tools.ietf.org/html/rfc2026#section-9.1 correctly, we'd either need this document to be Experimental instead of Standards Track, or we'd need to justify a similar variance.

So I suggest making this doc Experimental.

2.
I noticed the filter acls were strings, but there's no definition of the format or meaning of the strings, that I saw.

Maybe the filters should use the acl-base type from https://tools.ietf.org/html/draft-ietf-netmod-acl-model-19#section-4.1 ?

Either that or define the semantics of the strings in the acls, and how they filter.

3.
I also saw a few nits:
- section 6 is just: " No notification is defined in this model."
Maybe it's better to remove the section?

- section 3 I think there's a grammar error. Suggestion:
OLD:
The filter features allow operators to avoid some SA information be forwarded to some peers.
NEW:
The filter features selectively allow operators to prevent SA information from being forwarded to peers.

- section 5 I think there's a missing word. Suggestion:
OLD:
The part is used to define some useful and ordinary operations
NEW:
The RPC part is used to define some useful and ordinary operations

I have no other objections, I think it looks ok overall, as far as I can tell.

Kind regards,
Jake

On 2018-08-27, 16:54, "Stig Venaas" <[email-masked]> wrote:

    Hi

    
    Thanks,
    Stig

---

From: Stig Venaas <[email-masked]>
Date: Fri, 21 Sep 2018 17:45:37 -0700

Hi

I wish we had more responses to the WGLC. The WG members need to
participate more. However, with authors from several vendors, reviews
by YANG doctor, Jake and I, I think we can say that it passed this
second WGLC. Please address Jake's comments and then we can request
publication.

Stig