Subject: Re: Scale (and the SRV record)

From: Michael Helm <[email-masked]>
Date: Fri, 30 Oct 1998 09:49:30 -0800

"Tolga Acar" writes:
> >up for an attack based on a single (or small integer number) point 
> >of failure?  For example maybe I could trick you into using 

> Violation of integrity on the victim's side.
> if you ruin the baseline (integrity), and expect to be secure. can't do it.
> besides, this will hurt that particular victim, not others.

...
> insecurity is coming from the lack of integrity, so called "less reliable".
> you have to have them both: security and integrity. If one is missing, you can't have the other.

Arguments made in this vein seem convincing to me -- convincing
that you need signed operations & a very hi standard of integrity,
as put here, in the services that provide portions of the pki, even if it 
seems unnecessary from a theoretical point of view.  You never 
can tell what a security breach will escalate into, & the 
secureness or integrity of the potential victims is almost always
very questionable given the large number of variables (software,
protocol vulnerabilities, social engineering) that most of us
potential victims are subject to.

---

From: Bruce Greenblatt <[email-masked]>
Date: Fri, 30 Oct 1998 13:31:02 -0800

At 09:49 AM 10/30/98 -0800, Michael Helm wrote:
[snip]
>that you need signed operations & a very hi standard of integrity,
[snip]
...
For signed operations, you might want to take a look at the Signed
Operations draft of the LDAP Extensions WG
(http://info.internet.isi.edu:80/0/in-drafts/files/draft-ietf-ldapext-sigops
-03.txt).  Constructive comments are always welcome.  Please post them in
the appropriate mailing list though (i.e. not this one), or privately to
the authors (e.g. me).

Bruce
================================================
Bruce Greenblatt              [email-masked]
http://www.innetix.com/~bruceg
================================================