Subject: A question about X.509 Extensions

From: Sebastiano Di Paola <[email-masked]>
Date: Tue, 29 Aug 2000 17:27:30 +0200

I have a question about X.509 Extension.
I would like to know how they are codified..
What I mean is:
Extensions are defined as:

Extensions  ::=  SEQUENCE SIZE (1..MAX) OF Extension

Extension  ::=  SEQUENCE  {
     extnID      OBJECT IDENTIFIER,
     critical    BOOLEAN DEFAULT FALSE,
     extnValue   OCTET STRING  }

What I would like to know is: if I would like to put in a X.509 Cert the

Extension Authority Key
Identifier defined as:

AuthorityKeyIdentifier ::= SEQUENCE {
      keyIdentifier             [0] KeyIdentifier            OPTIONAL,
      authorityCertIssuer       [1] GeneralNames             OPTIONAL,
      authorityCertSerialNumber [2] CertificateSerialNumber  OPTIONAL }

KeyIdentifier ::= OCTET STRING

If I would like to include all of the fileds
(keyIdentifier,authorityCertIssuer ,authorityCertSerialNumber)
what I have to do to put the Extension in the llist EXTENSIONS which has

OctetString as extn value?
I mean do I have to Der Encode the structure AuthorityKeyIdentifier and
then create an OctetString with the encoded data or what?
The same question can be made for CrlNumber Extension where I have an
int which
should be put into an octet string.
I hope you can help me.
Kind Regards
Marco

---

From: Ambarish Malpani <[email-masked]>
Date: Tue, 29 Aug 2000 22:38:08 -0700

Hi Sebastiano, your analysis is correct (if I understood it
correctly).

To verify that we are both thinking the same thing, you could just
look at the bytes in a standard certificate that has the
extension you want (or some other extension).

Regards,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect                                                650.567.5457
ValiCert, Inc.                                  [email-masked]
339 N. Bernardo Ave.                          http://www.valicert.com
Mountain View, CA 94043

> -----Original Message-----
> From: Sebastiano Di Paola [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 8:28 AM
> To: [email-masked]
> Subject: A question about X.509 Extensions
> 
>