Subject: RE: OCSP and XML

From: Michael Myers <[email-masked]>
Date: Thu, 10 Aug 2000 11:11:59 -0700

Not at this time.

Mike

> -----Original Message-----
> From: Renato Portela [mailto:[email-masked]]
> Sent: Thursday, August 10, 2000 7:17 AM
> To: [email-masked]'
> Subject: OCSP and XML
> 
> 
> The syntax of SCVP is being specified with XML. 
> Is any chance do the same to OCSP?
> 
> Thanks
> Renato Portela
>

---

From: Peter Williams <[email-masked]>
Date: Thu, 10 Aug 2000 13:12:00 -0700

Renato, you can specify an XML-format payload for OCSP
at your leisure and at your will, and be entirely conforming
to the draft standard in using the payload-format options. Talk 
to Ambarish, inside or outside IETF - as Steve directs.

-----Original Message-----
From: Michael Myers [mailto:[email-masked]]
Sent: Thursday, August 10, 2000 11:12 AM
To: Renato Portela; [email-masked]'
Subject: RE: OCSP and XML

Not at this time.

Mike

---

From: "Bob Jueneman" <[email-masked]>
Date: Thu, 10 Aug 2000 14:27:39 -0600

>You don't prefer XML to ASN.1?

I most certainly don't for this purpose, and that has 
nothing whatsoever to do with the language's 
expressive power, efficiency, or whatever.

By now, anyone who is processing directories, certificates,
etc., has already climbed up the ladder of ASN.1 competence.
In our case we wrote our own set of libraries in a very short 
time, and have had no trouble using them.

What I DON'T want to have to do is support two different ways of 
doing the same thing.  It adds to code bloat, significantly increases 
the already too-high testing burden, etc.

In addition, and a more subtle point, is the fact that it is almost 
never possible to exactly translate between two languages --
there is always something in one specification that doesn't quite 
have an exact analog in the other language.

As a result, attempts to translate a specification in one language into 
another will typically fail the first or even the second time, and as
a result the specification becomes ambiguous.

Rewriting, rethinking, and recoding all of the work that has already 
been done would be an enormous undertaking, and certainly not
worth doing.

To quote Winston Churchill in a different context,
"That is the sort of nonsense up with which I shall not put."

Bob

Robert R. Jueneman
Consultant Engineer, PKI/Security Architect

Novell, Inc. -- the leading provider of Net services software
1800 South Novell Place
Provo, UT 84606
www.novell.com

[email-masked]
1-801-861-7387

DISCLAIMER:
  If this message (with or without attached documents) is digitally signed, and/or if certificates are attached, the intended purpose is to 
   (1) Ensure that e-mail came from the apparent sender
   (2) Protect e-mail from tampering
   (3) Ensure that the content of e-mail sent to me and encrypted in  my dual-use key cannot be viewed by others.
  It is explicitly NOT the intent of any such signed message or document to represent any type or form of legally binding contract or other representation, and any such interpretation should not be considered commercially reasonable and will be repudiated, notwithstanding any wording or implications to the opposite effect in the text of the message itself.