Subject: RE: CRL number in CRL and ARL

From: Sharon Boeyen <[email-masked]>
Date: Fri, 11 Aug 2000 08:56:54 -0400

An additional point on the numbering of CRLs. In the 2000 edition of 
X.509, additional flexibility for CRLs was added. For example, a status 
referrals extension can indicate that an authority has changed its 
partitioning scheme, indirect delta CRL streams were added etc. To help 
reduce confusion over the CRL numbering, the new cRLStreamIdentifier 
extension was added. This new extension basically identifies a context 
(e.g. full crls, CRL DPs, delta for a given CRLDP,indirect delta for a 
given scope, etc) within which the cRLNumber must be unique. This 
is defined in 8.5.2.7 of the 2000 text of 509:

ftp://ftp.bull.com/pub/OSIdirectory/4thEditionTexts/

Sharon 

> -----Original Message-----
> From: Ambarish Malpani [mailto:[email-masked]]
> Sent: Thursday, August 10, 2000 7:33 PM
> To: 'TAKIGUCHI Naruhito'; [email-masked]
> Subject: RE: CRL number in CRL and ARL
> 
> 
> 
> That is perfectly legal.
> 
> Regards,
> Ambarish
> 
> ---------------------------------------------------------------------
> Ambarish Malpani
> Architect                                                650.567.5457
> ValiCert, Inc.                                  [email-masked]
> 339 N. Bernardo Ave.                          http://www.valicert.com
> Mountain View, CA 94043
> 
> 
> > -----Original Message-----
> > From: TAKIGUCHI Naruhito [mailto:[email-masked]]
> > Sent: Thursday, August 10, 2000 4:52 AM
> > To: [email-masked]
> > Subject: Re: CRL number in CRL and ARL
> > 
> > 
> > Ambarish,
> > 
> > > If you are using CRLDPs, the numbering for each DP is independent.
> > > 
> > > It is okay to number them in the following way:
> > > 
> > > Time                DP1                     DP2
> > > 1                    10                      5
> > > 2                    12                      17
> > > 3                    15                      18
> > > 4                    99                     201
> > > 5                   202                     202
> > > 
> > > Or any other interesting scheme you would prefer, as long as
> > > the numbers for DP1 are monotonically increasing and the
> > > numbers for DP2 are monotoncally increasing.
> > > 
> > > Note: This example is *not* meant to imply that you even need to
> > > issue both DPs at all the times specified.
> > 
> > Thank you very much.
> > I see that the CRL number is a monotonically increasing
> > number for each CRL scope.
> > 
> > But, in your example, the CRL number is not a sequence number.
> > Is this right?
> > 
> > -----
> > Naruhito TAKIGUCHI
> > FUJITSU HOKURIKU SYSTEMS LTD.
> > 
> > 
>

---

From: TAKIGUCHI Naruhito <[email-masked]>
Date: Sat, 12 Aug 2000 15:03:49 +0900

Ambarish, Sharon, 

Thank you very much.
I could understand clearly about the numbering of CRL.

-----
Naruhito TAKIGUCHI