Subject: Re: Company OIDs for free for PIs?

From: "David P. Kemp" <[email-masked]>
Date: Tue, 1 Aug 2000 12:33:32 -0400 (EDT)

Bob,

Have you considered using Private Enterprise codes
(http://www.isi.edu/in-notes/iana/assignments/enterprise-numbers)?

True, the arc 2.6.7.11 is a little shorter than the IETF's 1.3.6.1.4.1,
but that shouldn't be a big deal.  They're both free.

Dave

> Date: Tue, 01 Aug 2000 10:13:57 -0400
> To: [email-masked]
> From: Robert Moskowitz <[email-masked]>
> Subject: Company OIDs for free for PIs?
> 
> I have often thought about how little companies can get OIDs for 
> free.  After all, a few thousand bills for a small company can be a lot of 
> money...
> 
> What I have seen is every company can have an EDI identifier.  X.435 
> (EDIFACT) has defined over 300 EDI identifier namespaces (DUNS being the 
> most common, supposedly).
> 
> I **THINK** this is the EDIFACT UNB IdentificationCode
> 
> X.435 has its own arc:  2.6.7.11
> 
> If we can get the EDI arc registered this way (probably is and only 
> documented in X.435), the PRESTO!  Any company that has an EDI  identifier 
> has an OID arc.
> 
> Can anyone fill in the missing parts of this and then perhaps Denis can add 
> this as a recommendation for company PIs.
> 
> Robert Moskowitz
> ICSA
> Security Interest EMail: [email-masked]
> 
> 
> 
> *****************************************************************************
> This confirms that this email message has been swept by
> MIMEsweeper for the presence of computer viruses.
> ******************************************************************************

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 01 Aug 2000 13:00:31 -0400

>(http://www.isi.edu/in-notes/iana/assignments/enterprise-numbers)?

Actually,  I have.  I got one for the AIAG (Automotive Industry Action 
Group) a couple of years ago  :)

>but that shouldn't be a big deal.  They're both free.

We would need to educate small businesses and IANA would have to get ready 
for a flood of 10Ks of company requests.

My little DBA, HTT Consulting, already has a DUNs #.  Once I know  how this 
arc would work (eg 2.6.7.11.4.5), I would then have a defacto arc.

In Europe, WIPO assigns company #s, they have over 25000 such companies 
registered already.  Again, instant arc.

Robert Moskowitz
ICSA