Subject: RE: TSP. Version 10, Removal of SIA Extension

From: Michael Zolotarev <[email-masked]>
Date: Fri, 20 Oct 2000 08:14:26 +1000

Sounds like its time to get SIA back to TSS draft, Denis :)

> -----Original Message-----
> From: Russ Housley [mailto:[email-masked]]
> Sent: Friday, 20 October 2000 6:26
> To: Denis Pinkas
> Cc: [email-masked]
> Subject: Re: TSP. Version 10, Removal of SIA Extension
> 
> 
> Tim and I have already started the addition of 
> subjectInfoAccess in the 
> next son-of-RFC2459 draft.  I assigned the OID for it 
> yesterday.  I posted 
> it to the IMC Web site earlier today.
> 
> Russ
> 
> At 05:15 PM 10/19/2000 +0200, Denis Pinkas wrote:
> >Francois,
> >
> > > Hi Denis,
> > >
> > > I just noticed that in the latest draft you completely 
> remove from Section
> > > 2.3 the text about a TSA's certificate possibly 
> containing a Subject
> > > Information Access (SIA) extension. From the many 
> comments received during
> > > last call against the previous draft, I did not recall 
> anyone asking for
> > > the SIA extension to be removed.
> > >
> > > Did I miss anything or is there a particular reason why 
> the SIA extension
> > > was removed?
> >
> >You read the draft very carefully, congratulations !
> >
> >I forgot to mention this point. At the Barcelona ISSE 
> meeting, I had a
> >discussion with Stephen Kent about the progression of this 
> draft to RFC. We
> >came to the conclusion that this draft should not be delayed 
> any longer.
> >Since the SIA extension is not defined in RFC 2459, we would 
> have had to
> >wait until "son-of-RFC 2459" is published. However, we did 
> not wanted to
> >hold the draft until "son-of-RFC 2459" got its own RFC number.
> >
> >Since the SIA was not mandatory to implement, it has been 
> suppressed. We now
> >have two options:
> >
> >1) either to re-incorporate it when the TSP Proposed 
> Standard will move to
> >Standard,
> >2) or define this extension directly in "son-of-RFC 2459" 
> (Tim can you hear
> >me ???)
> >
> >Regards,
> >
> >Denis
> >
> > > Regards,
> > >
> > > Francois
> > > ___________________________________
> > > Francois Rousseau
> > > Director of Standards and Conformance
> > > Chrysalis-ITS
> > > 1688 Woodward Drive
> > > Ottawa, Ontario, CANADA, K2C 3R7
> > > [email-masked]      Tel. (613) 723-5076 ext. 419
> > > http://www.chrysalis-its.com     Fax. (613) 723-5078
>

---

From: Denis Pinkas <[email-masked]>
Date: Mon, 23 Oct 2000 18:35:43 +0200

Michael,

> Sounds like its time to get SIA back to TSS draft, Denis :)

"son-of-RFC2459" has not yet passed WG last call, nor IESG last call.
Waiting for it would create a delay that could be estimated to be, at best,
about two months and thus would mean issuing the TSP RFC next year. :-(

We now need this long-awaited RFC. 

Denis

Note: I have just posted to the web editor an update (version 11) that
incorporates the changes that have been noticed (plus one, un-noticed in the
ASN1 module !)