Subject: Re: XML ACs Was Re: Objections to advancing the attribute certificate authentication draft

From: "Anders Rundgren" <[email-masked]>
Date: Mon, 16 Oct 2000 14:53:31 +0200

David,

> <chuckle>
> 
>I've heard some good arguments for using XML in various contexts, but
>"rigor of schema definition" has never been one of them!

Rigor or rigor.  The thing with XML schemas is that they have a "unique" name that the actual
documents must also contain.  Which a parser can use to automatically verify that
received documents follows the schema definition.  Or a sender can verify that it is sending
a proper document.  There is AFAIK no corresponding feature in X509 certificates
or EDI.  And for clearances and authorizations you'd better understand the message
or reject it.

Using XML, an AC draft specification would not have to define a single attribute or attribute syntax!
Just the container document and its signature part.  The attribute schema may be more or less strict
but that is up to the each AC application implementer to define.

That is indeed something to "chuckle" about compared to having in advance know
("guess" I would say),  how roles, clearances etc. could or should be cast in a digital format!

Anders

---

From: Michael Ströder <[email-masked]>
Date: Mon, 16 Oct 2000 15:24:38 +0200

Anders Rundgren wrote:
> 
> Using XML, an AC draft specification would not have to
> define a single attribute or attribute syntax!

Well, you would have to define a commonly used XML name space to let
different applications from different vendors work together. Same
thing as the ASN.1 type definitions used now.

Ciao, Michael.