Subject: R: R: TSP: Response to the comments raised by Russ Housley

From: Santoni Adriano <[email-masked]>
Date: Mon, 9 Oct 2000 15:02:40 +0200

You are right; I made a mistake. The response is not just a CMS msg, so the
"P7M" extensions would not do.

How about "TSR" for the request and "TST" for the response?

A

-----Messaggio originale-----
Da: Peter Sylvester [mailto:[email-masked]]
Inviato: lunedì 9 ottobre 2000 10.47
A: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Oggetto: Re: R: TSP: Response to the comments raised by Russ Housley

> 
> Is it really useful to tell apart requests vs. responses? From the TSP
> server viewpoint, an incoming message is supposed to be a request and it
> will be processed based on that obvious assumption. So the single
> content-type "application/timestamp" should suffice, IMO. As to file
> extensions, I think it's pretty irrilevant; however, as the response is a
> CMS SignedData message, I presume ".P7M" would be a proper file extension
> for it. As to the request...I do not know; why not ".TSR" ?

The response is NOT a CMS signeddata. The time stamp token, which
is embedded in the response is a CMS signeddata.

---

From: Peter Sylvester <[email-masked]>
Date: Mon, 9 Oct 2000 15:19:33 +0200 (MET DST)

> 
> You are right; I made a mistake. The response is not just a CMS msg, so =
> the

TST seems to indicate a 'time stamp token'. Since the response is
not a time stamp token, this would be even more misleading.