Subject: ASN.1 DER parser/compiler

From: "Robert T. Bell" <[email-masked]>
Date: Wed, 28 Mar 2001 11:13:39 -0700

Is there a good ASN.1 DER parser tool and also a good compiler available
somewhere? Could someone provide me with a pointer to them?

Thanks ---- Bob Bell

Bob Bell
Cisco Systems, Inc.
576 S. Brentwood Ln.
Bountiful, Utah 84010
801-294-3034 (v)
801-204-3023 (f)
801-971-4200 (cell)
[email-masked] <mailto:[email-masked]>  (email)

---

From: "Jonathan Jenkyn" <[email-masked]>
Date: Wed, 28 Mar 2001 20:38:25 +0100

Bob,

	As far as parsing goes the best known free tool is P.Gutmann's dumpasn1.
This can be found at his website (http://www.cs.aukuni.ac.nz/~pgut001/)

	Compilation can be done through several different tools:
	* snacc - freeware ASN.1 to C/C++ compiler
http://www.idiom.com/free-compilers/TOOL/ASN1-1.html - I believe this only
deals with BER rather than DER compilation
	* cryptlib - shareware crypto library for C++ written by P.Gutmann
http://www.cs.auckland.ac.nz/~pgut001/cryptlib/ - specifically adheres to
X.692 (DER encoding)

	Other ASN.1 compilers exist, but most of them you have to buy. If you are
still interested, ONE (http://www.one.com/products/a_1_t.html) make a good
one, as do OSS (http://www.oss.com/products/asn1cpp/tools_cpp.html)

	The location of many other ASN tools can be found here
:http://www-sop.inria.fr/rodeo/personnel/hoschka/asn1.html

	Hope this is of some help

	Regards

	Jonathan Jenkyn

Jonathan Jenkyn
Head of Cryptographic Systems
De La Rue InterClear
UK
+44(0)7957568126
[email-masked]
www.interclear.com

-----Original Message-----
From: Robert T. Bell [mailto:[email-masked]]
Sent: 28 March 2001 19:14
To: PKIX-MailList (E-mail)
Subject: ASN.1 DER parser/compiler

Thanks ---- Bob Bell

Bob Bell
Cisco Systems, Inc.
576 S. Brentwood Ln.
Bountiful, Utah 84010
801-294-3034 (v)
801-204-3023 (f)
801-971-4200 (cell)

---

From: Jeff Jacoby <[email-masked]>
Date: Thu, 29 Mar 2001 10:37:35 -0800

> This can be found at his website (http://www.cs.aukuni.ac.nz/~pgut001/)

I've also found that the GUI parser on IMC's SecureConnect 2 web page to
be quite nice (Windows only, though).  Two features I've found very
useful are recursive decoding of BIT STRINGs and OCTET STRINGs, and the 
ability to save a sub-component to its own file.

The page is at:  http://www.imc.org/imc-secureconnect/

Scroll down to the very bottom of the page.  

Jeff