Subject: Question about ECDSA.

From: 김 충길 <[email-masked]>
Date: Thu, 23 Aug 2001 18:39:13 +0900

I can't found ECDSA PriveKey OID.
There is no information about it in X9.62 and your draft-ietf-pkix-ipki-
pkalgs-03.txt.

I want to know ECDSA PrivateKey ASN.1 syntax, OID and
PrivateKeyAlgorithms OID.
where can I that information?

Thanks.

---

From: "Housley, Russ" <[email-masked]>
Date: Thu, 23 Aug 2001 10:22:27 -0400

The ANSI X9 and PKIX documents have never included specifications for 
private key syntax.

Perhaps Certicom can offer a recommended syntax.

Russ

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 27 Aug 2001 12:06:49 -0700

I had to look, but it appears that RFC2511bis does not do this even
though I might have expected it to.  There are now some private key
items put into the CMC-Archive document but I don't currently have any
EC private keys documented there.

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Housley, Russ
> Sent: Thursday, August 23, 2001 7:22 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Question about ECDSA.
> 
> 
>

---

From: Olivier Dubuisson <[email-masked]>
Date: Sun, 26 Aug 2001 08:55:42 +0000

> where can I that information?

I take this opportunity to keep you informed that an OID repository is
available on the ASN.1 website at http://asn1.elibel.tm.fr/oid/
Use the search engine of the website to check if some information
available concerning ECDSA.

We are in a process to redesign it and also to merge the data with those
of Harald Alvestrand's repository <http://www.alvestrand.no/objectid>.
In the October 2001 timeframe a lot more information should be available
regarding OIDs.
-- 
Olivier DUBUISSON
france telecom R&D
     _                 DTL/MSV - 22307 Lannion Cedex - France
    ( )           tel: +33 2 96 05 38 50 - fax: +33 2 96 05 39 45
    / \/               --------------------------------------
    \_/\               Site ASN.1 : http://asn1.elibel.tm.fr/