Subject: Re: New test TSA available

From: Peter Sylvester <[email-masked]>
Date: Tue, 21 Aug 2001 13:41:55 +0200 (MET DST)

> ::content type::
> 
>  (A) draft-ietf-pkix-time-stamp-15 states that eContentType for a time
>      stamping token should be id-ct-TSTInfo why is it instead set to
>      id-data ?
> 
>  since the encapsulated content type is set to id-data, version
>  field in SignedData is (`correctly' since (A)) set to 1 and not to 3

version 3 seems correct for another reason:
From CMS:

      version is the syntax version number.  If the SignerIdentifier is
      the CHOICE issuerAndSerialNumber, then the version shall be 1.  If
      the SignerIdentifier is subjectKeyIdentifier, then the version
      shall be 3.

151 31  119:         SET {
 153 30  117:           SEQUENCE {
 155 02    1:             INTEGER 3
 158 80   20:             [0]
            :               6F 68 B0 B9 90 36 9F 63 4E 96 45 BE A4 9B E7 E3
            :               64 38 B9 55

      SignerInfo ::= SEQUENCE {
        version CMSVersion,
        sid SignerIdentifier,

      SignerIdentifier ::= CHOICE {
        issuerAndSerialNumber IssuerAndSerialNumber,
        subjectKeyIdentifier [0] SubjectKeyIdentifier }

---

From: tho <[email-masked]>
Date: Tue, 21 Aug 2001 14:23:22 +0200

hello peter(s),

there is another point which i've missed in the previous mail that is 
concerned with the TSA certificate: it should contain one (and sole)
extended key usage field with value id-kp-timeStamping so that the only
keyUsage set to nonRepudiation is not enough...

i'm growing more and more pedantic, excuse me :)

tho
-- 
(__)         
(oo)        
 \/-------\
  ||     | \  
  ||---W||  *