Subject: Re: signed e-mail

From: "Bob Jueneman" <[email-masked]>
Date: Fri, 09 Nov 2001 14:14:01 -0700

Well, in part because most of the TTP CA's software is rather far behind the current standards and S/MIME implementations, and that causes some aggravating user interface problems.

Your Equifax certificate, for example, does not contain a CRLDistributionPoint, so I have no way of verifying whether your certificate is still valid.  In addition, it doesn't have the keyUsage field flagged as critical, so I get a warning that it is not V3 compliant as well. 

Your own certificate confirms that you are Rob G Weemhoff, AKA [email-masked], but it also says, as part of your subject name, that you are OID.0.9.2342.19200300.100.1.1=093252788.  And since I don't recognize that OID, I don't know whether that means that I should give you the secret handshake the next time we meet, or simply shoot you when you show up.  Or maybe that's your robot ID, or your rabies vaccination tag number -- who knows!

So I get a big splash screen full of warnings that I then have to ignore to read what you said.  And even though your certificate presumably confirms that your identity is indeed Rob Weemhoff, that in itself doesn't convey any useful information to me the first time around, since I don't know Rob Weemhoff from Adam.

But it did turn a 413 byte message into a 7138 byte MIME-encoded message, which has to be transported and stored until I decide to purge it.

In short, no value was added when communicating with strangers, except that I know that the mail gateway didn't mangle your message.  

In addition, if I were to digitally sign my mail, then I would feel compelled to add a fairly lengthy paragraph of legal disclaimers to protect myself against the possibility that my utterances might be construed to be legally binding under the laws of the Nether Antilles or elsewhere.

Having said all of that, I DO routinely use signed and/or encrypted mail when there is some purpose for doing so.

Robert R. Jueneman
Security Architect

Novell, Inc -- the leading provider of Net services software

>>> "Rob G Weemhoff" <[email-masked]> 11/09/01 10:34AM >>>
To start with, why are we, as security advocates, not all using signed 
e-mail?

----
Regards,
Ing. Rob G. WEEMHOFF 
Senior Consulting IT-Architect 
IBM Security and Privacy Services (EMEA)
Tel:        +31(0)20 513  9102 
Mobile: +31(0)653263269

E-mail: [email-masked] 
Fax: +31(0)33 2470578
Computerweg 8
3821 AB  Amersfoort
The Netherlands

http://www.ibm.com/security 
See you at AIM (RobGWeemhoff)

---

From: "Khaja E. Ahmed" <[email-masked]>
Date: Sun, 11 Nov 2001 10:18:52 -0800

Unless I have misunderstood, Bob is saying that we do not use signed email
on this list because:

1.) Benefit.  It adds too little value in the instance being discussed. The
infrastructures is not quite there yet so proper and complete path
validation not always possible.  The certificates are not interoperable
enough in practice. There is frequently no way of checking revocation
status.
2.) Cost.  It has not crossed the threshold of being easy enough to use all
the time, even by the judgment of security experts.

I happen to agree with this view for signed email on this list.

What worries me however is that in discussions with senior management and
CIOs of 4 B2B exchanges (2 of them big name) this argument was applied to
signed transactions that are valued at $1M average. Surprisingly, even the
point that Adam Perez makes about being able to recognize "implicitly" who
wrote the email was applied to purchase orders and reverse auctions.
Apparently they have a "pattern".  Unless application developers make it
easier to use PKI, and unless CAs address the interoperability problem, PKI
adoption will remain weak.  Most application vendors seem to claim that is
too hard to develop compliant applications and most CAs seem to say there is
perfect interoperability - if everyone uses my certificates.  ...and that's
the stalemate the market's been in for at least the last couple of years.  I
would love to hear that this is not true or that we are breaking out of this
stalemate.  For now this is what I believe the situation to be.

Khaja

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Bob Jueneman
> Sent: Friday, November 09, 2001 1:14 PM
> To: [email-masked]; [email-masked]
> Subject: Re: signed e-mail
>
>
> Well, in part because most of the TTP CA's software is rather far
> behind the current standards and S/MIME implementations, and that
> causes some aggravating user interface problems.
>
> Your Equifax certificate, for example, does not contain a
> CRLDistributionPoint, so I have no way of verifying whether your
> certificate is still valid.  In addition, it doesn't have the
> keyUsage field flagged as critical, so I get a warning that it is
> not V3 compliant as well.
>
> Your own certificate confirms that you are Rob G Weemhoff, AKA
> [email-masked], but it also says, as part of your
> subject name, that you are
> OID.0.9.2342.19200300.100.1.1=093252788.  And since I don't
> recognize that OID, I don't know whether that means that I should
> give you the secret handshake the next time we meet, or simply
> shoot you when you show up.  Or maybe that's your robot ID, or
> your rabies vaccination tag number -- who knows!
>
> So I get a big splash screen full of warnings that I then have to
> ignore to read what you said.  And even though your certificate
> presumably confirms that your identity is indeed Rob Weemhoff,
> that in itself doesn't convey any useful information to me the
> first time around, since I don't know Rob Weemhoff from Adam.
>
> But it did turn a 413 byte message into a 7138 byte MIME-encoded
> message, which has to be transported and stored until I decide to
> purge it.
>
> In short, no value was added when communicating with strangers,
> except that I know that the mail gateway didn't mangle your message.
>
> In addition, if I were to digitally sign my mail, then I would
> feel compelled to add a fairly lengthy paragraph of legal
> disclaimers to protect myself against the possibility that my
> utterances might be construed to be legally binding under the
> laws of the Nether Antilles or elsewhere.
>
> Having said all of that, I DO routinely use signed and/or
> encrypted mail when there is some purpose for doing so.
>
> Robert R. Jueneman
> Security Architect
>

---

From: Michael Ströder <[email-masked]>
Date: Mon, 12 Nov 2001 11:00:46 +0100

> wrote the email was applied to purchase orders and reverse auctions.

It's just a matter of risk managment. It's up to the application
owner to decide if he wants to live with that risk or not. In most
cases there is in fact a human being processing the transaction and
validating the request. Especially when it comes to the $1M range.

Ciao, Michael.