Subject: RE: TSA messages for http ?

From: Cristian Marinescu <[email-masked]>
Date: Mon, 12 Nov 2001 09:50:42 +0100

Hello!

I am having the same problem. We have implemented
a socket-based server and client, and now we are
trying to offer some HTTP support, too. The main problem
is that, behind the WWW server (because I would like to
use IIS and Apache), I would definitively forward the
request to the socket-based TSA. The problem is that
in such cases, if I would configure the servlet to use
another TSA (what is actually quite possible), I would have
to deal with all the socket-based things like polling, negative
reply, etc.

At the moment, in such cases, I return an error, but well,
it is not very correct, from my point of view...
The standard is not suggesting any answer to this question.
What would you do? (And BTW, Todd, please send me your pdf,
I would be interested...)

Any comments are highly appreciated,
Cristian

=====================
Dipl-Ing. Cristian Marinescu
Software Developer
OMICRON electronics GmbH
Oberes Ried 1
A-6833 Klaus
AUSTRIA
Tel. +43-5523-507-113
Fax. +43-5523-507-999
E-Mail: [email-masked]
WWW: www.omicron.at

> -----Original Message-----
> From: S.T. Wong [mailto:[email-masked]]
> Sent: Freitag, 9. November 2001 08:44
> To: [email-masked]
> Subject: TSA messages for http ?
> 
> 
> 
> Hi, there,
> 
> As mentioned in RFC3161, in socket based protocol TCP-based 
> TSA messages,
> which consist of triplet of (length, flag, value), are used 
> to communicate
> between the request initiator and listener.  If functions 
> (like polling 
> requests) are implemented on other protocols (e.g. SMTP, FTP, 
> HTTP, etc), can 
> we simply make use of such TSA message triplets ?    
> 
> Would anyone please advise ?
> Thanks a lot.
> 
> ST Wong
> 
> -- 
> S.T. Wong                               | Email: [email-masked]
>

---

From: "todd glassey" <[email-masked]>
Date: Mon, 12 Nov 2001 05:57:00 -0800

No problem Christian - I'll send it under separate cover. What I wanted to
mention for this effort is that in order for logging or timestamping to be
of real value there will also be a need to prove delivery and receipt of the
material.

This can be accomplished by a comparative logging process wherein messages
are compared after the fact for delivery or content. Otherwise some
circuit-level delivery proofing is necessary or there is no way to rely on
this for an Evidentiary Grade Marque.

Todd

----- Original Message -----
From: "Cristian Marinescu" <[email-masked]>
To: "S.T. Wong" <[email-masked]>; <[email-masked]>
Sent: Monday, November 12, 2001 12:50 AM
Subject: RE: TSA messages for http ?

>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
>
> Hello!
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGPfreeware 6.0.2i
>
> iQA/AwUBO+9/UsV5iyNCxCiSEQJcJwCfdtMVE94zetthhcfjNxNGXzP/7YcAnjve
> PQ0oq+hdiGkQiJ9f/71Qky5m
> =4tbc
> -----END PGP SIGNATURE-----
>