Subject: RE: TSA messages for http ?

From: Cristian Marinescu <[email-masked]>
Date: Tue, 13 Nov 2001 09:37:18 +0100

Hello!

> -----Original Message-----
> From: Peter Sylvester [mailto:[email-masked]]
> Sent: Montag, 12. November 2001 16:42
> To: [email-masked]; [email-masked]; Cristian
> Marinescu
> Subject: RE: TSA messages for http ?
> 
> 
> 
> > another TSA (what is actually quite possible), I would have
> > to deal with all the socket-based things like polling, negative
> > reply, etc.
> > 
> > At the moment, in such cases, I return an error, but well,
> > it is not very correct, from my point of view...
> IMHO the polling feature in the socket transport protocol is
> not a feature of the TSP protocol, if there is a transport
> mapper between HTTP and the socket protocol, then the
> http server would just waitabit and loop if there are responses
> for polling. 
> 

Yes, I agree, but this means that a HTTP solution could be
quite different from a socket-based solution. 
On the other hand, to wait "a little" is no solution.
You know exactly that the pollRep and the partialMsgRep include
a so-called time to check back. So, at least theoretically,
I should wait the specified time (10-20-60 seconds, why not?)
and then try again.
This doesn't sound like a good solution...

<snip>
    pollRep        '01'H    polling reference (32 bits),
                            time-to-check-back (32 bits)
      -- poll response where no TSA message response ready; use
polling
      -- reference value (and estimated time value) for later polling
...
    partialMsgRep  '04'H    next polling reference (32 bits),
                            time-to-check-back (32 bits),
                            DER-encoded TSA message
      -- partial response (receipt) to initial message plus new
polling 
      -- reference (and estimated time value) to use to get next part
of
      -- response
</snip>

Kindly regards,
Cristian

=====================
Dipl-Ing. Cristian Marinescu
Software Developer
OMICRON electronics GmbH
Oberes Ried 1
A-6833 Klaus
AUSTRIA
Tel. +43-5523-507-113
Fax. +43-5523-507-999
E-Mail: [email-masked]
WWW: www.omicron.at

---

From: "todd glassey" <[email-masked]>
Date: Tue, 13 Nov 2001 05:50:01 -0800

Actually before you say it does not sound like a good solution (although I
tend to agree with you) lets build a model where it is used so we can see
the edges of the trust model it provides. Then we will that we will know
what other solutions will be needed to build the guaranteed delivery
middleware, and other audit processes so that its data and process make
sense.

Todd

----- Original Message -----
From: "Cristian Marinescu" <[email-masked]>
To: "Peter Sylvester" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Tuesday, November 13, 2001 12:37 AM
Subject: RE: TSA messages for http ?

>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
> Hello!
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGPfreeware 6.0.2i
>
> iQA/AwUBO/DNrMV5iyNCxCiSEQKGUACfXKivymrLVls39BIoG8AHhAGiusQAoKLY
> 2DwKHlhB67lpx/a59lML/gJg
> =POKI
> -----END PGP SIGNATURE-----