Subject: RE: RFC2253 e-mail address

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 15 Nov 2001 11:33:49 +1100

If the attribute is not *recognised*, then it is not possible to decide if
the value is an RFC 822 address! It is not even possible to decide if the
value represents an ascii string (though, in this case, inspection would
show that it is (or perhaps it is base-64 encoded?))

Therefore, the value is presented in hexadecimal.

Ron.

-----Original Message-----
From: Michael Ströder [mailto:[email-masked]]
Sent: Thursday, 15 November 2001 0:47
To: Anders Rundgren
Cc: [email-masked]
Subject: Re: RFC2253 e-mail address

Anders Rundgren wrote:
> 
> Micheal,
> 2.4:
> 
>    If the AttributeValue is of a type which does not have a string
>    representation defined for it, then it is simply encoded as an
>    octothorpe character ('#' ASCII 35) followed by the hexadecimal
>    representation of each of the bytes of the BER encoding of the X.500
>    AttributeValue.  This form SHOULD be used if the AttributeType is of
>    the dotted-decimal form.
> 
> Hum,
> My colluege still think that the last line says something else!
> i.e. since the e-mail *type* must be represented as dotted decimal
> its value SHOULD be in hex rather than IA5String.  Or is this bad writing?

Might be a good idea to ask on the IETF-LDAPBIS list.

Ciao, Michael.

---

From: Michael Ströder <[email-masked]>
Date: Thu, 15 Nov 2001 01:48:18 +0100

> Therefore, the value is presented in hexadecimal.

Ron, but the attribute value has to be BER-encoded represented in
hex-decimal notation. Which string type is used for the BER-encoding
if your application does not even know the attribute type by OID?

Ciao, Michael.