Subject: TSP interop test (NEC)

From: hisayuki IWANISHI <[email-masked]>
Date: Fri, 08 Mar 2002 18:16:10 +0900

Dear all,

We , NEC tries to access to the test TSAs using our original developed
TSP clients. I report that we got following results with each TSAs.

TSP client
  - sent TimeStampReq and receive timeStampToken
    included in the TimeStampResp
  - decode the timeStampToken
  - verify the value of the messageImprint
  - verify the value of the nonce
  - confirm that the timeStampToken had the policy
  - confirm the timeliness of the time in the timeStampToken
  - sent bad-formatted TemeStampReq and receive
    the badDataFormat error response

We omitted to:
  - verify the signature of the SignaedData(CMS)
  - verify the SignedData(CMS)'s certificate path
    (described in the RFC2459 or its later drafts)
  - verify the extensions of the TSTInfo

We found that there was a TSA which returned normal timeStampToken with
its own policy as a response of TimeStampReq  with inadequate policy. We
excepted the "unacceptedPolicy error response" on this case.

Regards,
Hisayuki

---
Hisayuki IWANISHI
NEC Corporation /
4th Operations Unit, NEC System Technologies, Ltd.
Hiroshima Japan

SERVER                    HTTP          TCP
------------------------+----------+----------+
SIA
host=193.203.230.166        n/s       SUCCESS
port=318
policyid=1.3.135.1.2.0
------------------------+----------+----------+
EdelWeb
url=
http://www.edelweb.fr/    SUCCESS      n/s
cgi-bin/service-tsp
policyid=
1.3.6.1.4.1.5309.1.2.2
------------------------+----------+----------+
CNSG
host=tsp.test.polito.it
port=318                    n/s       SUCCESS
policyid=0.0
------------------------+----------+----------+
C&A
host=195.223.2.6
port=3318
policyid=0.4.0.1.1.1      SUCCESS     SUCCESS
url=
http://195.223.2.6:8080/
timestamp
------------------------+----------+----------+

n/s= Not Supported.

---

From: hisayuki IWANISHI <[email-masked]>
Date: Fri, 08 Mar 2002 18:50:40 +0900

All,

One Correction, on my previous message,

> excepted the "unacceptedPolicy error response" on this case.
We EXPECTED the..

My Apologies

Hisayuki

---
Hisayuki IWANISHI
NEC Corporation /