Subject: OCKID - question about the format

From: "Vesa Suontama" <[email-masked]>
Date: Tue, 19 Mar 2002 16:18:27 -0600

Paul, 

Just one comment about OCKID draft. I think the idea is good: There should be a standard way to represent the hash of the PKI objects. 

However, I do not like the idea of using the base32 conversion in converting the binary to ASCII. Numerous programs already out there just use the hex presentation of the SHA-1 hash. See for example, MS certificate viewer in Windows, Netscape, SSH Sentinel, etc. 

I suggest that the OCKID would also use the plain HEX representation of the SHA-1 hash. This would make the ID's provided by the programs already out there compatible with OCKID. 

The only drawback of this is that you need 24 characters instead of 20 (and probably one for the extra dash). 

E.g the example you provided in the draft would become CC48-7D7A A622-8613-E997 instead of 3TEH-48XG-ELDB-H4NZ. 

The change would also simplify the draft and the implementation. 

What was your motivation for re-inventing the wheel?

Vesa

---
 Vesa Suontama <[email-masked]>     Tel: +358-40-700 0131
                                     Fax: +358-9-8565 7151
 SSH Communications Security Corp    Fredrikinkatu 42
 http://www.ssh.com                  FIN-00100 Helsinki, Finland

---

From: Michael Ströder <[email-masked]>
Date: Fri, 22 Mar 2002 14:07:57 +0100

Vesa Suontama wrote:
 >
 > Just one comment about OCKID draft. I think the idea is good: There
 > should be a standard way to represent the hash of the PKI objects.

I concur.

 > However, I do not like the idea of using the base32 conversion in
 > converting the binary to ASCII. Numerous programs already out there just
 > use the hex presentation of the SHA-1 hash. See for example, MS
 > certificate viewer in Windows, Netscape, SSH Sentinel, etc.
 >
 > I suggest that the OCKID would also use the plain HEX representation of
 > the SHA-1 hash. This would make the ID's provided by the programs
 > already out there compatible with OCKID.

I strongly agree. I would additionally like to provide the MD5 hash of the 
certificates (like Netscape does). Maybe with a prefix describing the hash 
algorithm.

SHA1-CC48-7D7A A622-8613-E997

Ciao, Michael.