Subject: Re: Signer certificate discovery for CRLs

From: Denis Pinkas <[email-masked]>
Date: Wed, 03 Nov 2004 15:45:56 +0100

Santosh,

> X.509 Annex B and 3280 do describe how to deal with various CRLs.

No. I disagree.

X.509 Annex B only states:

"The relying party shall be able to obtain the public key of the issuer 
identified in the CRL using authenticated means;"

but does not say how this is done !

RFC 3280 is also lacking to provide any detail about this.

This is a major deficiency of both X.509 and RFC 3280.

Denis

> -----Original Message-----
> From: Denis Pinkas [mailto:[email-masked]] 
> Sent: Thursday, October 28, 2004 10:01 AM
> To: Santosh Chokhani
> Cc: 'pkix'; David A. Cooper
> Subject: Re: Signer certificate discovery for CRLs
> 
> 
> Santosh,
> 
> See responses in-line in [DP:]
> 
> (text deleted)
> 
> Before accepting AIA as a valid option for CRLs we have to say how and when
> it would be used. The issue is MUCH MORE complicated than simply adding AIA
> in CRLs, since we have to give the processing rules for that extension.
> 
> [SC: The issue is simple and straightforward.  Just the way signed CMS
> permits to carry signer's certificate, AIA in CRL simply points to the
> signer certificate.  You can use that pointer and develop the path whichever
> way you like]
> 
> Upon this aspect, we are far from an agreement and this is of course
> strongly related to the (lack of a) CRL processing model.
> 
> [SC: What specifically do you disagree with and why?  There is a CRL
> processing model.  It is well articulated in X.509 Annex B and well
> summarized in 3280]
> 
> [DP: There is no CRL processing model. It is not summarized in 3280. This is
> a major problem of 3280].
> 
> So we need first to say how we verify that a CRL Issuer is the right CRL
> Issuer (see my e-mail fom this morning to Santosh). Once we will have fixed
> that, then we will be able to explore the advantages and disavantages of
> including or not AIA in CRLs.
> 
> [SC: We have done this in this thread and by the briefing.]
> 
> [DP: No. We still need to say how we verify that a CRL Issuer is the right 
> CRL Issuer]. I fear a myriad of different models.
> 
> Denis
> 
> PS: David, I copied this message to you since you are making a list of 
> issues related to RFC 3280. This is certainly a major one: clarification on 
> CRL processing when the CRL Issuer is not the CA that has issued the 
> certificate is needed.
> 
>  > /Stefan
> 
>

---

From: "Santosh Chokhani" <[email-masked]>
Date: Wed, 3 Nov 2004 10:11:29 -0500

Denis,

See responses in-line in [SC]

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]] 
Sent: Wednesday, November 03, 2004 9:46 AM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: Signer certificate discovery for CRLs

Santosh,

No. I disagree.

[SC: When you look at Annex B of X.509 and 3280 and what we have proposed
here, what is missing in your analysis?]

[SC: US comment along the lines of what has been the consensus on this
thread has been made/included]

[SC: We are recommending the Editor include the consensus in the next round]

Denis

> Before accepting AIA as a valid option for CRLs we have to say how and 
> when it would be used. The issue is MUCH MORE complicated than simply 
> adding AIA in CRLs, since we have to give the processing rules for 
> that extension.
> 
> signer certificate.  You can use that pointer and develop the path 
> whichever way you like]
> 
> [DP: There is no CRL processing model. It is not summarized in 3280. 
> This is a major problem of 3280].
> 
> So we need first to say how we verify that a CRL Issuer is the right 
> CRL Issuer (see my e-mail fom this morning to Santosh). Once we will 
> have fixed that, then we will be able to explore the advantages and 
> disavantages of including or not AIA in CRLs.
>

---

From: Denis Pinkas <[email-masked]>
Date: Thu, 04 Nov 2004 18:41:01 +0100

Santosh,

See responses in-line in [DP: ]

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]]
Sent: Wednesday, November 03, 2004 9:46 AM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: Signer certificate discovery for CRLs

Santosh,

No. I disagree.

[DP: What do you mean by "US comment". There is no such a thing in the IETF 
procedures. Then, "included" in what ?!? ]

[DP: Fine, but there is no text at the present time, so no consensus yet at 
the present time].

Denis

---

From: "Santosh Chokhani" <[email-masked]>
Date: Thu, 4 Nov 2004 15:51:31 -0500

Denis,

See responses in-line.

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]] 
Sent: Thursday, November 04, 2004 12:41 PM
To: Santosh Chokhani
Cc: [email-masked]
Subject: Re: Signer certificate discovery for CRLs

Santosh,

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]]
Sent: Wednesday, November 03, 2004 9:46 AM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: Signer certificate discovery for CRLs

Santosh,

No. I disagree.

[SC: You asked a question of X.509 Annex B and so I responded how we are
fixing X.509.  Everyone knows that IETF does not deal with these things]

[SC: As I said, we have done some thinking and have proposed ideas for 3280
considerations.]

Denis

---

From: Denis Pinkas <[email-masked]>
Date: Fri, 05 Nov 2004 15:23:39 +0100

Santosh,

> [SC: As I said, we have done some thinking and have proposed ideas for 3280

"Ideas" and "thinkings" are not text for 3280bis consideration.

Denis

---

From: "Santosh Chokhani" <[email-masked]>
Date: Fri, 5 Nov 2004 16:08:55 -0500

Denis,

The purpose of this whole thread is to beef up 3280 and X.509 based on what
has been discussed.

Everyone on this list understands that the text does not currently say that
and that is why we had the dialog and that is what the briefing explicitly
recommends.

Also, the briefing proposes specific language and algorithm to achieve this.
If the RFC editor accepts the recommendations, I will be glad to work with
him to revise 3280.

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]] 
Sent: Friday, November 05, 2004 9:24 AM
To: Santosh Chokhani
Cc: [email-masked]
Subject: Re: Signer certificate discovery for CRLs

Santosh,

> [SC: When you look at Annex B of X.509 and 3280 and what we have
> proposed here, what is missing in your analysis?]
> 
> "The relying party shall be able to obtain the public key of the
> issuer identified in the CRL using authenticated means;"
> 
> [SC: You asked a question of X.509 Annex B and so I responded how we
> are fixing X.509.  Everyone knows that IETF does not deal with these 
> things]
> 

> [SC: As I said, we have done some thinking and have proposed ideas for
> 3280 considerations.]

Denis