Subject: Re: several key in same certificate

From: [email-masked]
Date: Wed, 10 Nov 2004 18:19:39 +0100

thank you for your preceding answer

> So, in all seriousness, I will assume that you're really asking about
> public keys that are used for certificate verification, and in that
> case, what you ask is certainly not possible, and it should be
> apparent if you read RFC 3280 or X.509 accurately.
>
I know RFC3280, I thought that perhaps somebody with have the idee of such a
process.

> Now, to get a real discussion going (if you want), why do you want to
> have more than one public key in your certificate?  What would they be
> used for, and most specifically, how would the appropriate key be
> selected for the operation you want to perform?
>
Because currently I have several keys (certificates) for the same entity. Each
certificate allows a particular function (different extendedKeyUsage and KeyUsage)

 I wondered whether the IETF, there a had been a reflexion, to extend a
certificate containing only one identity with several key and of the specific
extensions by keys.

An application could according to Keyusage and ExtendedKeyusage to take the good
key for for example applying a signature.

Thanks
Yannick Quenec'hdu

---

From: [email-masked]
Date: Wed, 10 Nov 2004 18:19:39 +0100

Thanks
Yannick Quenec'hdu