Subject: Re: DVCS ASN.1 module definition error

From: Peter Sylvester <[email-masked]>
Date: Sat, 13 Nov 2004 16:09:57 +0100 (MET)

> 
> Looks like a bug to me.  Peter, can you send the RFC Editor an errata entry.
> 

Yes, it's a bug. There is another bug that didn't find its way into the final text. 

A more or less known know implementation uses the following syntax peiecs.

Data ::= CHOICE {
      message           OCTET STRING ,
      messageImprint    DigestInfo,
      certs             [0] SEQUENCE SIZE (1..MAX) OF TargetEtcChain
}

PathProcInput ::= SEQUENCE {
     acceptablePolicySet          SEQUENCE SIZE (1..MAX) OF PolicyInformation,
     inhibitPolicyMapping         BOOLEAN DEFAULT FALSE,
     explicitPolicyReqd          [0] BOOLEAN DEFAULT FALSE,
     inhibitAnyPolicy            [1] BOOLEAN DEFAULT FALSE
}

> Russ
> 
> At 03:02 AM 11/5/2004, ChungKil Kim wrote:
> 
> >hi there.
> >
> >i found asn.1 definition error.
> >see following definition(rfc3029 Page 15).
> >
> >
> >Data ::= CHOICE {
> >message OCTET STRING ,
> >messageImprint DigestInfo,
> >certs SEQUENCE SIZE (1..MAX) OF
> >TargetEtcChain
> >}
> >
> >DigestInfo ::= SEQUENCE {
> >digestAlgorithm DigestAlgorithmIdentifier,
> >digest Digest
> >}
> >
> >messageImprint and certs have same tag type. it can't be CHOICE. right?
> 
>

---

From: Russ Housley <[email-masked]>
Date: Sat, 13 Nov 2004 13:09:18 -0500

Please send errata to the RFC Editor.

Russ

---

From: Russ Housley <[email-masked]>
Date: Sat, 13 Nov 2004 13:09:18 -0500

Russ