Subject: RE: ExtendedKeyUsage for TLS Client Authentication

From: "Stefan Santesson" <[email-masked]>
Date: Thu, 22 Sep 2005 13:18:34 +0100

Peter,

You may have missed that I made a correction of myself. IE and IIS do
accept certificates with an absent EKU. It enforces and mandates
presence of clientAuth when the EKU extension is present.

On the signing with encryption keys or encrypting with signature keys,
I'll have to come back to you.

I don't think we have any real disagreement on the EKU issue.

Stefan Santesson
Program Manager, Standards Liaison
Windows Security

> -----Original Message-----
> From: pgut001 [mailto:[email-masked]]
> Sent: den 22 september 2005 14:00
> To: [email-masked]; [email-masked];
> [email-masked]; Stefan Santesson
> Subject: RE: ExtendedKeyUsage for TLS Client Authentication
> 
> "Stefan Santesson" <[email-masked]> writes:
> 
> >I think this is misleading advice. At least Microsoft implementations
do
> >enforce both key usage and extended key usage.
> 
> I thought CryptoAPI explicitly allowed signing with encryption-only
keys
> or
> encryption with signing-only keys (I'd have to look up the details of
> which
> one it was)?  I've also had reports from users about it ignoring other
> usage
> restrictions... some of this dates back a few years, so maybe it's
gotten
> better now.  OTOH it was only two years ago that CryptoAPI actually
> started
> bothering to pay attention to the CA flag, and only then because of
> widespread
> bad publicity.
> 
> (The reason why I made the comment was that cryptlib is very careful
about
>  enforcing key usage (and any other) constraints, and the probably
single
>  biggest set of user complaints that I get is from users saying that
certs
>  they've used for ages can't be used with cryptlib.  The result is
> invariably
>  that they're trying to encrypt with a signature-only cert, or
something
>  similar.  Only about two weeks ago I got mail from a PKI application
>  developer to say that cryptlib was the first PKI code he'd ever run
into
> that
>  recognised (and rejected) the use of a CA-cert/CRL-signature-only
cert
> for
>  data encryption).
> Peter.

---

From: "Vahan Sardaryan" <[email-masked]>
Date: Thu, 22 Sep 2005 18:41:23 +0500

From my experience with CryptoAPI, it allows signing with key exchange pair, 
but not encrypting with signing keys.

Vahan

----- Original Message ----- 
From: "Stefan Santesson" <[email-masked]>
To: "pgut001" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Thursday, September 22, 2005 5:18 PM
Subject: RE: ExtendedKeyUsage for TLS Client Authentication