Subject: [pkix] Which CA to use for Inter PKI (Domain) Cross Certification

From: Erwin Himawan <[email-masked]>
Date: Tue, 15 Nov 2011 14:13:26 -0600

Hi,

If I have a PKI with hierarchical CAs (Root CA -> Intermediate CA ->
Issuing CA) and I would like to cross sign with other (PKI) domain, which
CA should I use for cross-signing (root CA, Intermediate CA)?

TWG-98-59 (Public Key Infrastructure (PKI) Technical Specifications: Part A
- Technical Concept of Operations) specifies that a "Principal CA" performs
the cross certification.
Furthermore, it also mentions that in a hierarchical topology, the
principal CA is the root CA.

I would like to get more insight on the pros and cons of having root CA
performs the cross signing vs having the Intermediate CA performs this
function.

Thanks
Erwin

---

From: "Polk, William T." <[email-masked]>
Date: Wed, 16 Nov 2011 01:59:00 -0500

If you are operating a hierarchical PKI, you could theoretically use any CA to issue a certificate to the principal CA.  A relying party that chose to use your root CA as a trust anchor would be able to build a path for certificates in the other domain through the intermediate CA.

There is an obvious negative impact: a longer path.  You have to get at least one additional certificate and more importantly, status information for at least one more certificate.

Another *possible* negative impact would be asymmetry: assuming the other PKI domain wishes to trust your entire domain, they will want to cross certify with your root CA.  Otherwise, they can only establish paths for certificates issued in a subtree of your hierarchical PKI.  The cross certification process is also simpler IMHO if the two principal CAs cross certify directly.  (I consider this a "possible negative", since there might be a valid scenario where the other domain only wants to recognize a subtree from your hierarchical PKI.)

There may be a significant positive impact of issuing the certificate for the other Principal CA from an intermediate CA, though.  Many PKIs lock their Root CA down pretty tightly, and issue long lived CRLs (e.g., 30 days) so they don't have to get access very often.  Since relying parties may choose to cache that 30 day CRL, revoking your trust relationship with that PKI domain may leave your relying parties with a long window of vulnerability.  If you issue the certificate from an intermediate CA, which is usually online, that window of vulnerability is likely to be hours instead of days or weeks.

Is this the sort of information you are looking for?

Tim

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Erwin Himawan [[email-masked]]
Sent: Tuesday, November 15, 2011 3:13 PM
To: [email-masked]
Subject: [pkix] Which CA to use for Inter PKI (Domain) Cross Certification

Hi,

If I have a PKI with hierarchical CAs (Root CA -> Intermediate CA -> Issuing CA) and I would like to cross sign with other (PKI) domain, which CA should I use for cross-signing (root CA, Intermediate CA)?

TWG-98-59 (Public Key Infrastructure (PKI) Technical Specifications: Part A - Technical Concept of Operations) specifies that a "Principal CA" performs the cross certification.
Furthermore, it also mentions that in a hierarchical topology, the principal CA is the root CA.

I would like to get more insight on the pros and cons of having root CA performs the cross signing vs having the Intermediate CA performs this function.

Thanks
Erwin