Subject: [pkix] [Editorial Errata Reported] RFC2560 (3251)

From: RFC Errata System <[email-masked]>
Date: Mon, 11 Jun 2012 18:33:09 -0700 (PDT)

The following errata report has been submitted for RFC2560,
"X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSP".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=2560&eid=3251

--------------------------------------
Type: Editorial
Reported by: Daniel Barclay <[email-masked]>

Section: 4.2.2.2

Original Text
-------------
...  They MUST reject the response if the certificate required to validate
the signature on the response fails to meet at least one of the following
criteria:

   1. ...
   2. ...
   3. ...

Corrected Text
--------------
...  They MUST reject the response if it is not the case that the
certificate required to validate the signature on the response meets at 
least one of the following criteria:

   1. ...
   2. ...
   3. ...

Notes
-----
The "fails to meet at least one ... " part of the original wording is ambiguous.  

It can sound like the grouping is "(fails to meet) at least one ..." rather than the (apparently) intended "fails to (meet at least one)".

Note:  The submitted corrected text needs further improvement.  I think it eliminates the ambiguity, but it currently is harder to follow.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2560 (draft-ietf-pkix-ocsp-07)
--------------------------------------
Title               : X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSP
Publication Date    : June 1999
Author(s)           : M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Miller, Timothy J." <[email-masked]>
Date: Tue, 12 Jun 2012 14:27:13 +0000

I have passive voice.  I suggest instead:

"...The certificate required to validate the signature on the response
MUST meet at least one of the following criteria:
1. ...
2. ...
3. ...
"""

-- T

On 6/11/12 8:33 PM, "RFC Errata System" <[email-masked]> wrote:

>It can sound like the grouping is "(fails to meet) at least one ..."
>rather than the (apparently) intended "fails to (meet at least one)".
>
>Note:  The submitted corrected text needs further improvement.  I think
>it eliminates the ambiguity, but it currently is harder to follow.
>
>Instructions:
>-------------
>_______________________________________________
>pkix mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pkix