Subject: [pkix] Compiling ASN.1 for PKCS10 (RFC 2986)

From: <[email-masked]>
Date: Mon, 2 Jul 2012 17:30:52 -0400

Hi,

Hoping someone can provide me with a pointer. I'm trying to compile the ASN.1 for PKCS10 embedded in RFC 2986 to C structures & definitions. Both of my ASN1 compilers (asn1c and snacc) are complaining when they parse the ASN.1; they both appear to be hanging at parsing the ALGORITHM import statement.

I've taken care to include the UsefulDefinitions module which defines the IMPORTs required for PKCS10, but I'm still not having any luck.

Has anyone else recently compiled the PKCS10 ASN.1?

Thanks,
Walter Goulet
Senior Practice Consultant
RSA, The Security Division of EMC
M: (224) 277-6821

---

From: <[email-masked]>
Date: Mon, 2 Jul 2012 18:00:56 -0400

Ah ok, that makes sense. Debugging the ASN.1 compiler errors seems to be dragging me down quite the rathole.

> -----Original Message-----
> From: Peter Gutmann [mailto:[email-masked]]
> Sent: Monday, July 02, 2012 4:56 PM
> To: [email-masked]; Goulet, Walter
> Subject: Re: [pkix] Compiling ASN.1 for PKCS10 (RFC 2986)
> 
> <[email-masked]> writes:
> 
> >Hoping someone can provide me with a pointer. I'm trying to compile the
> >ASN.1 for PKCS10 embedded in RFC 2986 to C structures & definitions.
> >Both of my
> >ASN1 compilers (asn1c and snacc) are complaining when they parse the
> >ASN.1; they both appear to be hanging at parsing the ALGORITHM import
> statement.
> 
> Until relatively recently, a lot of the IETF's ASN.1, particularly the '88 form that
> was still used years after it was withdrawn by the ISO as a standard, was
> present for sort of illustrative purposes rather than for machine processing.
> It's quite possible that this ASN.1 has never been compilable, so you'd have
> to adapt it yourself to make it work.
> 
> Peter.

---

From: Russ Housley <[email-masked]>
Date: Tue, 3 Jul 2012 09:58:59 -0400

I compiled it many years ago with ESNACC.  I had to make a few changes to make it work.  These are the notes I left behind:

-- The following is a translation of the ASN.1 module from RFC 2986, which
-- makes use of the 1993 ASN.1 syntax and IMPLICIT tags.  Also, revised
-- the IMPORT to take advantage of the ASN.1 module from RFC 3280.

Russ

On Jul 2, 2012, at 5:30 PM, <[email-masked]> <[email-masked]> wrote:

> Hi,
>  
> Hoping someone can provide me with a pointer. I’m trying to compile the ASN.1 for PKCS10 embedded in RFC 2986 to C structures & definitions. Both of my ASN1 compilers (asn1c and snacc) are complaining when they parse the ASN.1; they both appear to be hanging at parsing the ALGORITHM import statement.
>  
> I’ve taken care to include the UsefulDefinitions module which defines the IMPORTs required for PKCS10, but I’m still not having any luck.
>  
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: <[email-masked]>
Date: Tue, 3 Jul 2012 10:19:12 -0400

Thanks for the notes Russ.

From: Russ Housley [mailto:[email-masked]]
Sent: Tuesday, July 03, 2012 8:59 AM
To: Goulet, Walter
Cc: [email-masked]
Subject: Re: [pkix] Compiling ASN.1 for PKCS10 (RFC 2986)

Russ

On Jul 2, 2012, at 5:30 PM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Thanks,
Walter Goulet

_______________________________________________
pkix mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pkix