Subject: Re: [pkix] Need for an organizationalIdentifier attribute

From: "Moudrick M. Dadashov" <[email-masked]>
Date: Sat, 08 Sep 2012 15:09:51 +0300

On 3/23/2012 7:13 PM, Stefan Santesson wrote:
> When a person is associated with an organization in a certificate the 
> subjects employee number or alike is often stored in the serialNumber 
> attribute.
>
> But where do you store an identifier of the organization?
> That is, not the name stored in organization name, but the registered 
> organization number?
>
> I've seen some odd solutions to this problem but nor clean solution.
> X.520 only offer organizationName and orgnizationalUnitName as 
> organizational attributes
>
> Have anyone else come across this issue?
> How did you solve it?
> Do we need to define a clean attribute for an organizationalIdentifier?
Definitely yes.

M.D.
>
> /Stefan
>
>
>
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: "Erik Andersen" <[email-masked]>
Date: Sun, 9 Sep 2012 13:51:27 +0200

FYI

Erik

Fra: [email-masked] [mailto:[email-masked]] På vegne af
Moudrick M. Dadashov
Sendt: 8. september 2012 14:10
Til: Stefan Santesson
Cc: pkix
Emne: Re: [pkix] Need for an organizationalIdentifier attribute

How did you solve it?

Definitely yes.

M.D.

/Stefan

---

From: Sean Turner <[email-masked]>
Date: Sun, 09 Sep 2012 20:41:23 -0400

Erik,

I think the apps folks might have some ideas.  I cc'ed that list to see 
if somebody is aware of an attribute that's already been defined for 
this purpose.

spt

On 9/9/12 7:51 AM, Erik Andersen wrote:
> FYI
>
> Erik
>
> *Fra:[email-masked] [mailto:[email-masked]] *På vegne af
> *Moudrick M. Dadashov
> *Sendt:* 8. september 2012 14:10
> *Til:* Stefan Santesson
> *Cc:* pkix
> *Emne:* Re: [pkix] Need for an organizationalIdentifier attribute
>
>     When a person is associated with an organization in a certificate
>     the subjects employee number or alike is often stored in the
>     serialNumber attribute.
>
>     That is, not the name stored in organization name, but the
>     registered organization number?
>
> [email-masked]  <mailto:[email-masked]>
>