Subject: [pkix] Random Serials Make OCSP Presigning Hard [WAS: Questioning the benefit of random serials over sequential ones in x.509 certificates]

From: "Schaen, Samuel I." <[email-masked]>
Date: Fri, 14 Dec 2012 22:05:24 +0000

I changed the subject name to keep the threads separate.

The CAs would need to update the responders with each new CRL to account for newly issued certificates. 

A new protocol would be needed to standardize how that list of issued certificates is passed to the provider (assuming you want CAs and Responders from different vendors). 

Passing the full list each time could be expensive in bandwidth for CAs with a large number of certificates (e.g., the DoD). 

Supporting deltas would add additional complexity. 

Not rocket science; but not a cakewalk either.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kemp, David P.
Sent: Friday, December 14, 2012 2:54 PM
To: [email-masked]
Subject: Re: [pkix] Questioning the benefit of random serials over sequential ones in x.509 certificates

Santosh,

You are correct.  For some reason my old brain got the idea that OCSP requests and responses contained subject DNs.  I have no clue where that came from, since:

   CertID          ::=     SEQUENCE {
       hashAlgorithm       AlgorithmIdentifier,
       issuerNameHash      OCTET STRING, -- Hash of Issuer's DN
       issuerKeyHash       OCTET STRING, -- Hash of Issuers public key
       serialNumber        CertificateSerialNumber }

As Roseanne Rosannadanna said, "never mind".

However, a list of issued CertificateSerialNumber's could be distributed to OCSP responders that don't have a direct CA connection, in addition to CRLs.  That is an added complication, but hardly an engineering challenge.

Dave

-----Original Message-----
From: Santosh Chokhani [mailto:[email-masked]] 
Sent: Friday, December 14, 2012 2:18 PM
To: Kemp, David P.; [email-masked]
Subject: RE: [pkix] Questioning the benefit of random serials over sequential ones in x.509 certificates

Dave,

What DN are you talking about?  If the Responder has the CRL, it has the issuer DN.  It verifies the signature on the CRL using the issuer public key which it obtains using any proper means (say a certificate).

I do not see any other data required for request or response that Responder needs.
_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: "Piyush Jain" <[email-masked]>
Date: Fri, 14 Dec 2012 14:26:31 -0800

Comments inline.

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Schaen, Samuel I.
> Sent: Friday, December 14, 2012 2:05 PM
> Subject: [pkix] Random Serials Make OCSP Presigning Hard [WAS:
> Questioning the benefit of random serials over sequential ones in x.509
> certificates]
> 
[Piyush] Agreed.  I would assume it's a big problem in enterprise PKI, not
so much in web pki. 
The update would be needed not only with each CRL but with every new cert
that is issued.
> 
> A new protocol would be needed to standardize how that list of issued
> certificates is passed to the provider (assuming you want CAs and
> Responders from different vendors).
> 
[Piyush] Don't think that is happening. Public CAs are happy with the
proprietary method as they own the CA and the responder. Some large
enterprise PKI deployments though,have refused to adopt random serials
precisely because of this reason.

> Passing the full list each time could be expensive in bandwidth for CAs
with a
> large number of certificates (e.g., the DoD).
> 
[Piyush] Do you mean deltas of pre-signed response collection? Not sure if I
understand this one.
> Subject: Re: [pkix] Questioning the benefit of random serials over
sequential
> ones in x.509 certificates
> 
> Santosh,
> 
> You are correct.  For some reason my old brain got the idea that OCSP
> requests and responses contained subject DNs.  I have no clue where that
> came from, since:
> 
>    CertID          ::=     SEQUENCE {
> However, a list of issued CertificateSerialNumber's could be distributed
to
> OCSP responders that don't have a direct CA connection, in addition to
CRLs.
> That is an added complication, but hardly an engineering challenge.
> 
> Dave
> 
> 
> 
> Subject: RE: [pkix] Questioning the benefit of random serials over
sequential
> ones in x.509 certificates
> 
> Dave,
> 
> What DN are you talking about?  If the Responder has the CRL, it has the
> issuer DN.  It verifies the signature on the CRL using the issuer public
key
> which it obtains using any proper means (say a certificate).
> 
> I do not see any other data required for request or response that
Responder
> needs.