Subject: [pkix] why revoked certificate entry has to be included in one CRL issued beyond certificate validity period

From: "Andris Berzins" <[email-masked]>
Date: Thu, 27 Dec 2012 22:05:40 +0200

rfc5280 states:

"An entry MUST NOT be removed

from the CRL until it appears on one regularly scheduled CRL issued

beyond the revoked certificate's validity period."

and

"If a certificate revocation notice first appears on a delta CRL, then

it is possible for the certificate validity period to expire before

the next complete CRL for the same scope is issued.  In this case,

the revocation notice MUST be included in all subsequent delta CRLs

until the revocation notice is included on at least one explicitly

issued complete CRL for this scope."

Why is that required?

---

From: Denis Pinkas <[email-masked]>
Date: Fri, 28 Dec 2012 12:00:31 +0100

RFC 5280 states:

4.1.2.5.Validity

The certificate validity period is the time interval during which the

CA warrants that it will maintain information about the status of the
    certificate.

Since this CRL is the first one issued beyond the end of the validity 
period, this guarantees that
the CA maintains the revocation status really up to the end of the 
validity period.

Denis

> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: [email-masked] (Martin Rex)
Date: Fri, 28 Dec 2012 16:09:32 +0100 (CET)

I would say that the reason for this requirement is the last sentence
of rfc5280 section 5, page 55:

http://tools.ietf.org/html/rfc5280#page-55

                                        Conforming applications are not
   required to support processing of delta CRLs, indirect CRLs, or CRLs
   with a scope other than all certificates issued by one CA.

If a CA revokes a cert, it must issue at least one CRL that
*ALL* conforming applications will be able to see.  In the border
case, when a cert is revoked very close to the end of its validity,
it may require the CA to list the revoked cert on a complete regular CRL
with a "thisUpdate" that is after the "notAfter" of such a cert that is
revoked just before then end of its validity period.

-Martin

---

From: Santosh Chokhani <[email-masked]>
Date: Fri, 28 Dec 2012 10:26:22 -0500

Andris,

The rationale behind this is to provide for archive and future verification (e.g., for non-repudiation purposes) for .

Let us make the following assumptions:

1.     The CRLs are the official archive.

2.     Delta CRLs are not the official archive

3.     A new CRL Y can be built using the previous CRL X and a delta issued when Y is issued.

In that case, you want a certificate on at least one CRL and maintain on delta until it is recorded in a CRL that is archived.

5280 language is unnecessarily constraining.  It should state, “expired certificates shall be removed from the CRL, except a revoked certificate shall appear on at least one CRL.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andris Berzins
Sent: Thursday, December 27, 2012 3:06 PM
To: [email-masked]
Subject: [pkix] why revoked certificate entry has to be included in one CRL issued beyond certificate validity period

rfc5280 states:

and

Why is that required?

---

From: [email-masked] (Martin Rex)
Date: Fri, 28 Dec 2012 17:30:26 +0100 (CET)

Santosh Chokhani wrote:
> 
> The rationale behind this is to provide for archive and future
> verification (e.g., for non-repudiation purposes) for.
> 
> In that case, you want a certificate on at least one CRL and maintain
> on delta until it is recorded in a CRL that is archived.
> 
> 5280 language is unnecessarily constraining.  It should state,
> ?expired certificates shall be removed from the CRL,
> except a revoked certificate shall appear on at least one CRL.

Except for the special case of _pure_ online authentication,
one really wants to be able to publish key compromise on CRLs _forever_.

For digital signatures on Emails, Code, Documents, etc. it seems
unreasonable to _not_ be able to revoke a cert after it has expired.
The revocation date is the point in time when the revocation was
requested or published (and may happen after expiration of the cert).
The more interesting revocation information for archived digitally
signed data is the invalidity date asserted by the revocation.

-Martin

---

From: Santosh Chokhani <[email-masked]>
Date: Sat, 29 Dec 2012 20:47:46 -0500

While not explicit, 5280 and my post permit you to revoke an expired certificate if you wish to and it will be on one CRL and then be removed.

In terms of keeping certificates on CRL forever, these are relying party issues that can be solved for non-repudiation purposes using time stamps, LTANS trusted archive, or using historical CRL as associated issuance, revocation and invalidity dates to create a time-line and resolve disputes,

Do not forget, PKI is not the non-repudiation decision maker.  It is just one of the inputs (albeit a strong one) to help the judicial system to make a determination.  There are other IT and non-IT inputs one uses to resolve such disputes.

-----Original Message-----
From: Martin Rex [mailto:[email-masked]] 
Sent: Friday, December 28, 2012 11:30 AM
To: Santosh Chokhani
Cc: Andris Berzins; [email-masked]
Subject: Re: [pkix] why revoked certificate entry has to be included in one CRL issued beyond certificate validity period

Santosh Chokhani wrote:
> ?expired certificates shall be removed from the CRL, except a revoked 
> certificate shall appear on at least one CRL.

Except for the special case of _pure_ online authentication, one really wants to be able to publish key compromise on CRLs _forever_.

For digital signatures on Emails, Code, Documents, etc. it seems unreasonable to _not_ be able to revoke a cert after it has expired.
The revocation date is the point in time when the revocation was requested or published (and may happen after expiration of the cert).
The more interesting revocation information for archived digitally signed data is the invalidity date asserted by the revocation.

-Martin