Subject: [pkix] [Editorial Errata Reported] RFC4211 (3948)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Apr 2014 22:01:14 -0700 (PDT)

The following errata report has been submitted for RFC4211,
"Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4211&eid=3948

--------------------------------------
Type: Editorial
Reported by: Tom Biskupic <[email-masked]>

Section: 5.3.4

Original Text
-------------
 CertRepMessage ::= SEQUENCE {
         caPubs          [1] SEQUENCE SIZE (1..MAX) OF Certificate
                             OPTIONAL,
         response            SEQUENCE OF CertResponse
     }

Corrected Text
--------------
CertRepMessage ::= SEQUENCE {
         caPubs       [1] SEQUENCE SIZE (1..MAX) OF CMPCertificate
                          OPTIONAL,
         response         SEQUENCE OF CertResponse
     }

Notes
-----
The definition in the text is different to the one in the ASN.1 module contained in Appendix F. The correct text is assumed to be the one from Appendix F

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4211 (draft-ietf-pkix-rfc2511bis-08)
--------------------------------------
Title               : Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)
Publication Date    : September 2005
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 03 Apr 2014 10:28:37 +0100

It would be so nice if people would post a message to the
pkix list before posting an erratum. That'd save some errors
and wasted time for those who have to later process the
errata and would mean that the person reporting could add
a link the the list archive to help someone who reads the
thing.

Thanks,
S.

On 04/03/2014 06:09 AM, Tom Biskupic wrote:
> Sorry I have submitted this against the wrong RFC - it should have been RFC
> 4210 (not 4211). I've submitted an errata for the correct RFC.
> 
> Thanks,
> 
> Tom Biskupic
> 
> 
> On Thu, Apr 3, 2014 at 4:01 PM, RFC Errata System <[email-masked]
>> wrote:
> 
>> The definition in the text is different to the one in the ASN.1 module
>> contained in Appendix F. The correct text is assumed to be the one from
>> Appendix F
>>
>> Instructions:
>> -------------

---

From: Tom Biskupic <[email-masked]>
Date: Thu, 3 Apr 2014 20:45:43 +1100

Will note this for future. I had thought this was the less obtrusive way to post minor editorial errors.

Again - sorry for the error with the rfc number.

Tom Biskupic

> On 3 Apr 2014, at 20:28, Stephen Farrell <[email-masked]> wrote:
> 
>

---

From: Alice Russo <[email-masked]>
Date: Thu, 3 Apr 2014 18:53:29 -0400

FYI, the erratum mistakenly reported for RFC 4211 has been removed.

Thank you.
RFC Editor/ar

On Apr 3, 2014, at 1:09 AM, Tom Biskupic wrote:

> Sorry I have submitted this against the wrong RFC - it should have been RFC 4210 (not 4211). I've submitted an errata for the correct RFC.
> 
> Thanks,
> 
> Tom Biskupic
> 
> 
> On Thu, Apr 3, 2014 at 4:01 PM, RFC Errata System <[email-masked]> wrote: