Subject: [pkix] [Technical Errata Reported] RFC6402 (3943)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Apr 2014 11:16:32 -0700 (PDT)

The following errata report has been submitted for RFC6402,
"Certificate Management over CMS (CMC) Updates".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6402&eid=3943

--------------------------------------
Type: Technical
Reported by: Jim Schaad <[email-masked]>

Section: 2.8,

Original Text
-------------

      ChangeSubjectName ::= SEQUENCE {
          subject             Name OPTIONAL,
          subjectAlt          SubjectAltName OPTIONAL
      }
      (WITH COMPONENTS {..., subject PRESENT} |
            COMPONENTS {..., subjectAlt PRESENT} )

Corrected Text
--------------
      ChangeSubjectName ::= SEQUENCE {
          subject             Name OPTIONAL,
          subjectAlt          [1] SubjectAltName OPTIONAL
      }
      (WITH COMPONENTS {..., subject PRESENT} |
            COMPONENTS {..., subjectAlt PRESENT} )

Notes
-----
Both Name and SubjectAltName use the same tag (SEQUENCE) so it is not possible to distinguish between the two fields without having a tag on one of them.  This fix adds a tag so that it is possible to differentiate the two fields.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6402 (draft-ietf-pkix-rfc5272-bis-08)
--------------------------------------
Title               : Certificate Management over CMS (CMC) Updates
Publication Date    : November 2011
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 03 Apr 2014 00:03:35 +0100

A bug fix that breaks interop?  Is that a valid Erratum?

S

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 2 Apr 2014 16:29:17 -0700

Doesn't break interop - The module fails to compile without the fix.  I
somehow only used one of the three compilers on my machine which I checked
this and it was the wrong one as that oddity of the encoder was not checked
by that compiler.

Jim

> -----Original Message-----
> From: Stephen Farrell [mailto:[email-masked]]
> Sent: Wednesday, April 02, 2014 4:04 PM
> To: RFC Errata System; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Technical Errata Reported] RFC6402 (3943)
> 
> 
> > Both Name and SubjectAltName use the same tag (SEQUENCE) so it is not
> possible to distinguish between the two fields without having a tag on one
of
> them.  This fix adds a tag so that it is possible to differentiate the two
fields.
> > use "Reply All" to discuss whether it should be verified or rejected.
> > When a decision is reached, the verifying party (IESG) can log in to
> > change the status and edit the report, if necessary.
> >

---

From: "Manger, James" <[email-masked]>
Date: Thu, 3 Apr 2014 14:13:03 +1100

Another problem with the spec and this errata is that uses a non-existent ASN.1 type: SubjectAltName.

Should be GeneralNames instead.

--
James Manger

-----Original Message-----
From: pkix [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Thursday, 3 April 2014 10:29 AM
To: 'Stephen Farrell'; 'RFC Errata System'; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [pkix] [Technical Errata Reported] RFC6402 (3943)

Jim

of
fields.
> > Instructions:

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix