Subject: [pkix] Fwd: New Version Notification for draft-housley-pkix-oids-03.txt

From: Russ Housley <[email-masked]>
Date: Wed, 23 Apr 2014 12:21:10 -0400

I updated this document to do two things:

(1) correct an error discovered by Roni Even in his Gen-ART Review.

(2) add a sentence to the security considerations about id-pe-nsa.

Russ

Begin forwarded message:

> From: [email-masked]
> Date: April 23, 2014 12:17:53 PM EDT
> To: "Russ Housley" <[email-masked]>
> Subject: New Version Notification for draft-housley-pkix-oids-03.txt
> 
> 
> A new version of I-D, draft-housley-pkix-oids-03.txt
> has been successfully submitted by Russ Housley and posted to the
> IETF repository.
> 
> Name:		draft-housley-pkix-oids
> Revision:	03
> Title:		Object Identifier Registry for the PKIX Working Group
> Document date:	2014-04-23
> Group:		Individual Submission
> Pages:		30
> URL:            http://www.ietf.org/internet-drafts/draft-housley-pkix-oids-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-housley-pkix-oids/
> Htmlized:       http://tools.ietf.org/html/draft-housley-pkix-oids-03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-housley-pkix-oids-03
> 
> Abstract:
>   When the Public-Key Infrastructure using X.509 (PKIX) Working Group
>   was chartered, an object identifier arc was was allocated by IANA for
>   use by that working group.  This document describes the object
>   identifiers that were assigned in that arc, it returns control of
>   that arc to IANA, and it establishes IANA allocation policies for any
>   future assignments within that arc.

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 23 Apr 2014 12:40:34 -0400

Hi Russ,

Two observations/questions about clause 5.1.

> [ASN1-88] International Telephone and Telegraph Consultative 
> Committee, "Specification of Abstract Syntax Notation One (ASN.1)", 
> CCITT Recommendation X.208, 1988.

How is it possible to cite a specification as normative
that no longer exists?

> [ASN1-97] International Telecommunications Union, "Abstract Syntax 
> Notation One (ASN.1): Specification of basic notation", ITU-T 
> Recommendation X.680, 1997. 

1. The organization name is "International Telecommunication Union"
2. How is it possible to cite the 1997 version as normative when it
has been superseded?  Are any of the amendments or corrections
included?

These seem like significant questions that anyone attempting
to implement the RFC would ask.

--tony

On 2014-04-23 12:21 PM, Russ Housley wrote:
> ure assignments within that arc.
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Russ Housley <[email-masked]>
Date: Wed, 23 Apr 2014 16:42:46 -0400

Tony:

>> [ASN1-88] International Telephone and Telegraph Consultative Committee, "Specification of Abstract Syntax Notation One (ASN.1)", CCITT Recommendation X.208, 1988.
> 

Some of the PKIX documents use the 1988 version, and others use the later versions.  Fortunately, these are compatible in their use of object identifiers, so this does not become an issue here.  Of course, there are other aspects os ASN.1 that are not compatible between the 1988 version and later versions.

>> [ASN1-97] International Telecommunications Union, "Abstract Syntax Notation One (ASN.1): Specification of basic notation", ITU-T Recommendation X.680, 1997. 
> 

Please excuse the typo.  It will be corrected.

Actually, since this document only uses object identifiers, there are not concerns with the version as explained above.

Russ

---

From: [email-masked] (Martin Rex)
Date: Thu, 24 Apr 2014 03:06:53 +0200 (CEST)

Russ Housley wrote:
> Tony:
> 
>> [ASN1-88] International Telephone and Telegraph Consultative Committee,
>> "Specification of Abstract Syntax Notation One (ASN.1)",
> Actually, since this document only uses object identifiers,
> there are no concerns with the version as explained above.

"no longer exists" do not seem to describe the facts adequately.

The document X.209, 1988 still exists, you can publicly download it here:

http://www.itu.int/rec/T-REC-X.208-198811-W/en

And if you desperately want to pay for it, there is an URL on that page
suggesting that ITU might be willing to still sell this document to you.

"withdrawn" / "superseded" is terminology that is regularly abused
by marketing departments to push a specific desire, but does not
necessarily match market behaviour, i.e. the perceived nuisance
commonly known as the "real world".

-Martin

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 23 Apr 2014 22:07:20 -0400

Well then maybe terms like "normative" shouldn't
be used either. :-)

-- 

________________________________ **

*Tony Rutkowski*

EVP, Industry Standards & Regulatory Affairs

[email-masked] <mailto:[email-masked]> **

*Yaana Technologies LLC *

542 Gibraltar Drive

Milpitas CA 95035 USA

---

From: "Erik Andersen" <[email-masked]>
Date: Thu, 24 Apr 2014 08:20:13 +0200

The 2002 edition of ASN.1 is also freely available, so money cannot be the
excuse for PKIX to produce back level specifications
(http://www.itu.int/rec/T-REC-X.680-200207-S/en).

Erik

-----Original Message-----
From: pkix [mailto:[email-masked]] On Behalf Of Martin Rex
Sent: Thursday, April 24, 2014 3:07 AM
To: Russ Housley
Cc: IETF PKIX
Subject: Re: [pkix] Fwd: New Version Notification for
draft-housley-pkix-oids-03.txt

Russ Housley wrote:
>> How is it possible to cite a specification as normative that no 
>> longer exists?
> 
> Actually, since this document only uses object identifiers, there are 
> no concerns with the version as explained above.

"withdrawn" / "superseded" is terminology that is regularly abused by
marketing departments to push a specific desire, but does not necessarily
match market behaviour, i.e. the perceived nuisance commonly known as the
"real world".

-Martin