Subject: [pkix] X.500 Edition 8 modules

From: Peter Bowen <[email-masked]>
Date: Tue, 21 Feb 2017 07:33:18 -0800

Does anyone know if the collected ASN.1 modules from edition 8 have
been posted?  http://www.x500standard.com/index.php?n=Ig.Asn1 only has
edition 7.

Thanks,
Peter

---

From: "Erik Andersen" <[email-masked]>
Date: Tue, 21 Feb 2017 17:04:44 +0100

I will post them tomorrow.

Kind regards,

Erik

-----Oprindelig meddelelse-----
Fra: pkix [mailto:[email-masked]] På vegne af Peter Bowen
Sendt: 21 February 2017 16:33
Til: PKIX <[email-masked]>; Directory list <[email-masked]>
Emne: [pkix] X.500 Edition 8 modules

Does anyone know if the collected ASN.1 modules from edition 8 have been
posted?  http://www.x500standard.com/index.php?n=Ig.Asn1 only has edition 7.

Thanks,
Peter

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: Peter Bowen <[email-masked]>
Date: Tue, 21 Feb 2017 08:09:10 -0800

Do you know if edition 8 adds a definition for "passwordAttribute"?
It is undefined in edition 7 yet used in InformationFramework.

---

From: "Erik Andersen" <[email-masked]>
Date: Wed, 22 Feb 2017 12:35:59 +0100

Hi Peter,

I am quite sure, such a definition was not added. I will look into the matter and possibly issue a defect report.

Kind regards,

Erik

-----Oprindelig meddelelse-----
Fra: Peter Bowen [mailto:[email-masked]] 
Sendt: 21 February 2017 17:09
Til: Erik Andersen <[email-masked]>
Cc: PKIX <[email-masked]>; Directory list <[email-masked]>
Emne: Re: [pkix] X.500 Edition 8 modules

On Tue, Feb 21, 2017 at 8:04 AM, Erik Andersen <[email-masked]> wrote:
> been posted?  http://www.x500standard.com/index.php?n=Ig.Asn1 only has edition 7.
>
> Thanks,
> Peter
>

---

From: Peter Bowen <[email-masked]>
Date: Wed, 22 Feb 2017 07:24:27 -0800

Erik,

It appears that there is a bug in the ASN.1 compiler I'm using.  There
is not supposed to be a definition of passwordAttribute; it is a
parameter name.

Thanks,
Peter

---

From: Sean Turner <[email-masked]>
Date: Thu, 23 Feb 2017 18:44:05 -0500

Maybe "passwordAttribute” in pwdHistory/PwdHistory, pwdRecentlyExpired, and pwdHistoryMatch is supposed to “pwdAttribute” to match the object class and attribute both of which are defined in the module:
https://www.itu.int/ITU-T/formal-language/itu-t/x/x501/2012/InformationFramework.html

spt

> On Feb 22, 2017, at 10:24, Peter Bowen <[email-masked]> wrote:
> 
> Erik,
>