Subject: [pkix] [Editorial Errata Reported] RFC6844 (5091)

From: RFC Errata System <[email-masked]>
Date: Fri, 18 Aug 2017 08:06:30 -0700 (PDT)

The following errata report has been submitted for RFC6844,
"DNS Certification Authority Authorization (CAA) Resource Record".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5091

--------------------------------------
Type: Editorial
Reported by: Mak Kolybabi <[email-masked]>

Section: 4

Original Text
-------------
   o  If CAA(X) is not empty, R(X) = CAA (X), otherwise

Corrected Text
--------------
   o  If CAA(X) is not empty, R(X) = CAA(X), otherwise

Notes
-----
Remove unnecessary space after second CAA, making appearances of CAA(X) consistent throughout the section.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6844 (draft-ietf-pkix-caa-15)
--------------------------------------
Title               : DNS Certification Authority Authorization (CAA) Resource Record
Publication Date    : January 2013
Author(s)           : P. Hallam-Baker, R. Stradling
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Fri, 18 Aug 2017 11:14:48 -0400

I do not think the extra space will confuse any implementers.  Also, since the LAMPS WG is considering a charter item to update this document, a resolution of "held for future update" seems right to me.

Russ

> On Aug 18, 2017, at 11:06 AM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 18 Aug 2017 11:17:55 -0400

Russ, thanks for the quick response on each of these!

-- 

Best regards,
Kathleen

---

From: "Phillip" <[email-masked]>
Date: Fri, 18 Aug 2017 12:27:26 -0400

Please reject, Errata 5065 already updates this section, we should avoid
errata of errata.

https://www.rfc-editor.org/errata_search.php?rfc=6844&rec_status=15&presenta
tion=records

The second space does not worry me nearly as much as the issues to do with
CNAME handling.

-----Original Message-----
From: Russ Housley [mailto:[email-masked]] 
Sent: Friday, August 18, 2017 11:15 AM
To: Kathleen Moriarty <[email-masked]>; Eric Rescorla
<[email-masked]>
Cc: Phillip Hallam-Baker <[email-masked]>; Rob Stradling
<[email-masked]>; IETF PKIX <[email-masked]>
Subject: Re: [pkix] [Editorial Errata Reported] RFC6844 (5091)

I do not think the extra space will confuse any implementers.  Also, since
the LAMPS WG is considering a charter item to update this document, a
resolution of "held for future update" seems right to me.

Russ

> The following errata report has been submitted for RFC6844, "DNS 
> Certification Authority Authorization (CAA) Resource Record".
> 
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 22 Aug 2017 13:28:55 -0400

Thanks, Philip.  I see your point on errata of errata, but your errata
didn't fix the space, so HFDU seems right to me so this change isn't
forgotten.

Best regards,
Kathleen

-- 

Best regards,
Kathleen