Subject: [pkix] Applied Quantum Resistant Crypto

From: "Dr. Pala" <[email-masked]>
Date: Tue, 17 Jul 2018 15:35:05 -0400

Hi all,

I was wondering if there are people interested in setting up some sort
of discussion forum where to discuss the deployment (from a practical
point of view) for QRC in their systems. The intent here would be to
share the experiences, provide feedback, and possibly even share
implementations/references/etc.

Moreover, being this quite a new field when it comes to real-world
applications, it would be interesting to understand the new requirements
so that we can plan for algorithm agility correctly and not having to go
through what we suffered in the past (and in some cases with current
protocols) to upgrade/switch among different schemes/algorithms.

For example, some of the topics might include:

  * How to deploy PKI services
  * Mixed environments considerations (QRC and "Traditional" Crypto)
  * Mixed environments (stateful vs. stateless)
  * Encryption and Key-Exchange for QRC - what are the options there (it
    seems auth is well understood, but other problems are still open)?
  * Are there implications for the deployment of PKIs we need to be
    aware of and are not currently mentioned/addressed?
  * Any real-world deployment out there (or plans for it)?
  * Algorithm Agility, what to plan for?
  * Applicability to Revocation Services

Most of the activities to standardize QRC in CMS/SecFirmware/etc. that I
can see are related to the use of Stateful HASHSIG and I have not seen
any "standardization" activities around stateless schemes (e.g.,
SPHINCS), but if I am wrong, please let me know (and if you could
provide some interesting links, that would be great). I think it would
be useful to understand how to practically deploy these new schemes and
how to refine / provide the building blocks required for their
implementation and deployment.

Here's some references:

Merkle Tree Signatures (Stateful):

  * https://datatracker.ietf.org/doc/draft-mcgrew-hash-sigs/
  * https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/
  * https://www.ietf.org/id/draft-housley-suit-cose-hash-sig-04.txt
  * https://datatracker.ietf.org/doc/rfc8391/ (XMSS)
  * https://eprint.iacr.org/2018/063 (Viability of Post Quantum X.509
    Certs Paper)

  * Implementations:
      o https://github.com/cisco/hash-sigs

SPHINCS Related (Stateless):

  * https://sphincs.org/

  * Implementations:
      o https://sphincs.org/data/sphincs+-reference-implementation-20180313.tar.bz2

Other Relevant Links:

  * https://datatracker.ietf.org/doc/draft-truskovsky-lamps-pq-hybrid-x509/
  * https://csrc.nist.gov/Projects/Post-Quantum-Cryptography
  * http://test-pqpki.com/

I guess this is all for now - you can reply privately at the following
addresses:

    [email-masked]
    [email-masked]

Thanks,
Max

-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: CJ Tjhai <[email-masked]>
Date: Tue, 17 Jul 2018 21:08:26 +0100

Hi Max,

There is also an experimental work on hybrid post-quantum key-exchange for
IKEv2 VPN. The work was done on a forked of strongSwan and it is available
here: https://github.com/post-quantum/strongswan/commits/qske and it works
on Linux, Android and OS X. It relies on the post-quantum libraries that is
available at this repository: https://github.com/post-quantum/nistpqc,
which contains a number of post-quantum algorithms submitted as part of
NIST standardization. Not all submitted algorithms are included, but it's
pretty straightforward to add additional ones.

This experimental work implements version 00 of this IETF draft:
https://datatracker.ietf.org/doc/draft-tjhai-ipsecme-hybrid-qske-ikev2/. We
hope to update the experimental work once the draft is in a more mature
state.

Best regards,
CJ

On 17 July 2018 at 20:35, Dr. Pala <[email-masked]> wrote:

> Hi all,
>
> I was wondering if there are people interested in setting up some sort of
> discussion forum where to discuss the deployment (from a practical point of
> view) for QRC in their systems. The intent here would be to share the
> experiences, provide feedback, and possibly even share
> applications, it would be interesting to understand the new requirements so
> that we can plan for algorithm agility correctly and not having to go
>    - How to deploy PKI services
>    - Mixed environments considerations (QRC and "Traditional" Crypto)
>    - Mixed environments (stateful vs. stateless)
>    - Encryption and Key-Exchange for QRC - what are the options there (it
>    - Are there implications for the deployment of PKIs we need to be
>    - Any real-world deployment out there (or plans for it)?
>    - Algorithm Agility, what to plan for?
>    - Applicability to Revocation Services
>
> can see are related to the use of Stateful HASHSIG and I have not seen any
> "standardization" activities around stateless schemes (e.g., SPHINCS), but
> if I am wrong, please let me know (and if you could provide some
> interesting links, that would be great). I think it would be useful to
> understand how to practically deploy these new schemes and how to refine /
> provide the building blocks required for their implementation and
> deployment.
>
> Here's some references:
>
>    - https://datatracker.ietf.org/doc/draft-mcgrew-hash-sigs/
>    - https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/
>    - https://www.ietf.org/id/draft-housley-suit-cose-hash-sig-04.txt
>    - https://datatracker.ietf.org/doc/rfc8391/ (XMSS)
>    - https://eprint.iacr.org/2018/063 (Viability of Post Quantum X.509
>    Certs Paper)
>
>    - Implementations:
>       - https://github.com/cisco/hash-sigs
>
>    - https://sphincs.org/
>    - Implementations:
>    - https://sphincs.org/data/sphincs+-reference-
>       implementation-20180313.tar.bz2
>       <https://sphincs.org/data/sphincs+-reference-implementation-20180313.tar.bz2>
>
> Other Relevant Links:
>
>    - https://datatracker.ietf.org/doc/draft-truskovsky-lamps-pq-
>    hybrid-x509/
>    - https://csrc.nist.gov/Projects/Post-Quantum-Cryptography
>    - http://test-pqpki.com/
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 17 Jul 2018 20:49:50 +0000

Hi,

We have started some work in enabling key distribution schemas powered by QKD, that I believe could be applicable to post-quantum or QRC as well. So, yes, definitely interested in exploring those ways.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 17/07/2018, 15:36, "saag on behalf of Dr. Pala" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi all,

I was wondering if there are people interested in setting up some sort of discussion forum where to discuss the deployment (from a practical point of view) for QRC in their systems. The intent here would be to share the experiences, provide feedback, and possibly even share implementations/references/etc.

Moreover, being this quite a new field when it comes to real-world applications, it would be interesting to understand the new requirements so that we can plan for algorithm agility correctly and not having to go through what we suffered in the past (and in some cases with current protocols) to upgrade/switch among different schemes/algorithms.

For example, some of the topics might include:
·         How to deploy PKI services
·         Mixed environments considerations (QRC and "Traditional" Crypto)
·         Mixed environments (stateful vs. stateless)
·         Encryption and Key-Exchange for QRC - what are the options there (it seems auth is well understood, but other problems are still open)?
·         Are there implications for the deployment of PKIs we need to be aware of and are not currently mentioned/addressed?
·         Any real-world deployment out there (or plans for it)?
·         Algorithm Agility, what to plan for?
·         Applicability to Revocation Services

Most of the activities to standardize QRC in CMS/SecFirmware/etc. that I can see are related to the use of Stateful HASHSIG and I have not seen any "standardization" activities around stateless schemes (e.g., SPHINCS), but if I am wrong, please let me know (and if you could provide some interesting links, that would be great). I think it would be useful to understand how to practically deploy these new schemes and how to refine / provide the building blocks required for their implementation and deployment.

Here's some references:

Merkle Tree Signatures (Stateful):
·         https://datatracker.ietf.org/doc/draft-mcgrew-hash-sigs/
·         https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/
·         https://www.ietf.org/id/draft-housley-suit-cose-hash-sig-04.txt
·         https://datatracker.ietf.org/doc/rfc8391/ (XMSS)
·         https://eprint.iacr.org/2018/063 (Viability of Post Quantum X.509 Certs Paper)
·         Implementations:
o    https://github.com/cisco/hash-sigs

·         https://sphincs.org/
·         Implementations:

Other Relevant Links:
·         https://datatracker.ietf.org/doc/draft-truskovsky-lamps-pq-hybrid-x509/
·         https://csrc.nist.gov/Projects/Post-Quantum-Cryptography
·         http://test-pqpki.com/

I guess this is all for now - you can reply privately at the following addresses:

    [email-masked]<mailto:[email-masked]>
    [email-masked]<mailto:[email-masked]>

Thanks,
Max
--
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
[OpenCA Logo]

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição