Subject: [pkix] [Technical Errata Reported] RFC6844 (5452)

From: RFC Errata System <[email-masked]>
Date: Mon, 6 Aug 2018 11:13:30 -0700 (PDT)

The following errata report has been submitted for RFC6844,
"DNS Certification Authority Authorization (CAA) Resource Record".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5452

--------------------------------------
Type: Technical
Reported by: EBNF, text, examples do not match <[email-masked]>

Section: GLOBAL

Original Text
-------------

The EBNF (scattered throughout the document) does not match the examples
nor the prose. It is also ambiguous in places (allowing two different
interpretations of a parameter list), and nonsensical in others (such
as the handling of whitespace).

Corrected Text
--------------
The EBNF should be corrected as follows:

issuevalue = *WSP [domain *WSP] [";" *WSP [parameters *WSP]]

domain = label *("." label)
label = (ALPHA / DIGIT) *( *("-") (ALPHA / DIGIT))

parameters = (parameter *WSP ";" *WSP parameters) / parameter
parameter = tag *WSP "=" *WSP value
tag = (ALPHA / DIGIT) *(ALPHA / DIGIT)
value = *(%x21-3A / %x3C-7E)

Notes
-----
I am proposing this on behalf of the IETF ACME WG. We want to submit a standards-track document, but the current CAA specification is broken. We know it is being revised, but we do not want to wait.  Our AD has said to submit the errata and he will accept it.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6844 (draft-ietf-pkix-caa-15)
--------------------------------------
Title               : DNS Certification Authority Authorization (CAA) Resource Record
Publication Date    : January 2013
Author(s)           : P. Hallam-Baker, R. Stradling
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Alice Russo <[email-masked]>
Date: Mon, 6 Aug 2018 11:56:59 -0700

Verifiers,
Just FYI, the submitter name and email address have been corrected on this report:
http://www.rfc-editor.org/errata/eid5452
(These changes were confirmed with the submitter. Details in-line below.)

Thank you.
RFC Editor/ar

> "DNS Certification Authority Authorization (CAA) Resource Record".
OLD: Reported by: EBNF, text, examples do not match <[email-masked]>
NEW: Reported by: Rich Salz <[email-masked]>