Subject: [pmtud] I am currently updating draft-ietf-pmtud-method-02bis

From: Matt Mathis <[email-masked]>
Date: Sat, 16 Oct 2004 19:45:18 -0400 (EDT)

If you want to /help/kibitz/watch it would be best to get live updates from
http://www.psc.edu/~mathis/MTU/pmtud/index.html  (almost daily)

Quick question: can somebody cite a table of common tunnel overheads?

For example:
20 : IPv4 in IP
12 : IPsec ESP_AUTH
24 : IPsec AH, IPsec ESP_CIPHER

Alternatively, can somebody extend this list?

Thanks,
--MM--
-------------------------------------------
Matt Mathis      http://www.psc.edu/~mathis
Work:412.268.3319    Home/Cell:412.654.7529
-------------------------------------------
Evil is defined by people who think they know
"The Truth" and use force to apply it to others.

_______________________________________________
pmtud mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pmtud

---

From: Michael Richardson <[email-masked]>
Date: Sat, 16 Oct 2004 20:23:33 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Matt" == Matt Mathis <[email-masked]> writes:
    Matt> For example:
    Matt> 20 : IPv4 in IP
    Matt> 12 : IPsec ESP_AUTH

  Not correct, really.
  You want to list end-application, not protocol.
  Typical VPN usage of IPsec is either:

	  IP ESP IPcomp IP payload

  If IPcomp fails to compress, then the overhead is:	
          ESP = 4 for SPI
              + 4 for replay counter
	      + 8 for IV
	      + 4 for block padding 
	      + 12 for HMAC
	      = 32
          IPIP+ 20
              =>52    

  VPN a la microsoft:
	IP ESP UDP L2TP PPP IP payload
       
          ESP  = 32
	  UDP  = 14
	  L2TP =  8 (as I recall)
          PPP  =  2
	  IP   = 20
          total  76

    Matt> 24 : IPsec AH, IPsec ESP_CIPHER

  Well this combination is strongly deprecated.

- --
]     "Elmo went to the wrong fundraiser" - The Simpson         |  firewalls  [
]   Michael Richardson,    Xelerance Corporation, Ottawa, ON    |net architect[
] [email-masked]      http://www.sandelman.ottawa.on.ca/mcr/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [

---

From: Fred Templin <[email-masked]>
Date: Wed, 20 Oct 2004 10:58:25 -0700 (PDT)

Matt Mathis <[email-masked]> wrote: Quick question: can somebody cite a table of common tunnel overheads?

For example:
20 : IPv4 in IP
12 : IPsec ESP_AUTH
 
Matt,
 
I'm wondering about the nature of your concern here . Are you worried about
the overhead for encapsulations that occur between the packetization layer
and the link layer within the same end node that performs packetization, i.e.,
"transport-mode" IPsec/VPN/etc.? Or, are you concerned about "tunnel mode"
encapsulations that might occur in middle boxes along the path? (Maybe my
terminology is off here, but I am assuming you meant the former even though
you said "tunnel overheads" - please correct me if I'm wrong.
 
Assuming you are talking about encapsulations that get added between the
packetization layer and the link layer, I suppose there are two components
to the question: 1) how does the packetization layer know which paths will
add the  encapsulations so that it can reduce the MPS for those paths, and
2) how does the packitization layer deal with ICMP PTB messages that
report a larger MTU size than the actual size of the packetization layer
segment used for probing (larger because IPsec/VPN/etc encapsulations
were added after packetization)? 
 
Thanks - Fred
[email-masked]

---

From: Matt Mathis <[email-masked]>
Date: Wed, 20 Oct 2004 15:28:02 -0400 (EDT)

Can you site documents for these numbers?

Have full VPNs effectively deprecated most other tunnels?  I think there are 
several flavors of IP-in-IP tunnels for things like IPv6 migration, mobility, 
etc.

Thanks,
--MM--

On Sat, 16 Oct 2004, Michael Richardson wrote:

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.2 (GNU/Linux)
> Comment: Finger me for keys
>
> iQCVAwUBQXG7b4qHRg3pndX9AQHBCwP+L5C3qX/68d6f63LINLzPJyi3+n2A0ocN
> v5EjttebgCpZquDSy/eHDJnIRKDCRSgYkX3Gb2Cb7lFF/Gwv39Td2lKvmJPya8Cz
> rwdmdld/k3/5JYsnpELCGUibTB1tOdxcaPKhwucFpim7U6U1wvY57VWGuLugiVsR
> ECYZOYx2zDo=
> =F8L4
> -----END PGP SIGNATURE-----
>

---

From: Matt Mathis <[email-masked]>
Date: Thu, 21 Oct 2004 08:54:28 -0400 (EDT)

Nothing so complicated.  I am looking for a table of likely tunnel header 
overheads (sizes).  If you know that the base MTU is 1500, what are the likely 
useful MTUs across all types of tunnel environments?  I don't care if the 
tunnel endpoints are end systems or middle boxes, or any of the other details.

This is for the PLPMTUD search heuristic.

Let me give a specific question:  If a 1044 Byte packet is delivered, and a
1500 Byte packet is not, what other sizes would you try, and why?

Is is sufficient to assume multiples of 12, 16 or 20 bytes?  Which?

Or would it be significantly to have an explicit table of common tunnel sizes?

Thanks,
--MM--

---

From: Fred Templin <[email-masked]>
Date: Thu, 21 Oct 2004 11:34:51 -0700 (PDT)

Matt Mathis <[email-masked]> wrote:
Can you site documents for these numbers?
 
Matt,
 
Here is a citation I recall seeing fly by on the old ngtrans mailing
list a couple of years ago that might help:
 
  http://www.caida.org/outreach/papers/2002/Frag/

Your questions are compelling, and I wish I had time to explore
them in more detail right now but I don't - perhaps at some later
time. Best of luck in your continued investigations.
 
Thanks - Fred
[email-masked]