Subject: Re: latest MPPE spec

From: "Glen Zorn" <[email-masked]>
Date: Thu, 26 Mar 1998 16:42:05 -0800

Robert Friend <[email-masked]> writes:

>Hi Glen,
>
>I have some minor questions and a comment about this doc.
>
>Section 5.: Are the configuration values of 0x20 and 0x40 "backwards
>compatible"?  

Yes.

>I am not sure what this means because I don't know who has
>implemented MPPE-00.  Maybe that is the answer?

Microsoft has ;-).  

>
>Section 7.7.1.: The stateless scheme seems to work well, but it seems to
>require quite a lot of resources calculating new keys.  If the packets
>are less than 256 bytes then this sounds expensive.  Of course, hardware
>would mitigate this performance hit.  :-).

Yup.

>
>Section 7.7.1.: Question: is it possible in a tunnel to receive packets
>out of order?  That is, if the receiver the following coherency counts:
>0, 2, 1.  Then how does the receiver handle the third packet (i.e. C3 =
>1)?

Drops it.

>
>Section 7.7.2.: The document does not say what the receiver does between
>the time he sends a Reset-REQ and the time he receives a packet with the
>Flush bit set.  Due to line delays, the receiver could receive several
>packets without the Flush bit set.  What does he do with them?  Silently
>Discard them?

Yes.

>
>Regards,
>_____________________________________________________________
>
>Robert C. Friend              Hi/fn
>Applications Engineering      5973 Avenida Encinas, Suite 110
>voice: (760) 827-4542         Carlsbad, CA 92008
>FAX:   (760) 827-4577         email: [email-masked]
>
>
>

---

From: Archie Cobbs <[email-masked]>
Date: Mon, 30 Mar 1998 15:17:38 -0800 (PST)

> >0, 2, 1.  Then how does the receiver handle the third packet (i.e. C3 =

This issue perhaps could use some more discussion in the draft.
Since the sequence number space is circular, implementors must
make a decision about how big a jump in the sequence number is
considered ``too big.''

If the underlying PPP link is functioning properly, then packets
should NEVER arrive out of order.. in which case a discontinuity
in sequence numbers is ALWAYS due to dropped packets. But suppose
you get sequence number N followed by sequence number N - 1. Surely
you didn't just miss 2^12-1 packets.. and it would take forever to
update your key anyway.

So I think the best strategy is to decide on a maximum allowed jump
in sequence numbers.. and if you get a jump that's too big, tear
down the connection.

-Archie

___________________________________________________________________________
Archie Cobbs   *   Whistle Communications, Inc.  *   http://www.whistle.com