Subject: Re: draft-ietf-pppext-mppe-00.txt

From: "Glen Zorn" <[email-masked]>
Date: Mon, 23 Mar 1998 13:13:06 -0800

Archie Cobbs <[email-masked]> writes:

>
>A couple of minor comments on draft-ietf-pppext-mppe-00.txt..
>
>1. The "Get_Start_Key" function is described in pseudo-code as:
>
>    Get_Start_Key(Challenge, H) {
>       SHAInit(Context)
>       SHAUpdate(Context, H, 16)
>       SHAUpdate(Context, H+Challenge, 24)
>       SHAFinal(Context, Digest)
>       memcpy(H, Digest, 16)
>    }
>
>  It would be clearer to write this as:
>
>    Get_Start_Key(Challenge, H) {
>       SHAInit(Context)
>       SHAUpdate(Context, H, 16)
>       SHAUpdate(Context, H, 16)
>       SHAUpdate(Context, Challenge, 8)
>       SHAFinal(Context, Digest)
>       memcpy(H, Digest, 16)
>    }
>
>  if that's in fact what is meant (is it??).

Nope, it means that SHAUpdate() with the challenge concatenated to H as the
second parameter.  For example, if H == "12" and Challenge == "34", then
H+Challenge == "1234".  I'll add a comment to that effect.

>
>2. Because Get_Start_Key() requires the MS-CHAP challenge value,
>   MPPE may interact badly with Multi-link PPP.. because, which
>   challenge do you use if there are multiple links?

The challenge from the first authenticator.

>
>   In pratice this is probably not likely to happen, but maybe
>   it ought to be mentioned.
>
>-Archie
>
>___________________________________________________________________________
>Archie Cobbs   *   Whistle Communications, Inc.  *   http://www.whistle.com
>

---

From: Archie Cobbs <[email-masked]>
Date: Mon, 23 Mar 1998 14:32:50 -0800 (PST)

> H+Challenge == "1234".  I'll add a comment to that effect.

Aren't these the same thing? That is,

should be equivalent to

       SHAUpdate(Context, Concatenate(H, Challenge), 24)

It just wasn't clear that "+" meant concatentation, especially since
it was only used once.

> The challenge from the first authenticator.

OK.. it would be good if this were added.

Thanks,
-Archie