Subject: Re-keying and PPP Encryption

From: Greg Carter <[email-masked]>
Date: Mon, 19 Jan 1998 17:22:44 -0500

Hi,

I have looked at RFC-1968 ECP, draft-ietf-pppext-des-encrypt-v2-01.txt,
and draft-ietf-pppext-3des-encrypt-00.txt and can't see how to refresh
the keying material.  Only that a shared secret is used.  

Am I missing something, or is it assumed that the key never changes
during the duration of the PPP connection?
Thanks.
Bye.
----
Greg Carter, Entrust Technologies
[email-masked]

>
>On Fri, 16 Jan 1998, Karl Fox wrote:
>
>> The IESG has asked me why DESE and 3DESE are Informational instead of
>> standards track documents.  If I remember correctly, it's because we
>> modeled the ECP documents on the similar CCP documents.  The CCP
>> algorithms were almost all proprietary and thus couldn't be standards
>> track, but that argument doesn't apply to DES, which is freely
>> available.
>> 
>> Does anybody object to moving DESE and 3DESE to standards track?
>> Please respond quickly if you want your opinion to count.
>> 
>

---

From: James Carlson <[email-masked]>
Date: Mon, 19 Jan 1998 20:59:01 -0500

> the keying material.  Only that a shared secret is used.

You can renegotiate ECP at any time.  I'd do this if I were changing the
key.

> during the duration of the PPP connection?

No, that's not assumed.  But it is assumed that the keys come from some
other unspecified mechanism, such as a secure hash or some kind of
database.

-- 
James Carlson			<[email-masked]>