Subject: PPP protocol numbers

From: sergey <sergey@.rad.co.il>
Date: Sun, 2 Nov 1997 06:42:31 +-200

Hello, everybody.

We have the following problem. The new RFC  2153 (PPP Vendor Extensions)  permits to define new code types and new configuration options for existing LCP and NCP protocols. But what to do if we need to develop device transferring data  for which protocol code is not defined using PPP mechanism. Which protocol code can we assign in order not to interceptc with other applications. If some procedure exists of obtaining such protocol number? Or may be there are some proposals on defining Vendor Extensions to protocol code similar to RFC 2153?

Best regards, 
Sergey Plotnikov, Senior development engineer

---

From: Craig Fox <[email-masked]>
Date: Sun, 2 Nov 97 3:47:13 PST

> 
> Hello, everybody.
> 
> We have the following problem. The new RFC  2153 (PPP Vendor Extensions)
> permits to define new code types and new configuration options for existing
> LCP and NCP protocols. But what to do if we need to develop device
> transferring data  for which protocol > code is not defined using PPP
> mechanism. Which protocol code can we assign in order not to interceptc with
> other applications. If some procedure exists of obtaining such protocol
> number? Or may be there are some proposals on defining Vendor Extensions to
> protocol code similar to RFC 2153?
> 
Such an idea was proposed by the working group chair in private discussions
at the last IETF meeting in Munich.  No action has been taken to the best
of my knowledge.  I was going to volunteer to create such a draft.  I guess
that it is time to get started.

In the meantime, you may request a proprietary protocol ID from the IANA.
How soon do you need the ID?  Can you wait for the draft to be approved for
publication?

Craig