Subject: Re: Guessing the link speed.

From: Archie Cobbs <[email-masked]>
Date: Tue, 20 Jul 1999 10:38:53 -0700 (PDT)

John R. Martz writes:
> Over the next few weeks we have to start wrestling with addressing
> how much "usage" a PPP line is getting relative to it's "capacity".
> My first thought is that I'm not sure I really know what these
> terms mean. Or how to algorithmically take a guess at what these
> values are for an active link.
> 
> Can anyone point me towards code or text that discusses these topics
> in the context of managing a PPP link? Would like to get some idea
> what others have done rather than reinvent the proverbial wheel.
> (Or worse, implement a square wheel :) In particular, I was wondering
> how the transmission speed of a link is usually determined.

We have worked on this same problem with the Whistle InterJet. Our
solution is not especially clever but it seems to work.

First, if the link layer "knows" the speed it should be able to
communicate that back up the stack. Eg, for ISDN you know each
B channel is either 64K or 56K. For a modem (if you have scripting
that is capable of this) you can set the modem to reflect actual
carrier baud rate and then have your script match the CONNECT message.

For hardware that can't tell (eg, generic synchronous serial), you
simply have to watch how long it takes to transmit a packet. If the
possible values are quantized (eg, 128K, 384K, ...) then you can
simply round up.

-Archie

___________________________________________________________________________
Archie Cobbs   *   Whistle Communications, Inc.  *   http://www.whistle.com

---

From: "John R. Martz" <[email-masked]>
Date: Tue, 20 Jul 1999 13:28:35 -0400

Folks,

Over the next few weeks we have to start wrestling with addressing how much "usage" a PPP line is
getting relative to it's "capacity". My first thought is that I'm not sure I really know what these
terms mean. Or how to algorithmically take a guess at what these values are for an active link.

Can anyone point me towards code or text that discusses these topics in the context of managing a
PPP link? Would like to get some idea what others have done rather than reinvent the proverbial
wheel. (Or worse, implement a square wheel :) In particular, I was wondering how the transmission
speed of a link is usually determined.

Figured it never hurts to post and ask ....

Thanks,
-john martz ([email-masked])
IBM AS/400 TCP/IP PPP (and stuff)

---

From: "Karl Fox" <[email-masked]>
Date: Tue, 20 Jul 1999 13:59:56 -0400

At 10:38 AM 7/20/99 -0700, Archie Cobbs wrote:
>For a modem (if you have scripting

Of course, compressing modems are hard, as their actual throughput varies 
from moment to moment depending on the compressibility of the data being sent.

Karl Fox <[email-masked]>
Key fingerprint = 5B15 7260 D55E D680 0B93  4953 8A3B AB0E C05D 77A3

---

From: Archie Cobbs <[email-masked]>
Date: Tue, 20 Jul 1999 11:03:04 -0700 (PDT)

> from moment to moment depending on the compressibility of the data being sent.

Right.. plus I forgot to mention that they can transparently renegotiate
in face of +/- line noise.

Another approach is to apply the 'packet watching' heuristic in the
modem case, averaged over time.

-Archie