Subject: RE: Guessing the link speed.

From: Andy Koscinski <[email-masked]>
Date: Tue, 20 Jul 1999 11:21:06 -0700

> -----Original Message-----
> From: Archie Cobbs [mailto:[email-masked]]
> Sent: Tuesday, July 20, 1999 10:39 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Guessing the link speed.
> 
> 
> John R. Martz writes:
> > Over the next few weeks we have to start wrestling with addressing
> > how much "usage" a PPP line is getting relative to it's "capacity".
> > My first thought is that I'm not sure I really know what these
> > terms mean. Or how to algorithmically take a guess at what these
> > values are for an active link.
> > 
> > Can anyone point me towards code or text that discusses these topics
> > in the context of managing a PPP link? Would like to get some idea
> > what others have done rather than reinvent the proverbial wheel.
> > (Or worse, implement a square wheel :) In particular, I was 
> wondering
> > how the transmission speed of a link is usually determined.
> 
> We have worked on this same problem with the Whistle InterJet. Our
> solution is not especially clever but it seems to work.
> 
> First, if the link layer "knows" the speed it should be able to
> communicate that back up the stack. Eg, for ISDN you know each
> B channel is either 64K or 56K. 

I think the question was about the "usage" (e.g. 30K data over 64K
channel)
relative to "capacity" (e.g. ISDN = 64K)

> For a modem (if you have scripting
> that is capable of this) you can set the modem to reflect actual
> carrier baud rate and then have your script match the CONNECT message.
> 
> For hardware that can't tell (eg, generic synchronous serial), you
> simply have to watch how long it takes to transmit a packet. If the
> possible values are quantized (eg, 128K, 384K, ...) then you can
> simply round up.

again the question was about usage, not the speed.
You can have a PPP link over multi segment physical links
(e.g. ISDN to LAC and then OC3 to LNS). 
I'd like to know about existing solution with an answer to the question
about the usage rate of a PPP link.

I can think about possibile soultions in the future: 
e.g. meter the data coming in over the PPP link in the receiving
hardware module.

[email-masked]
 
> 
> -Archie
> 
> ______________________________________________________________
> _____________
> Archie Cobbs   *   Whistle Communications, Inc.  *   
http://www.whistle.com

---

From: Archie Cobbs <[email-masked]>
Date: Tue, 20 Jul 1999 11:31:43 -0700 (PDT)

> again the question was about usage, not the speed.

? Knowing the usage is trivial, once you know the speed (ie, capacity).
You just count the bits moved each second and divide by the capacity
to get a percentage. Or am I missing something.

-Archie

___________________________________________________________________________
Archie Cobbs   *   Whistle Communications, Inc.  *   http://www.whistle.com