Subject: PPP

From: "Bill Cunningham" <[email-masked]>
Date: Sat, 23 Feb 2002 23:53:35 -0500

I'm a little fuzzy on PPP. I was reading rfc 1661 and does the LCP and NCP aspect of PPP establish a link then their work and that of PPP is done for the session ? Then it's up to TCP and UDP to continue throughout the session. Or is all PPP communication during a session done in PPP packets?

---

From: Archie Cobbs <[email-masked]>
Date: Sun, 24 Feb 2002 11:08:44 -0800

> I'm a little fuzzy on PPP. I was reading rfc 1661 and does the LCP and NCP aspect of PPP establish a link then their work and that of PPP is done for the session ? Then it's up to TCP and UDP to co…

The latter is true. PPP defines it's own sub-protocol numbers for
LCP, IPCP, etc. (the negotiation protocols) as well as for actual
data packets (IP, IPX, AppleTalk, etc.).

TCP and UDP are just instances of IP, as far as PPP is concerned
(Van Jacobsen compression notwithstanding).

-Archie

__________________________________________________________________________
Archie Cobbs     *     Packet Design     *     http://www.packetdesign.com