Subject: Archives

From: "Affan Ahmed" <[email-masked]>
Date: Sun, 17 Feb 2002 21:55:06 -0800

hello every one.. 
i need some clarification regarding the automaton described in rfc 1661. Archives would help. Where do i get them.
  other wise my q are

1) tls and tlf are implementation dependent, yes but could some body please translate them into an event to a lower state machine... say IPCP was performing these action(no auth fsm) to the LCP automaton what should it do.

2)how are spurious retransmission of conf req's handled at a peer that has already ack a previous one before getting a new one due to tranmission latencies..

thank you all

Check out Cupid School where you will learn from Matchmaker's
best and brightest. Good Luck!

http://ecard.matchmaker.com/cupid0202/cupid0202.html

---

From: Barney Wolff <[email-masked]>
Date: Mon, 18 Feb 2002 01:32:32 -0500

> 1) tls and tlf are implementation dependent, yes but could some body please translate them into an event to a lower state machine... say IPCP was performing these action(no auth fsm) to the LCP aut…

The conceptual model here is that control flows from above, which may not
be how any particular implementation works.  If IPCP says tls, LCP should
interpret it as an Open event; tlf would translate to a Close if no other
NCPs were operating.

> 2)how are spurious retransmission of conf req's handled at a peer that has already ack a previous one before getting a new one due to tranmission latencies..

There is no such thing in PPP as a spurious retransmission.  There is no
transport layer as there is in L2TP.  The PPP state machine includes the
cases where you get a request again after having ACK'd it.  Just follow
the state machine and you'll be fine.  Of course if your peer never stops
retransmitting you will never reach the Opened state - that's why it's
wise to have an overall timeout after which you give up, if you're not on
an "always up" line.

-- 
Barney Wolff

"Nonetheless, ease and peace had left this people still curiously
tough.  They were, if it came to it, difficult to daunt or to kill;
and they were, perhaps, so unwearyingly fond of good things not
least because they could, when put to it, do without them, and could
survive rough handling by grief, foe, or weather in a way that
astonished those who did not know them well and looked no further
than their bellies and their well-fed faces." J.R.R.T.