Subject: Re: PPP question on draft-ietf-ccamp-lmp-test-sonet-sdh-02.txt

From: Jonathan Sadler <[email-masked]>
Date: Thu, 03 Apr 2003 10:59:30 -0600

James -

James Carlson wrote:

> Jonathan Sadler writes:
> > Since the test message is going between two immediate neighbors on a PPP
> > link, there is no need to include IP or UDP in the messages.  Instead, two
> > methods exist that conform with the RFC 1661 may be used:
> >  - Use the Identification LCP message as defined in RFC 1570
> >  - Have the LMP test message carried as an LCP option when
> >    LCP negotiation is done on the PPP link.
>
> Here's a third: create an LMP "network protocol."  I'd be happier with
> that than with either an LCP option or hijacking the Identification
> message.  Note that it's not actually necessary for any network
> protocol in PPP to have a corresponding NCP to negotiate anything, so
> you could just open LCP and then send your "network layer messages"
> (actually LMP test messages).  (Each network layer protocol is
> separately defined for this reason; each can define its own
> procedures.)

LCP is not likely to reach the "open" state if server layer is
mis-connected/mis-wired(ie. Node A Port 1 Tx -> Node B Port 1 Rx & Node B Port 1
Tx -> Node A Port 2 Rx).  Consequently, using a new NCP would yield LMP unable to
assist in troubleshooting mis-connection/mis-wiring cases.  This is one of the
stated uses of the connectivity verification (TEST) process.

> Since you send them infrequently and header compression isn't much of
> an issue, you could use the relatively open 4xxx range of protocol
> IDs.
>
> > The first method has benefits over the later as:
> >  - the identification field provides a "method for an
> >    implementation to identify itself to its peer."  The test
> >    message defined by LMP contains "TE Link" identification.
>
> Er ... ok.  The intent of the Identification field is to provide a
> software version string that can be placed in a log file for a human
> to determine what might have gone wrong with a broken link.  I agree
> that there's no "standard" for what is placed there, but placing
> machine-readable data into a field intended for text seems to be an
> abuse to me.
>
> Worse, if you did this, nobody would be able to use LCP Identification
> on SONET/SDH for its intended purpose, and that would seem to me to
> represent a net loss.
>
> >  - there is no need for a new code point (and related
> >    behavior) to be defined
> >  - a test message can be sent at any time, independent of PPP
> >    protocol state
>
> That'd be also true if you created a new network layer number.
>
> > Because of these reasons, the ITU chose the first methods for G.7714.1.
> >
> > A related question is: do we need two different methods for passing the "TE
> > Link" id in-band to verify the connectivity of a link endpoint?
>
> Fewer would certainly be better.  One would be ideal.
>
> --
> James Carlson, Solaris Networking         <[email-masked]>
> Sun Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
> MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677

============================================================
The information contained in this message may be privileged 
and confidential and protected from disclosure.  If the 
reader of this message is not the intended recipient, or an 
employee or agent responsible for delivering this message to 
the intended recipient, you are hereby notified that any 
reproduction, dissemination or distribution of this 
communication is strictly prohibited. If you have received 
this communication in error, please notify us immediately by 
replying to the message and deleting it from your computer.

Thank you.
Tellabs
============================================================

---

From: James Carlson <[email-masked]>
Date: Thu, 3 Apr 2003 12:04:22 -0500

> stated uses of the connectivity verification (TEST) process.

I see.  It would still be nice to avoid taking over LCP
Identification.  A new code number would do the trick.