Subject: Re: [ppsp] survey and problem statement of P2P streaming

From: "yunfei zhang" <[email-masked]>
Date: Tue, 18 Nov 2008 23:36:17 +0800

Hi,This is Yunfei.I met with the same problem as Jun has when I use
[email-masked] for posting.So I suspect this is a single
case.And I contacted with Steve Young for solving this problem.
Unfortunately seems this issue isn't solved yet.Glen, how can I find you in
Hilton?I think ppsp mailing list needs your help.Many times I have to email
to all reciptants directly by their email instead of [email-masked].

                                       Yunfei

2008/11/18, Lars Eggert <[email-masked]>:
>
> Hi,
>
> I'm CC'ing Glen, who is our main contact at the secretariat for this, and
> mailing list admins.
>
> Could you three try and meet with Glen in person and debug these issues? At
> least Glen and Yunfei are both here in Minneapolis, so hopefully that lets
> us resolve these issues quickly.
>
> Thanks,
> Lars
>
> Please
> On 2008-11-18, at 2:56, ext Jun Lei wrote:
>
> Lars Eggert wrote:
>>
>>> Please CC the mailing list on these discussions, otherwise there is no
>>> archived record.
>>>
>>> Thanks,
>>> Lars
>>>
>> Hi, Lars,
>>
>> I tried several times by cc the mailing list, however, my email seems to
>> be stucked somewhere.
>>
>> Do you have any idea about it? or the mailing list still has problems?
>>
>>
>> Cheers
>>
>> Jun
>>
>
>
>
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Glen <[email-masked]>
Date: Tue, 18 Nov 2008 08:39:40 -0800

I am no longer at the meeting, as I had to fly back last night.

However, I am in the office, and will look into this momentarily.

Glen

yunfei zhang wrote:
> [email-masked] <mailto:[email-masked]> for
> posting.So I suspect this is a single case.And I contacted with Steve
> Young for solving this problem. Unfortunately seems this issue isn't
> solved yet.Glen, how can I find you in Hilton?I think ppsp mailing list
> needs your help.Many times I have to email to all reciptants directly by
> their email instead of [email-masked] <mailto:[email-masked]>.
>  
>  
>                                        Yunfei
> 
>  
> 2008/11/18, Lars Eggert <[email-masked]
> <mailto:[email-masked]>>:
> 
>     Hi,
> 
>     I'm CC'ing Glen, who is our main contact at the secretariat for
>     this, and mailing list admins.
> 
>     Could you three try and meet with Glen in person and debug these
>     issues? At least Glen and Yunfei are both here in Minneapolis, so
>     hopefully that lets us resolve these issues quickly.
> 
>     Thanks,
>     Lars
> 
>     Please

---

From: Glen <[email-masked]>
Date: Tue, 18 Nov 2008 08:57:39 -0800

Dear Yunfei:

In the case of Jun, I see that his email address is coming in, and being
accepted, and being processed normally.   So I need him to contact me
immediately the next time a message to this list fails, so that I can
trace it.  I need the date and time, preferably in GMT, that the message
was sent.  Processing time is fast, so he should know within one hour
that his email did not go through, and contacting us immediately when
that happens will enable us to find it more quickly.

It appears to us that his email may have been going to moderation, so
please be careful when dumping moderated messages to ensure no mail is
waiting from him.

In the case of your own email, I see no evidence of any mail from your
China Mobile address coming in.  So I will make the same request of you.
 The next time you send a message to the list from your CM address,
please email me and let me know the date and time and I will trace it here.

Glen

---

From: <[email-masked]>
Date: Tue, 18 Nov 2008 17:38:26 +0000

OK, so folk who had problems sending to the list should try again ASAP and
let Glen know so he can debug. (Maybe CC him on the test mail.)

Lars

---

From: Jun Lei <[email-masked]>
Date: Tue, 18 Nov 2008 18:44:04 +0100

Hi, Glen,

I've just forwarded the failed email to the PPSP mailing list again.  
Will you be able to trace it?

Cheers

Jun (Ms.)

---

From: Jun Lei <[email-masked]>
Date: Tue, 18 Nov 2008 18:46:31 +0100

Hi, Ning Zong, all:
>
> please see comments inline.
>   

> >> Thanks so much for zongnong's contribution.It offers much new knowledge to me.I have several suggestions on this survey:
> >> 1)Buffer map can used not only in VoD,but in live streaming.You can refer to the following paper:Measurement of Commercial Peer-To-Peer Live Video Streaming,Shahzad Ali, Anket Mathur and Hui Zhang,School of Computer Science,Carnegie Mellon University.
> >>   
> >>     
>   
> Buffering/caching techniques would be certainly an interesting point for
> further investigations, either for live streaming or VoD systems. I
> would give two cents here.
>   

> >> 2)I notice that some people have doubts on whether VoD should be considered in PPSP and it would be great if we can compare in the survey on what's the common parts in the signalling and transmission process of live and VoD streaming and what's the differnt parts;
> >> 3)It's an interesting topic to compare p2p stremaing performance using TCP and UDP,and we see that different systems have different strategies in this issue.This is a baseline we draw up PPSP transmission protocol.
> >>   
> >>     
>   
> Yeah. This issue has also been investigated in our report about VoD
> system investigations
> "http://www.net.informatik.uni-goettingen.de/publications/1484/Joost_experiment.pdf".
> We explored the fact that especially in wireless scenarios TCP will be
> the main transport protocol as the stability and re-transmission might
> be necessary.
>
> Besides, this doc didn't mention why is there difference between PPLive
> and PPStream using different transport protocols. Under which
> circumstances, which protocol is preferred??
>   

> >> 4)It would be better to have an overall System Architecture and Working Flows for ppstream,SOPCast and TVAnts as well as their traffic account in the Internet to show they really share a common structure.
> >>   
> >>     
>   
> Totally agree!
>   

> >> 5)I suggest to merge part3 into problem statement document as they belong to one topic and have some similar discussion.
> >> 6)As for part3.2,I feel that PPSP include both signalling and transmission protcol because signalling protocol alone cannot solve all the problems p2p streaming faces with.For example,many of the delay problem stated in "problem statement document" I sent cannot slove by signalling protocol only.It relates to many transmission factors,such as the point I mentioned above to compare the performance using TCP or UDP or both; the effect examination of using RTP or should we design a new p2p transmission protocol above TCP/UDP(the position is same as RTP)to faciliate chunk transmission to realize real-time streaming with multiple simultaneous sources where RTP may be unsuitable.
> >> Thereforethe transmission protocol should be included in PPSP.
> >> Just two cents.
> >>
> >>
> >> Yunfei
> >>   
> >>     
>   
> Additionally, I am afraid that I have a couple of questions and doubts.
> Maybe it is just my opinion,
>
> 1. The structure of this draft is rather dis-ordered. Therefore, it is
> very hard to understand the real purpose of this doc. Besides, please
> re-organize the reference part with published conference/journal, year,
> month....
>
> I would suggest follow the usual order with 1) introduction; 2) related
> work/summary of existing work; 3) problem statement......
>
> 2. Since it is called "survey and problem statement ....", however, it
> is not really a survey, nor a problem statement to me. Only four
> applications are mentioned in a very dis-ordered way. There is no
> specific problem investigations?
>
> I would suggest to have 1) a high level overview of the existing
> mechanisms; 2) a summary of them with PPSP's intension/focus; 3) explore
> the existing problem/gaps to fit for PPSP; 4) consider possible
> solutions either use existing approaches or extend them.
>
> 3. Most of the detailed are motivated from reference [7] which is not a
> high level paper.
>
> 4. IMO, most of the contents are not in the first place of our focus,
> for example, how does a buffer map in PPLive work? how does PPLive work
> with media player? they are not the main focus of PPSP in the current stage.
>
> 5. For Section 3.1. where are the exact requirements? could you please
> list them? instead of proposing a hybrid CDN and P2P streaming
> architecture.....
>
>
> Hopefully, we can come up with some good problem statement  :-) 
>
> Cheers
>
>
> Jun
>   

> >> =======您在来信中写到：=======
> >> Hi, all,
> >> Please find the attached Survey and Problem Statement of P2P Streaming. I hope it would be one of baseline documents for discussion during the incoming PPSP bar BoF. Any comments and suggestions are welcome.
> >> Thank you!
> >>
> >> Best Regards
> >> Ning Zong
> >>
> >> ******************************************************************************************
> >> This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or em
> >> ail immediately and delete it!
> >> *****************************************************************************************
> >>
> >> - Survey and Problem Statement of P2P Streaming.pdf

---

From: "Steve Young" <[email-masked]>
Date: Tue, 18 Nov 2008 09:54:18 -0800

Hi,

I see in the logs...

Nov 18 09:44:11 2008 (4918) post to ppsp from
[email-masked], size=5628,
message-id=<[email-masked]>, success
Nov 18 09:46:36 2008 (4918) post to ppsp from
[email-masked], size=10366,
message-id=<[email-masked]>, success

So I am assuming that the email got sent to the list recipients ok.

If that's not the case please let me know.

Thanks,
Steve

> -----Original Message-----
> From: Jun Lei [mailto:[email-masked]]
> Sent: Tuesday, November 18, 2008 9:44 AM
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: *****SPAM***** Re: [ppsp] survey and problem statement of P2P
streaming
> >>>         I tried several times by cc the mailing list, however, my
email
> >>>         seems to