Subject: [ppsp] PPSP Protocols

From: "Victor Pascual Ávila" <[email-masked]>
Date: Wed, 26 Nov 2008 12:07:56 +0100

Hi,
(trying to catch up with the discussion)

PPSP Signaling Protocol:

On Thu, 23 Oct 2008 11:02:44 +0800, Song Haibin posted a message[1]
that does not seem to have generated much echo (browsing the
discussion archive I failed to find any response).

[1] http://www.ietf.org/mail-archive/web/ppsp/current/msg00005.html

Is there any significant difference between "PPSP Signaling Procotol"
and "P2PSIP Peer Protocol + SIP + OTSp2p-like algorithm"?

PPSP Transmission Protocol:

Why isn't RTP sufficient for this?

Cheers and excuse me if it has been already discussed,
-- 
Victor Pascual Ávila
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Das, Saumitra" <[email-masked]>
Date: Sun, 30 Nov 2008 18:39:06 -0800

I think these are some of the things that need to be discussed based on the Minn BOF.

1. Can PPSP signaling be overlaid as a usage on top of RELOAD. I think this can be a separate usage for reload on the same level as SIP. One obvious use is to implement a distributed tracker. Now whether reload should be used for exchanging bitmaps etc (if that is what we determine the main thing the signaling does) by making direct nodeid->nodeid connections; should be discussed.

2. I agree we need to define what are the goals of the PPSP transmission protocol. Since this is on demand/live streaming ledbat does not apply. Can we reuse some existing transport?

But before these questions, I think the main question the BOF brought up is what exactly is being standardized here (which components of the overall problem) and why.

Thanks,
Saumitra

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Victor Pascual Ávila
Sent: Wednesday, November 26, 2008 3:08 AM
To: [email-masked]
Subject: [ppsp] PPSP Protocols

Hi,

PPSP Signaling Protocol:

---

From: "yunfei zhang" <[email-masked]>
Date: Mon, 1 Dec 2008 17:27:13 +0800

We have discussed these issues in the mailing list.Unfortunately there were
something wrong with the mailing list last month and the discussion didn't
appear in the mailing list.
I'd like to answer this question once again.
1)As mentioned in the presentation and the problem statement document in the
bar bof, PPSP signaling protocol has a similar stack position as P2PSIP.But
P2PSIP doesn't meet the rigid real-time requirements in live and vod
streaming due to the searching inefficency.Moreover the heavyweight
signaling overhead in P2PSIP isn't suitable for streaming applications.
2)RTP seems unsuitable for PPSP transmission for the following reasons:
   a)The timing and syn information in RTP is of no use in one-to-many
envirnment which achieves the similar effect using a different means;but we
will still explore the feasibilty of using RTP in p2p streaming
envrinment.This is one of the main tasks in PPSP transmission part.
   b)In current practice UDP is mostly used for P2P transmission and it
proves to be efficent;

                                       Yunfei

---

From: "yunfei zhang" <[email-masked]>
Date: Mon, 1 Dec 2008 17:36:06 +0800

Hi,Das,Thanks for your comments.
1)It's unsuitable viewing PPSP a overlaid usage on top of RELOAD.But as
mentioned in the bar bof, the work of distributing trackers can use P2PSIP
as the supporting protocol.
As for exchanging bitmap,it's a task of using direct connection between two
NOT-KNOWN-BEFORE nodes,so there are no nodeid->nodeid connections that can
be built in PPSP envrinment.
2)I agree with you in this point.In fact we should discuss the possibilty of
reusing current IETF protocols in both signaling and transmission protocols
since we need to limit the scope of PPSP.
I agree with you that the main question the BOF brought up is what exactly
is being standardized here (which components of the overall problem) and
why.I'd like to launch a discussion in PPSP mailing list shortly.

                           Yunfei

2008/12/1, Das, Saumitra <[email-masked]>:
> 1. Can PPSP signaling be overlaid as a usage on top of RELOAD. I think this
> can be a separate usage for reload on the same level as SIP. One obvious use
> is to implement a distributed tracker. Now whether reload should be used for
> exchanging bitmaps etc (if that is what we determine the main thing the
> signaling does) by making direct nodeid->nodeid connections; should be
> discussed.
>
> 2. I agree we need to define what are the goals of the PPSP transmission
> protocol. Since this is on demand/live streaming ledbat does not apply. Can
> we reuse some existing transport?
>
> But before these questions, I think the main question the BOF brought up is
> what exactly is being standardized here (which components of the overall
> problem) and why.
>
> Thanks,
> Saumitra
>