Subject: Re: [ppsp] ppsp charter discussion

From: Ning Zong <[email-masked]>
Date: Thu, 10 Sep 2009 15:59:48 -0300

Hi, Ping,

Thank you for your comments, please see in-line.

Ning,

I'd think that it is very important to emphasis the target users of the work, which has been quoted as "intelligent endpoints, caches, content distribution network nodes, and/or other edge devices."

[Ning Zong] This is a good suggestion.

If possible, I would hope that further specification, clarification and constraints to be added in one of the documents.

The reasoning is that, if the work is to enable further proliferation of P2P clients within the networks, then the WG needs to address issues including security, privacy and copyrights extensively. This may be above and beyond technology, and is probably outside the scope of PPSP.

On the other hand, if the work is to enable more efficient streaming content distribtution within a controlled environment by leveraging mechanisms such as tracker management and chuck discovery, then the work is well understood, and can be clearly defined, specified and experimented in the near future.

[Ning Zong] If I understand your question correctly, this is related to the incentives of PPSP work. The clarification of incentives are further provided in problem statement. IMO, the second point in your comments is closer to current intention of PPSP. To be brief, the intention include (maybe not limited to): 1) enable more efficient streaming to integrate 3rd party devices, e.g. cache/CDN nodes; 2) enable streaming vendors to accomplish content distribution via some standard API, thus reduce the time-to-market and maybe cost, we hope; 3) enable ISPs to construct standard streaming platform to run content provisioning services.

2 cents,

- Ping

2009/9/10 Ning Zong <[email-masked]>

Hi, Lucy

The participating entities in the first paragraph include both peers and trackers in P2P streaming systems. In second paragraph, we discuss the roles of trackers - assuming that people know the basic meaning of peers.
Formal definitions of PPSP peers and PPSP trackers are defined in Problem Statement Draft.

BR,
Ning Zong

Hi YunFei and Christian,

One clarification: “participating entities” listed in the text are the peer in P2P streaming systems, is that right? Thus, “PPSP” trackers are another participator in the systems.  Suggest stating that clearly in the first paragraph.

Cheers,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Schmidt, Christian 1. (NSN - DE/Munich)
Sent: Thursday, September 10, 2009 3:03 AM
To: ext zhangyunfei; [email-masked]
Subject: Re: [ppsp] ppsp charter discussion

Hi Yunfei,
after reading your charter proposal, a text proposal and 2 questions for clarifications.

Best Regards
Christian Schmidt

Proposed new text for more transparency in main description:
Old text:
The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is chartered to develop standard signaling protocols (called PPSP protocols) for multiple types of entities (e.g. intelligent endpoints, caches, content distribution network nodes, and/or other edge devices) to participate in P2P streaming systems in both fixed and mobile Internet.

PPSP protocols include the PPSP tracker protocol – a signaling protocol between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of participating PPSP peers, each for a specific channel or streaming file, and answers the queries from PPSP peers for candidate PPSP peers. PPSP peers inform their status information to PPSP trackers, exchange their chunk availability with other PPSP peers and/or PPSP trackers, and ask other PPSP peers for wanted data. 

New text:
The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is chartered to develop standard signaling protocols (called PPSP protocols) for P2P streaming systems in both fixed and mobile Internet. Participating entities could be intelligent endpoints, caches, content distribution network nodes, and/or other edge devices.

For a specific channel or streaming file, a PPSP tracker maintains lists of particiating PPSP peers. The PPSP tracker answers queries from PPSP peers for candidate PPSP peers. PPSP peers provide their status information to PPSP trackers, exchange their chunk availability with other PPSP peers and/or PPSP trackers, and ask other PPSP peers for wanted data. PPSP protocols include the PPSP tracker protocol – a signaling protocol between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling protocol among “PPSP peers”. 

Architectural survey
3. An "architectural survey" document explaining the current P2P streaming architectures, in particular tracker-based P2P streaming, and key issues in best practice.
It is good to have a description of the current P2P streaming architecture. What is missing is the relation to the PPSP work. Will it contain a proposal for the PPSP architecture?

Usage document
6. A “usage document” explaining how the protocols defined above, along with existing IETF protocols, such as RELAOD, ALTO and RTSP, can inter-operate; and how they may be integrated together to produce complete P2P streaming systems.
This sounds more like a "interop document". Was this the intention?

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext zhangyunfei
Sent: Thursday, September 10, 2009 8:24 AM
To: [email-masked]
Subject: [ppsp] ppsp charter discussion

Dear all,
   The following is the modified version of PPSP charter(An early version was published in the IETF PPSP wiki page).Please review it and any comments and suggestions are highly appreciated.

           BR
            Yunfei
--------------------------------------------------------
Description of PPSP Working Group:
The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is chartered to develop standard signaling protocols (called PPSP protocols) for multiple types of entities (e.g. intelligent endpoints, caches, content distribution network nodes, and/or other edge devices) to participate in P2P streaming systems in both fixed and mobile Internet.

PPSP protocols include the PPSP tracker protocol – a signaling protocol between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of participating PPSP peers, each for a specific channel or streaming file, and answers the queries from PPSP peers for candidate PPSP peers. PPSP peers inform their status information to PPSP trackers, exchange their chunk availability with other PPSP peers and/or PPSP trackers, and ask other PPSP peers for wanted data. 

This WG's primary tasks are to produce:
1. A “problem statement” document describing the problems, incentives, and scope of developing the PPSP protocols, as well as common terminologies and concepts.

2. A “requirements” document listing the requirements on the designed PPSP protocols (e.g., general functionality and performance requirements of PPSP protocols or basic types of information that PPSP protocols should communicate to facilitate P2P streaming).

3. An "architectural survey" document explaining the current P2P streaming architectures, in particular tracker-based P2P streaming, and key issues in best practice.

4. A proposed standard defining the PPSP peer protocol. This protocol will define how PPSP peers advertise chunk availability. The protocol will also define the requests and responses of chunks among PPSP peers.

5. A proposed standard defining the PPSP tracker protocol. This protocol will define how PPSP peers inform and request information from PPSP trackers and how PPSP trackers reply to the requests.

6. A “usage document” explaining how the protocols defined above, along with existing IETF protocols, such as RELAOD, ALTO and RTSP, can inter-operate; and how they may be integrated together to produce complete P2P streaming systems.

7. Optionally a ”mobile usage document” (PPSP mobile BCP document) to evaluate PPSP with and without Mobile IP support when there are a lot of mobile peers in the system.

The work planned for the PPSP WG is distinct from, but requires close participation with, work in other IETF WGs, particularly P2PSIP, ALTO and MMUSIC. The PPSP WG assumes that it cannot modify baseline P2PSIP, ALTO, and MMUSIC behaviors. If PPSP determines that extensions to P2PSIP, ALTO, MMUSIC are needed, PPSP will seek to define such extensions and present to the respective working groups.

The design of PPSP has to consider security/privacy issues. The protocol document will contain a complete description of the security/privacy issues that PPSP should address.

The following topics are excluded from this WG's scope:
1. Transport mechanisms for data transmission among PPSP peers, e.g. using TCP or UDP, unicast or multicast, etc.

2. Network coding mechanisms in P2P streaming. Network coding may be used in P2P streaming, but its support is beyond the scope of current charter.

3. Play-out mechanisms including streaming control (e.g., pause, fast-forward, and rewind).

4. Algorithms that may be different in different deployments (e.g., chunk selection, local storage strategies).

5. Research type questions related to P2P streaming. This WG will instead forward such questions to the IRTF P2PRG or other RG as appropriate. Examples include cache management.
Goals and Milestones:
Apr 2010Working Group Last Call for problem statement
Jun 2010Submit problem statement to IESG as Informational document
Aug 2010Working Group Last Call for architecture survey
Aug 2010Working Group Last Call for requirements
Oct
2010Submit architecture survey to IESG as Informational document
Oct 2010Submit requirements to IESG as Informational document
Apr 2011Working Group Last Call for PPSP peer protocol
Apr
2011Working Group Last Call for PPSP tracker protocol
Aug 2011Submit PPSP peer protocol to IESG as Proposed Standard
Aug 2011Submit PPSP tracker protocol to IESG as Proposed Standard
Nov 2011Working Group Last Call of usage document
Nov 2011Working Group Last Call of mobility BCP document
Jan 2012Submit usage document to IESG as Informational document
Jan 2012Submit mobility BCP document to IESG as Informational document
Apr 2012Dissolve or re-charter 

zhangyunfei
2009-09-10

_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Ping Pan <[email-masked]>
Date: Thu, 10 Sep 2009 12:37:01 -0700

Ning,
We are in agreement here. So, you have listed three objectives for PPSP:

1. Standard interface to CDN/Cache
2. Enable media providers to stream content through standard interfaces
3. Help the service providers to manage their network/links better.

So, curious, does it require the end users to run PPSP as well? The problem
statement draft (draft-zhang-ppsp-problem-statement-04.txt) seems to assume
that is the case. (If I am not mistaken, all the "proprietary protocols"
listed in Section 3.1 are client P2P applications). If yes, you have a wide
scope of non-technical issues to deal with. If no, then you need to make it
clear in the documents.

Thanks for clarification.

Ping

>  ------------------------------
>  Ning,
>
> I'd think that it is very important to emphasis the target users of the
> work, which has been quoted as "intelligent endpoints, caches, content
> distribution network nodes, and/or other edge devices."
>
> If possible, I would hope that further specification, clarification and
> constraints to be added in one of the documents.
>
> The reasoning is that, if the work is to enable further proliferation of
> P2P clients within the networks, then the WG needs to address issues
> including security, privacy and copyrights extensively. This may be above
> and beyond technology, and is probably outside the scope of PPSP.
>
> On the other hand, if the work is to enable more efficient streaming
> content distribtution within a controlled environment by leveraging
> mechanisms such as tracker management and chuck discovery, then the work is
> well understood, and can be clearly defined, specified and experimented in
> the near future.
>
> [Ning Zong] If I understand your question correctly, this is related to the
> incentives of PPSP work. The clarification of incentives are further
> provided in problem statement. IMO, the second point in your comments is
> closer to current intention of PPSP. To be brief, the intention include
> (maybe not limited to): 1) enable more efficient streaming to integrate 3rd
> party devices, e.g. cache/CDN nodes; 2) enable streaming vendors to
> accomplish content distribution via some standard API, thus reduce
> the time-to-market and maybe cost, we hope; 3) enable ISPs to
> construct standard streaming platform to run content provisioning services.
>
> 2 cents,
>
> - Ping
>
>> The participating entities in the first paragraph include both peers and
>> trackers in P2P streaming systems. In second paragraph, we discuss the roles
>> of trackers - assuming that people know the basic meaning of peers.
>>  ------------------------------
>>
>> Hi YunFei and Christian,
>>
>>
>>
>> One clarification: “participating entities” listed in the text are the
>> peer in P2P streaming systems, is that right? Thus, “PPSP” trackers are
>> another participator in the systems.  Suggest stating that clearly in the
>> first paragraph.
>>
>>
>>
>> Cheers,
>>
>> Lucy
>>
>>
>>   ------------------------------
>>
>> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
>> Of *Schmidt, Christian 1. (NSN - DE/Munich)
>> *Sent:* Thursday, September 10, 2009 3:03 AM
>> *To:* ext zhangyunfei; [email-masked]
>> *Subject:* Re: [ppsp] ppsp charter discussion
>>
>>
>>
>> Hi Yunfei,
>>
>> The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
>> chartered to develop standard signaling protocols (called PPSP protocols)
>> for multiple types of entities (e.g. intelligent endpoints, caches, content
>> distribution network nodes, and/or other edge devices) to participate in P2P
>> streaming systems in both fixed and mobile Internet.
>>
>>
>> PPSP protocols include the PPSP tracker protocol – a signaling protocol
>> between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a
>> signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of
>> participating PPSP peers, each for a specific channel or streaming file, and
>> answers the queries from PPSP peers for candidate PPSP peers. PPSP peers
>> inform their status information to PPSP trackers, exchange their chunk
>> availability with other PPSP peers and/or PPSP trackers, and ask other PPSP
>> peers for wanted data.
>>
>>
>>
>> New text:
>>
>> The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
>> chartered to develop standard signaling protocols (called PPSP
>> protocols) for P2P streaming systems in both fixed and mobile Internet.
>> Participating entities could be intelligent endpoints, caches, content
>> distribution network nodes, and/or other edge devices.
>>
>>
>>
>> For a specific channel or streaming file, a PPSP tracker maintains lists
>> of particiating PPSP peers. The PPSP tracker answers queries from PPSP peers
>> for candidate PPSP peers. PPSP peers provide their status information to
>> PPSP trackers, exchange their chunk availability with other PPSP peers
>> and/or PPSP trackers, and ask other PPSP peers for wanted data. PPSP
>> protocols include the PPSP tracker protocol – a signaling protocol between
>> “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling
>> protocol among “PPSP peers”.
>>
>>
>>
>> Architectural survey
>>
>> 3. An "architectural survey" document explaining the current P2P streaming
>> architectures, in particular tracker-based P2P streaming, and key issues in
>> best practice.
>>
>> It is good to have a description of the current P2P streaming
>> architecture. What is missing is the relation to the PPSP work. Will it
>> contain a proposal for the PPSP architecture?
>>
>>
>>
>> Usage document
>>
>> 6. A “usage document” explaining how the protocols defined above, along
>> with existing IETF protocols, such as RELAOD, ALTO and RTSP, can
>> inter-operate; and how they may be integrated together to produce complete
>> P2P streaming systems.
>>
>>  ------------------------------
>>
>> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
>> Of *ext zhangyunfei
>> *Sent:* Thursday, September 10, 2009 8:24 AM
>> *To:* [email-masked]
>> *Subject:* [ppsp] ppsp charter discussion
>>
>> **
>>
>> *Dear all,*
>>
>> *   The following is the modified version of PPSP charter(An early
>> version was published in the IETF PPSP wiki page).Please review it and any
>> comments and suggestions are highly appreciated.*
>>
>>
>>
>> *           BR*
>>
>> *            Yunfei*
>>
>> *--------------------------------------------------------*
>>
>> *Description of PPSP Working Group:*
>>
>> The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
>> chartered to develop standard signaling protocols (called PPSP protocols)
>> for multiple types of entities (e.g. intelligent endpoints, caches, content
>> distribution network nodes, and/or other edge devices) to participate in P2P
>> streaming systems in both fixed and mobile Internet.
>>
>>
>> PPSP protocols include the PPSP tracker protocol – a signaling protocol
>> between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a
>> signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of
>> participating PPSP peers, each for a specific channel or streaming file, and
>> answers the queries from PPSP peers for candidate PPSP peers. PPSP peers
>> inform their status information to PPSP trackers, exchange their chunk
>> availability with other PPSP peers and/or PPSP trackers, and ask other PPSP
>> peers for wanted data.
>>
>>
>>
>> 1. A “problem statement” document describing the problems, incentives, and
>> scope of developing the PPSP protocols, as well as common terminologies and
>> concepts.
>>
>>
>>
>> 2. A “requirements” document listing the requirements on the designed PPSP
>> protocols (e.g., general functionality and performance requirements of PPSP
>> protocols or basic types of information that PPSP protocols should
>> communicate to facilitate P2P streaming).
>>
>>
>> 3. An "architectural survey" document explaining the current P2P streaming
>> architectures, in particular tracker-based P2P streaming, and key issues in
>> best practice.
>>
>>
>> 4. A proposed standard defining the PPSP peer protocol. This protocol will
>> define how PPSP peers advertise chunk availability. The protocol will also
>> define the requests and responses of chunks among PPSP peers.
>>
>>
>>
>> 5. A proposed standard defining the PPSP tracker protocol. This protocol
>> will define how PPSP peers inform and request information from PPSP trackers
>> and how PPSP trackers reply to the requests.
>>
>>
>>
>> 6. A “usage document” explaining how the protocols defined above, along
>> with existing IETF protocols, such as RELAOD, ALTO and RTSP, can
>> inter-operate; and how they may be integrated together to produce complete
>> P2P streaming systems.
>>
>>
>>
>> 7. Optionally a ”mobile usage document” (PPSP mobile BCP document) to
>> evaluate PPSP with and without Mobile IP support when there are a lot of
>> mobile peers in the system.
>>
>>
>> The work planned for the PPSP WG is distinct from, but requires close
>> participation with, work in other IETF WGs, particularly P2PSIP, ALTO and
>> MMUSIC. The PPSP WG assumes that it cannot modify baseline P2PSIP, ALTO, and
>> MMUSIC behaviors. If PPSP determines that extensions to P2PSIP, ALTO, MMUSIC
>> are needed, PPSP will seek to define such extensions and present to the
>> respective working groups.
>>
>>
>> The design of PPSP has to consider security/privacy issues. The protocol
>> document will contain a complete description of the security/privacy issues
>> that PPSP should address.
>>
>>
>>
>> 2. Network coding mechanisms in P2P streaming. Network coding may be used
>> in P2P streaming, but its support is beyond the scope of current charter.
>>
>>
>>
>> 5. Research type questions related to P2P streaming. This WG will instead
>> forward such questions to the IRTF P2PRG or other RG as appropriate.
>> Examples include cache management.
>>
>> *Goals and Milestones:*
>>
>> Apr 2010
>>
>> Working Group Last Call for problem statement
>>
>> Jun 2010
>>
>> Submit problem statement to IESG as Informational document
>>
>> Aug 2010
>>
>> Working Group Last Call for architecture survey
>>
>> Aug 2010
>>
>> Working Group Last Call for requirements
>>
>> Oct
>>
>> 2010
>>
>> Submit architecture survey to IESG as Informational document
>>
>> Oct 2010
>>
>> Submit requirements to IESG as Informational document
>>
>> Apr 2011
>>
>> Working Group Last Call for PPSP peer protocol
>>
>> Apr
>>
>> 2011
>>
>> Working Group Last Call for PPSP tracker protocol
>>
>> Aug 2011
>>
>> Submit PPSP peer protocol to IESG as Proposed Standard
>>
>> Aug 2011
>>
>> Submit PPSP tracker protocol to IESG as Proposed Standard
>>
>> Nov 2011
>>
>> Working Group Last Call of usage document
>>
>> Nov 2011
>>
>> Working Group Last Call of mobility BCP document
>>
>> Jan 2012
>>
>> Submit usage document to IESG as Informational document
>>
>> Jan 2012
>>
>> Submit mobility BCP document to IESG as Informational document
>>
>> Apr 2012
>>
>> Dissolve or re-charter
>>
>>
>>
>>
>>  ------------------------------
>>
>> zhangyunfei
>>
>> 2009-09-10
>>  ------------------------------
>>
> ------------------------------
>