Subject: [ppsp] A Question about the architecture of P2P CDN based content sharing

From: xuan tai <[email-masked]>
Date: Mon, 10 May 2010 15:23:30 +0800

Dear Everyone:

I have a question when I was reading a draft about PPSP named
*“draft-li-ppsp-p2p-cdn-00”(A
P2P CDN based Content Sharing System using PPSP and RELOAD)*, and welcome
everybody to join me to discuss the question as follows:

*Background:*

In the architecture of P2P CDN based content sharing system, there are three
kinds of participators: content/service provider, CDN provider and user;

The CDN provider provides tracker overlay, storage overlay and cachers;

The storage overlay acts as storage cloud providing the services of storing
massive content safely and reliably. Cachers are deployed near CSCs, and
cache the hot contents for CSCs.

*The problem is*:

*Is it necessary to design this kind of functions: “storage overlay”?*

In my opinion, content provider acts as the content source, and it must be
very safe and reliable, while cachers store some hot contents and deliver
them to users very quickly, therefore there is no need to design a function
entity “storage overlay”; and in common knowledge, the architecture of CDN
systems includes no “storage overlay” providing this kind of functions.

*PS: *

In the DECADE proposed by Huawei, every UE in the P2P Systems has its own
“storage” which has the same name but different functions with the “storage
overlay” in this draft .The “storage” in DECADE provides other UEs to
download the UE’s data when the UE is offline.

-- 
Regards,

北京邮电大学 / Beijing University of Posts and Telecommunications (BUPT)
台璇 / Tai Xuan
e-mail: [email-masked]
mobile:+86135-8176-2082

---

From: [email-masked]
Date: Fri, 14 May 2010 16:52:18 +0800

Hi Xuan
Thanks for your comments.
With cachers, content source doesn't need to be very powerful, doesn't 
need to have very wide bandwidth. Analogously, with storage overlay, 
content source doesn't need to be very reliable. 
Using storage overlay's persistent storage service, content/service 
provider's can save the cost to deploy and maintain a very reliable 
storage system.
Many CDN providers provide persistent storage service. In my opinion, 
persistent storage can be viewed as an optional function of CDN or a CDN 
related function.

BR
Lichun

xuan tai <[email-masked]> 
发件人:  [email-masked]
2010-05-10 15:23

收件人
[email-masked]
抄送

主题
[ppsp] A Question about the architecture of P2P CDN based content sharing

Dear Everyone:
I have a question when I was reading a draft about PPSP named “
draft-li-ppsp-p2p-cdn-00”(A P2P CDN based Content Sharing System using 
PPSP and RELOAD), and welcome everybody to join me to discuss the question 
as follows:
 
Background:
In the architecture of P2P CDN based content sharing system, there are 
three kinds of participators: content/service provider, CDN provider and 
user; 
The CDN provider provides tracker overlay, storage overlay and cachers;
The storage overlay acts as storage cloud providing the services of 
storing massive content safely and reliably. Cachers are deployed near 
CSCs, and cache the hot contents for CSCs. 
 
The problem is:
Is it necessary to design this kind of functions: “storage overlay”?
In my opinion, content provider acts as the content source, and it must be 
very safe and reliable, while cachers store some hot contents and deliver 
them to users very quickly, therefore there is no need to design a 
function entity “storage overlay”; and in common knowledge, the 
architecture of CDN systems includes no “storage overlay” providing this 
kind of functions.
 
PS: 
In the DECADE proposed by Huawei, every UE in the P2P Systems has its own 
“storage” which has the same name but different functions with the “
storage overlay” in this draft .The “storage” in DECADE provides other 
UEs to download the UE’s data when the UE is offline.

-- 
Regards,

北京邮电大学 / Beijing University of Posts and Telecommunications (BUPT)
台璇 / Tai Xuan
e-mail: [email-masked]
mobile:+86135-8176-2082_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: xuan tai <[email-masked]>
Date: Mon, 17 May 2010 14:57:37 +0800

Hi lichun
Thanks for your reply for "A Qustion about" the architecture of P2P CDN
based content sharing.
According to your answer, I still doubt that, could this kind of function
such as "persistent storage service" be provided by content provider ,but
not storage overlay? Can you give more detailed explanation?
Thank you very much.

在 2010年5月14日 下午4:52， <[email-masked]>写道：

> With cachers, content source doesn't need to be very powerful, doesn't need
> to have very wide bandwidth. Analogously, with storage overlay, content
> source doesn't need to be very reliable.
> provider's can save the cost to deploy and maintain a very reliable storage
> system.
>   *xuan tai <[email-masked]>*
> I have a question when I was reading a draft about PPSP named *“draft-li-ppsp-p2p-cdn-00”(A
> e-mail: [email-masked]* <[email-masked]>
>

-- 
Regards,

---

From: [email-masked]
Date: Mon, 17 May 2010 15:21:56 +0800

Yes, a content provider can deploy its own persistent storage system, and 
doesn't use the persistent storage service provided by CDN provider.
Many CDN providers provide the persistent storage service. I think small 
content/service providers would like the persistent storage service. With 
this service, content/service providers don't need a very reliable content 
source server, and don't need to keep the server online 24/7. 

2010-05-17 14:57

收件人
[email-masked]
抄送
[email-masked], [email-masked]
主题
Re: [ppsp] A Question about the architecture of P2P CDN based content 
sharing

Hi lichun

Hi Xuan 

BR 
Lichun 

收件人
[email-masked] 
抄送

主题

Dear Everyone: 
  
Background: 
  
The problem is: 
  
PS: 

-- 
Regards,

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

-- 
Regards,

---

From: xuan tai <[email-masked]>
Date: Mon, 17 May 2010 15:39:33 +0800

OK, I understand it now, at some extent, storage overlay can liberate
content providers from keeping online and persistent all the time, thank you
very much!

在 2010年5月17日 下午3:21， <[email-masked]>写道：

> 在 2010年5月14日 下午4:52， <[email-masked]* <[email-masked]>>写道：
>
> Hi Xuan
>   *xuan tai <[email-masked]* <[email-masked]>*>*
> 发件人:  [email-masked]* <[email-masked]>
>
> 2010-05-10 15:23
>
>   收件人
> [email-masked]* <[email-masked]>
> 抄送
>   主题
>  *
> Background:*
>  *
> The problem is*: *
> Is it necessary to design this kind of functions: “storage overlay”?*
>  *
> PS: *
> ppsp mailing list*
> [email-masked]* <[email-masked]>*
> **https://www.ietf.org/mailman/listinfo/ppsp*<https://www.ietf.org/mailman/listinfo/ppsp>
>
>
> are not permitted to disclose the contents of this communication to others.
> If you have received this email in error please notify the originator of the
> message. Any views expressed in this message are those of the individual
> sender.

-- 
Regards,

---

From: Song Haibin <[email-masked]>
Date: Mon, 17 May 2010 16:12:39 +0800

>>The “storage” in DECADE provides other UEs to download the UE’s data
when the UE is offline. 

Sorry to chime in. Right. And the in-network storage does not have to
support various application layer protocols. The DECADE client can also
control the network resources used by the in-network storage for content
distribution.

And in addition, as far as I can understand, PPSP is NOT trying to redesign
CDN architecture to provide something like “persistent storage”. So what
is the purpose of this document?

By the way, why don’t you send the email to [email-masked]?

Xie Xie,
Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, May 17, 2010 3:22 PM
To: xuan tai
Cc: [email-masked]; [email-masked]
Subject: Re: [ppsp] A Question about the architecture of P2P CDN based
content sharing

2010-05-17 14:57 

收件人

[email-masked] 

抄送

主题

		

Hi lichun 

在 2010年5月14日 下午4:52， < <mailto:[email-masked]> li.lichun1@zte.
com.cn>写道： 

Hi Xuan 

BR 
Lichun 

xuan tai < <mailto:[email-masked]> [email-masked]> 
发件人:   <mailto:[email-masked]> [email-masked] 

2010-05-10 15:23 

收件人

 <mailto:[email-masked]> [email-masked] 

抄送

主题

[ppsp] A Question about the architecture of P2P CDN based content
sharing

Dear Everyone: 
I have a question when I was reading a draft about PPSP named
“draft-li-ppsp-p2p-cdn-00”(A P2P CDN based Content Sharing System using
PPSP and RELOAD), and welcome everybody to join me to discuss the question
as follows: 
 
Background: 
 
The problem is: 
 
PS: 
In the DECADE proposed by Huawei, every UE in the P2P Systems has its own
“storage” which has the same name but different functions with the
“storage overlay” in this draft .The “storage” in DECADE provides other
UEs to download the UE’s data when the UE is offline. 

-- 
Regards,

北京邮电大学 / Beijing University of Posts and Telecommunications (BUPT)
台璇 / Tai Xuan
e-mail:  <mailto:[email-masked]> [email-masked] 

mobile:+86135-8176-2082_______________________________________________
ppsp mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/ppsp>
https://www.ietf.org/mailman/listinfo/ppsp 

-- 
Regards,

北京邮电大学 / Beijing University of Posts and Telecommunications (BUPT)
台璇 / Tai Xuan
e-mail:  <mailto:[email-masked]> [email-masked]
mobile:+86135-8176-2082

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 17 May 2010 16:27:55 +0800

I guess Lichun's document is to show a CDN use case with the support of PPSP.Here PPSP is not specific for persistent storage.Rather this is a byproduct which can be combined with PPSP functionalities.
The raised question of storage functionality in DECADE is a little far from the focus.The focus of DECADE is not to build in-network storage but to build an access and resource control protocol communicating with these kinds of in-network storage.

BR
Yunfei

zhangyunfei
2010-05-17

发件人： Song Haibin
发送时间： 2010-05-17 16:14:52
收件人： [email-masked]; 'xuan tai'
抄送： [email-masked]; [email-masked]
主题： Re: [ppsp] A Question about the architecture of P2P CDNbasedcontent sharing

>>The “storage” in DECADE provides other UEs to download the UE’s data when the UE is offline. 
Sorry to chime in. Right. And the in-network storage does not have to support various application layer protocols. The DECADE client can also control the network resources used by the in-network storage for content distribution.
 
And in addition, as far as I can understand, PPSP is NOT trying to redesign CDN architecture to provide something like “persistent storage”. So what is the purpose of this document?

Xie Xie,
Haibin
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 17, 2010 3:22 PM
To: xuan tai
Cc: [email-masked]; [email-masked]
Subject: Re: [ppsp] A Question about the architecture of P2P CDN based content sharing

Yes, a content provider can deploy its own persistent storage system, and doesn't use the persistent storage service provided by CDN provider.
Many CDN providers provide the persistent storage service. I think small content/service providers would like the persistent storage service. With this service, content/service providers don't need a very reliable content source server, and don't need to keep the server online 24/7. 

xuan tai <[email-masked]> 
2010-05-17 14:57 [email-masked] 
[email-masked], [email-masked] 
主题Re: [ppsp] A Question about the architecture of P2P CDN based content         sharing

Hi lichun 
Thanks for your reply for "A Qustion about" the architecture of P2P CDN based content sharing. 
According to your answer, I still doubt that, could this kind of function such as "persistent storage service" be provided by content provider ,but not storage overlay? Can you give more detailed explanation? 
Thank you very much. 

Hi Xuan 
Thanks for your comments. 
With cachers, content source doesn't need to be very powerful, doesn't need to have very wide bandwidth. Analogously, with storage overlay, content source doesn't need to be very reliable. 
Using storage overlay's persistent storage service, content/service provider's can save the cost to deploy and maintain a very reliable storage system. 
Many CDN providers provide persistent storage service. In my opinion, persistent storage can be viewed as an optional function of CDN or a CDN related function.

BR 
Lichun 

xuan tai <[email-masked]> 
发件人:  [email-masked] 
2010-05-10 15:23  
[email-masked] 
抄送
主题[ppsp] A Question about the architecture of P2P CDN based content        sharing

Dear Everyone: 
I have a question when I was reading a draft about PPSP named “draft-li-ppsp-p2p-cdn-00”(A P2P CDN based Content Sharing System using PPSP and RELOAD), and welcome everybody to join me to discuss the question as follows: 
 
Background: 
In the architecture of P2P CDN based content sharing system, there are three kinds of participators: content/service provider, CDN provider and user; 
The CDN provider provides tracker overlay, storage overlay and cachers; 
The storage overlay acts as storage cloud providing the services of storing massive content safely and reliably. Cachers are deployed near CSCs, and cache the hot contents for CSCs. 
 
The problem is: 
Is it necessary to design this kind of functions: “storage overlay”? 
In my opinion, content provider acts as the content source, and it must be very safe and reliable, while cachers store some hot contents and deliver them to users very quickly, therefore there is no need to design a function entity “storage overlay”; and in common knowledge, the architecture of CDN systems includes no “storage overlay” providing this kind of functions. 
 
PS: 
In the DECADE proposed by Huawei, every UE in the P2P Systems has its own “storage” which has the same name but different functions with the “storage overlay” in this draft .The “storage” in DECADE provides other UEs to download the UE’s data when the UE is offline. 

-- 
Regards,

-- 
Regards,

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 17 May 2010 08:09:13 -0600

Hi All,

Can everyone please try and use [email-masked] as the email to reach this list. Some email has been using [email-masked]. I'm sure this just happened due to some reply along the way but it makes it hard for others to later search and filter the email. I'd appreciate it if people could use [email-masked]. 

Thanks, Cullen