Subject: RE: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt

From: Shahram Davari <[email-masked]>
Date: Thu, 5 Sep 2002 14:32:35 -0700

Eric,

> 
> Shahram> Why only  2 types of L2VPN (VPWS  & VPLS) are 
> covered  in the frame
> Shahram> work?  For example  you could think of a  L2VPN 
> connecting a number
> Shahram> of ATM/FR networks, in which the provider network 
> acts as a virtual
> Shahram> switch, requiring  ATM/FR switching  at PEs (i.e.,  
> virtual private
> Shahram> ATM/FR  service).   Isn't it  more  appropriate  to  
> define a  more
> Shahram> generic virtual private L2 service rather than a 
> VPLS only for LAN? 
> 
> In the generic Framework, a "Forwarder" attaches to multiple 
> Pseudowires and
> multiple  Attachment Circuits,  and  the Forwarder  
> determines  how to  move
> frames among them, possibly by looking at L2-specific 
> addressing information
> and comparing it to the contents of an L2-specific forwarding 
> database.

It seems odd to define the generic framework in PWE3 rather than PPVPN.
  
> 
> More detail  is provided only  for VPWS and  VPLS because 
> this  reflects the
> interests of the WG, as evidenced by its set of internet drafts.

I suggest adding a text to the introduction that says this is not a generic L2VPN framework.
So that if others in future wants to define a VPN based on another L2, then they would not
be bound by this draft.

Thanks,
-Shahram

---

From: Eric Rosen <[email-masked]>
Date: Fri, 06 Sep 2002 10:37:02 -0400

Shahram> It seems  odd to define the  generic framework in  PWE3 rather than
Shahram> PPVPN.  

I don't know what  you mean, the framework I was talking  about is the PPVPN
L2VPN  framework.   However, we  have  tried to  align  this  with the  PWE3
framework, which seems like a good thing to do.