Subject: RE: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt

From: Waldemar Augustyn <[email-masked]>
Date: Tue, 03 Sep 2002 11:36:42 -0400

Shahram,

What's not clear is whether you mean a "native" ATM/FR, or a "virtual" 
ATM/FR VPN.  If you mean the former, this is definitely not in the IETF 
scope.

If you mean the latter, however, then there are further questions.  Are you 
suggesting to emulate ATM/FR switches with IP?  (I hope not)

If not, are you only suggesting CEs be using ATM/FR framing for their L2 
encapsulations?  If so, then the VPN will clearly end up falling into 
either VPWS, or VPLS depending on whether broadcast/multicast is to be 
recognized.  Notice, if you may be thinking point-to-multipoint, then VPWS 
applies, as this case is really a collection of point-to-point circuits.

There is also a  possibility you might want your VPN limit to IP services, 
in which case you could consider the ARP mediation or IPLS concept.

At 07:41 AM 9/3/2002 -0700, Shahram Davari wrote:
>Loa,
>
>Please see my comments in line.
>
>Thanks,
>-Shahram
>
> > -----Original Message-----
> > From: Loa Andersson [mailto:[email-masked]]
> > Sent: Monday, September 02, 2002 3:19 AM
> > To: Shahram Davari
> > Cc: [email-masked]
> > Subject: Re: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt
> >
> >
> > Sharam,
> >
> > see in line
> >
> > Shahram Davari wrote:
> >
> > > Hi,
> > >
> > > 1) Why only 2 types of L2VPN (VPWS & VPLS) are covered in
> > the frame work?
> > >    For example you could think of a L2VPN connecting a
> > number of ATM/FR
> > >    networks, in which the provider network acts as a virtual switch,
> > >    requiring ATM/FR switching at PEs (i.e., virtual private
> > ATM/FR service).
> > >    Isn't it more appropriate to define a more generic
> > virtual private L2
> > >    service rather than a VPLS only for LAN?
> >
> >
> > I guess that there are more than one answer to this
> >
> > a. from my point of view I do not have an interest in atm or
> > fr services
>
>But you are only 1 person in the WG :) Have you asked others opinion?
>Also having a generic framework does not close the door on other L2 VPNs.
>
> >
> > b. from an ietf perspective I thought that this was the domain of pwe3
>
>
>PWE3 only develops the encapsulation. Signaling and discovery are part of
>PPVPN.
>
> >
> > c. if you are suggesting that we should specify virtual private atm
> > switches taking atm forwarding decisions as well as
> > particitating in atm
> > dignaling, this is outside the current scope of ppvnp
>
>How? PPVPN scope only mentions L2VPN, and does not talk at all about any
>specific L2. So I it seems to me it is pretty generic.
>
>
> >
> >
> > >
> > > 2) The framework talks about QoS and resiliency in the
> > context of SLA, but does
> > >    not talk about requirements for decoupling QoS and
> > decoupling resiliency between
> > >    L2VPNs. Why is that?
> >
> >
> > agree on that there are possible improvements on these sections in the
> > draft, but also this is maybe something that would require a framework
> > of its own?
>
>May be, but at least a sentence could be added to show that decoupling of 
>customers'
>QoS and decoupling of their survivability is desired by service providers.
>
> >
> > /Loa
> >
> >
> > >
> > > Thanks,
> > > -Shahram
> > >
> > >
> >
> >
> > --
> >      Loa Andersson
> >      Chief Architect,
> >      Utfors Research, Architecture and Future Lab (URAX)
> >      Utfors AB
> >      Råsundavägen 12
> >      Box 525, 169 29 Solna
> >      Office          +46 8 5270 2000
> >      Office direct   +46 8 5270 5038
> >      Mobile          +46 70 848 5038
> >      Email           [email-masked]
> >      WWW             www.utfors.se
> >
> >

---

From: Shahram Davari <[email-masked]>
Date: Tue, 3 Sep 2002 08:52:37 -0700

Hi,

> From: Waldemar Augustyn [mailto:[email-masked]]
> Sent: Tuesday, September 03, 2002 11:37 AM
> To: Shahram Davari; 'Loa Andersson'
> Subject: RE: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt
> 
> 
> 
> Shahram,
> 

I meant the latter.
> suggesting to emulate ATM/FR switches with IP?  (I hope not)

I was suggesting, something for ATM/FR service similar to VPLS for Ethernet.
I was not sure whether any body is interested in VPATMS / VPFRS or not.
Although, I don't dispute that I still haven't seen anybody requiring
such a service.

> applies, as this case is really a collection of 

Sure.

> in which case you could consider the ARP mediation or IPLS concept.

Sure.

-Shahram

---

From: [email-masked]
Date: Tue, 3 Sep 2002 17:54:44 +0100

Shahram.....just to add to your remarks.  regards, Neil

<snipped>
> Also having a generic framework does not close the door on 
NH=> ATM/FR is ignored at peril.  Ditto SDH/Sonet.  Operators have loads of
this stuff deployed earning real revenue and it works really well.  There is
also very little cash to spend for the foreseeable future given the
reality-take on all the over-hyped technologies of recent years.  So please
bear this fact in mind.
> PWE3 only develops the encapsulation. Signaling and discovery 
NH=> Perhaps this is an error of judgement on functional decomposition (of
work organisation) then?
<snip>

> May be, but at least a sentence could be added to show that 
> decoupling of customers'
NH=> I have raised this point on numerous occasions.  Traffic/performance
isolation between VPNs (of different customers) would seem a pretty
important and basic requirement for VPNs *if* hard SLAs are required that
are also measurable.  But if you can't even fault-manage the technology in
question properly to start with (which begins with well-defined defects)
then I don't know how one can give any availability SLA assurances or QoS
SLA assurances.....since the latter is dependent on the former, and the
former is, in turn, dependent of sound fault-management.

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 5 Sep 2002 17:47:53 -0400

The particular generic framework Eric Rosen mentions should
be defined in PWE3.  It defines the assumptions we make in
describing pseudo-wire behavior.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Thursday, September 05, 2002 5:33 PM
> To: [email-masked]'
> Eric,
> > Shahram> Why only  2 types of L2VPN (VPWS  & VPLS) are
> > covered  in the frame
> > Shahram> work?  For example  you could think of a  L2VPN
> > connecting a number
> > Shahram> of ATM/FR networks, in which the provider network
> > acts as a virtual
> > Shahram> switch, requiring  ATM/FR switching  at PEs (i.e.,
> > virtual private
> > Shahram> ATM/FR  service).   Isn't it  more  appropriate  to
> > define a  more
> > Shahram> generic virtual private L2 service rather than a
> > VPLS only for LAN?
> >
> > In the generic Framework, a "Forwarder" attaches to multiple
> > Pseudowires and
> > multiple  Attachment Circuits,  and  the Forwarder
> > determines  how to  move
> > frames among them, possibly by looking at L2-specific
> > addressing information
> > and comparing it to the contents of an L2-specific forwarding
> > database.
> 
> It seems odd to define the generic framework in PWE3 rather than PPVPN.
> 
> >
> > More detail  is provided only  for VPWS and  VPLS because
> > this  reflects the
> > interests of the WG, as evidenced by its set of internet drafts.
> 
> I suggest adding a text to the introduction that says this is not a
> generic L2VPN framework.
> So that if others in future wants to define a VPN based on another L2,
> then they would not
> be bound by this draft.
> 
> Thanks,
> -Shahram
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Fri, 6 Sep 2002 07:56:24 -0700

Eric,

I have no problem aligning this document with PWE3. But this document does not mention
any thing about the PWE3 framework, and the PE model. 

Either this draft is a generic L2VPN framework (irrespective of the L2) or it is defined
for some specific L2s. All I am saying is that this should be spelled out in the introduction
and abstract, because the title is misleading.

Yours,
-Shahram

> From: Eric Rosen [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 10:37 AM
> To: Shahram Davari
> Shahram> It seems  odd to define the  generic framework in  
> PWE3 rather than
> Shahram> PPVPN.  
> 
> I don't know what  you mean, the framework I was talking  
> about is the PPVPN
> L2VPN  framework.   However, we  have  tried to  align  this  
> with the  PWE3
> framework, which seems like a good thing to do. 
> 
> 
> 
> 
>