Subject: RE: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt

From: Shahram Davari <[email-masked]>
Date: Tue, 3 Sep 2002 07:41:30 -0700

Loa,

Please see my comments in line.

Thanks,
-Shahram

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Monday, September 02, 2002 3:19 AM
> To: Shahram Davari
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-ppvpn-l2-framework-01.txt
> 
> 
> Sharam,
> 
> see in line
> 
> Shahram Davari wrote:
> 
> > Hi,
> > 
> > 1) Why only 2 types of L2VPN (VPWS & VPLS) are covered in 
> the frame work?
> >    For example you could think of a L2VPN connecting a 
> number of ATM/FR
> >    networks, in which the provider network acts as a virtual switch,
> >    requiring ATM/FR switching at PEs (i.e., virtual private 
> ATM/FR service).
> >    Isn't it more appropriate to define a more generic 
> virtual private L2
> >    service rather than a VPLS only for LAN?
> 
> 
> I guess that there are more than one answer to this
> 
> a. from my point of view I do not have an interest in atm or 
> fr services

But you are only 1 person in the WG :) Have you asked others opinion? 
Also having a generic framework does not close the door on other L2 VPNs.

> 
> b. from an ietf perspective I thought that this was the domain of pwe3

PWE3 only develops the encapsulation. Signaling and discovery are part of
PPVPN.

> 
> c. if you are suggesting that we should specify virtual private atm
> switches taking atm forwarding decisions as well as 
> particitating in atm
> dignaling, this is outside the current scope of ppvnp

How? PPVPN scope only mentions L2VPN, and does not talk at all about any
specific L2. So I it seems to me it is pretty generic.

> 
> 
> > 
> > 2) The framework talks about QoS and resiliency in the 
> context of SLA, but does
> >    not talk about requirements for decoupling QoS and 
> decoupling resiliency between
> >    L2VPNs. Why is that?
> 
> 
> agree on that there are possible improvements on these sections in the
> draft, but also this is maybe something that would require a framework
> of its own?

May be, but at least a sentence could be added to show that decoupling of customers'
QoS and decoupling of their survivability is desired by service providers.

> 
> /Loa
> 
> 
> > 
> > Thanks,
> > -Shahram
> > 
> > 
> 
> 
> -- 
>      Loa Andersson
>      Chief Architect,
>      Utfors Research, Architecture and Future Lab (URAX)
>      Utfors AB
>      Råsundavägen 12
>      Box 525, 169 29 Solna
>      Office          +46 8 5270 2000
>      Office direct   +46 8 5270 5038
>      Mobile          +46 70 848 5038
>      Email           [email-masked]
>      WWW             www.utfors.se
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 05 Sep 2002 10:43:39 +0200

Inline, please.

> Loa,

< snip >

> But you are only 1 person 

admittedly my spelling is bad ;), but I think counting is good, at least
as log as I only have to use the fingers of one hand :)

> in the WG :) Have you asked others opinion? 

this realy beats me - I guess the number of things I'm not interested in
far exceeds the fingers on boths hands (and toes on my feet ;) ), why
should I start botherning the ietf mailing lists by asking opinions
on the things I'm not interested in?

< snip >

> specific L2. So I it seems to me it is pretty generic.

I can't see that it is the ppvpn wg tasks address every possible l2vpn,
and I definetly think that atm signaling and switching is outside the
scope of ppvpn. so if the argument for generalizing more is to include
atm/fr signaling and switching, i don't see that is it as necessary.

/Loa