Subject: [precis] draft slides for precis-framework

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 10 Nov 2011 12:55:40 -0700

A draft of my slides can be found here:

http://www.saint-andre.com/ietf/ietf82-precis-framework.pdf

Comments are welcome, or we can discuss in Taipei.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 10 Nov 2011 17:42:30 -0500

- thanks Peter.
- uploaded to IETF proceedings: http://www.ietf.org/proceedings/82/slides/precis-0.pdf

Marc.

Le 2011-11-10 à 14:55, Peter Saint-Andre a écrit :

> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis

---

From: Dave Thaler <[email-masked]>
Date: Fri, 11 Nov 2011 01:09:23 +0000

Slide 3 asks the question about subclasses, but I don't see any mention of the
other question I asked in the same email: whether we should add the 
concept of a complex class for a string with multiple parts, each of which
has a different class.

Personally I think we should define such a concept in the framework because
many of the commonly used identifiers (email addresses, URIs, etc.) are 
complex in that way.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marc Blanchet
> Sent: Friday, November 11, 2011 6:43 AM
> To: Peter Saint-Andre
> Cc: [email-masked]
> Subject: Re: [precis] draft slides for precis-framework
> 
> - thanks Peter.
> - uploaded to IETF proceedings:
> http://www.ietf.org/proceedings/82/slides/precis-0.pdf
> 
> Marc.
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 10 Nov 2011 18:35:48 -0700

I suppose I see a complex class as a kind of subclass, but I might not 
have understood your point. That sounds like a good topic to discuss at 
the WG session next week. :)

---

From: Dave Thaler <[email-masked]>
Date: Fri, 11 Nov 2011 01:42:55 +0000

What's it a subclass of?
If it's a subclass of FreeClass, then so is NameClass.
So you could define the concept of a subclass, say FreeClass is the base class,
and then define subclasses, including NameClass and possibly others.

> From: Peter Saint-Andre [mailto:[email-masked]]
> Sent: Friday, November 11, 2011 9:36 AM
> To: Dave Thaler
> Cc: Marc Blanchet; [email-masked]
> I suppose I see a complex class as a kind of subclass, but I might not have
> understood your point. That sounds like a good topic to discuss at the WG
> session next week. :)
> 
> > Slide 3 asks the question about subclasses, but I don't see any
> > mention of the other question I asked in the same email: whether we
> > should add the concept of a complex class for a string with multiple
> > parts, each of which has a different class.
> >
> > Personally I think we should define such a concept in the framework
> > because many of the commonly used identifiers (email addresses, URIs,
> > etc.) are complex in that way.
> >
> > -Dave
> >
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Marc Blanchet

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Nov 2011 08:16:10 +0800

I see your point. :)

BTW I've updated my slides here:

-- 
Peter Saint-Andre
https://stpeter.im/