Subject: Re: [precis] PRECIS and CharMod [I18N-ACTION-250]

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 5 Sep 2013 14:16:22 +0000

Hello Yoshiro and PRECIS WG,

I'm writing on behalf of the I18N WG with a request. Our WG process normally includes group review of comments before we submit them. Our teleconferences are on Thursdays and your upcoming WGLC is scheduled to end next Wednesday. So I've been tasked with letting you know that we intend to submit comments, but that they will be a little late. Would you consider formally extending your deadline by a day?

Thanks,

Addison

Addison Phillips
Globalization Architect (Amazon Lab126)
Chair (W3C I18N WG)

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: Yoshiro YONEYA [mailto:[email-masked]]
> Sent: Wednesday, August 28, 2013 7:09 PM
> To: Phillips, Addison
> Cc: [email-masked]; [email-masked]
> Subject: Re: [precis] PRECIS and CharMod [I18N-ACTION-244]
> 
> Dear Addison,
> 
> Thank you for raising this.  Very timely, precis' core specification, framework
> (draft-ietf-precis-framework) begun 2 weeks WG LC yesterday, in conjunction
> with its related document (draft-ietf-precis-mappings).
> <http://www.ietf.org/mail-archive/web/precis/current/msg00503.html>
> <http://www.ietf.org/mail-archive/web/precis/current/msg00504.html>
> 
> Would you please review these documents and give us comments during the
> WG LC term?  Especially thoughts about applicability of the PRECIS framework
> to identifiers in CharMod normalization are very welcome.
> 
> Regards,
> 
> --
> Yoshiro YONEYA <[email-masked]>
> 
> On Wed, 28 Aug 2013 18:40:09 +0000 "Phillips, Addison"
> <[email-masked]> wrote:
> 
> > Hello Precis working group,
> >
> > I'm writing on behalf of the W3C Internationalization WG [1]. We've noticed
> that the work you're doing in your various internet-drafts is closely related to
> work we are (and have historically been) doing in the Character Model. In
> particular, we are working on an update to our Normalization and string
> matching document [2][3].
> >
> > We think it would make sense if the PRECIS and CharMod recommendations
> were consistent in what they require/recommend. How can we best
> coordinate?
> >
> > Regards (for W3C I18N),
> >
> > Addison
> >
> > [1] http://www.w3.org/International/
> > http://www.w3.org/International/track/actions/244
> > [2] New Draft: http://www.w3.org/International/docs/charmod-norm/
> > [3] Historical: http://www.w3.org/TR/2012/WD-charmod-norm-20120501/
> > [4] http://www.w3.org/TR/charmod/
> >
> >
> > Addison Phillips
> > Globalization Architect (Amazon Lab126) Chair (W3C I18N WG)
> >
> > Internationalization is not a feature.
> > It is an architecture.
> >
> >
> > _______________________________________________
> > precis mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/precis
> >
> >

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Sep 2013 10:23:36 -0600

On 9/5/13 8:16 AM, Phillips, Addison wrote:
> I'm writing on behalf of the I18N WG with a request. Our WG process
> normally includes group review of comments before we submit them. Our
> teleconferences are on Thursdays and your upcoming WGLC is scheduled
> to end next Wednesday. So I've been tasked with letting you know that
> we intend to submit comments, but that they will be a little late.
> Would you consider formally extending your deadline by a day?

Hi Addison,

I'll let Yoshiro and Marc comment on your request since they are the
chairs.

However, what is the best way for participants in the PRECIS WG to
common on the Character Model document?

Thanks!

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Yoshiro YONEYA <[email-masked]>
Date: Fri, 6 Sep 2013 11:29:16 +0900

Dear Addison,

The most important thing of the WG LC is to gather useful comments 
from the WG members and related parties.  Now we (the WG) know that 
we will get your comments on next Thursday, so we will accept it as 
comments submitted during the WG LC.  We are looking forward to it.

Regards,

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 6 Sep 2013 03:29:43 +0000

Hi Peter,

Thanks for the note.

If individual participants wish to comment, the instructions in the SOTD section apply:

--
If you wish to make comments regarding this document, please send them to [email-masked] (subscribe, archives). All feedback is welcome.
--

We maintain issues in our tracker (currently there are none for this document):

https://www.w3.org/International/track/products/49

Instructions on using the tracker are here:

http://www.w3.org/International/reviews/review-instructions

thanks,

Addison

Addison Phillips
Globalization Architect (Amazon)
Chair (W3C I18N WG)

> From: Peter Saint-Andre [mailto:[email-masked]]
> Sent: Thursday, September 05, 2013 9:24 AM
> To: Phillips, Addison
> Cc: Yoshiro YONEYA; [email-masked]; [email-masked]
> Subject: Re: [precis] PRECIS and CharMod [I18N-ACTION-250]
> 
> I'll let Yoshiro and Marc comment on your request since they are the chairs.
> 
> However, what is the best way for participants in the PRECIS WG to common on
> the Character Model document?
> 
> Thanks!
> 
> Peter
> 
> --
> Peter Saint-Andre
> https://stpeter.im/
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Sep 2013 21:47:01 -0600

On 9/5/13 9:29 PM, Phillips, Addison wrote:
> -- If you wish to make comments regarding this document, please
> send them to [email-masked] (subscribe, archives). All
> feedback is welcome. --
> 

Excellent. I'll add that document to my review list. By what date
would you prefer to receive comments?

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 6 Sep 2013 04:03:26 +0000

The current version has a large hole in it (Section 4), which we hope to fill in two edit sessions planned between now and the end of October. Following that, we intend to publish a complete version for formal review. Any review at this point would be very helpful.

If you are familiar with the old charmod [1], you'll appreciate that we've torn the document down and replaced most of it. The matching sections are a closer fit to what précis is working on (and reflect what we're concerned about being consistent with). The searching section is intended to cover the Ctrl-F feature in browsers (and similar operations), rather than formal languages or protocols.

Addison

[1] http://www.w3.org/TR/charmod-norm/

> Sent: Thursday, September 05, 2013 8:47 PM
> To: Phillips, Addison
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> > -- If you wish to make comments regarding this document, please send
> > them to [email-masked] (subscribe, archives). All feedback
> > is welcome. --
> >
> Excellent. I'll add that document to my review list. By what date would you
> prefer to receive comments?
> 
> Peter
> 
> - --
> Peter Saint-Andre
> https://stpeter.im/
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.19 (Darwin)
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
> 
> iQIcBAEBAgAGBQJSKVA1AAoJEOoGpJErxa2pdg8P/2mxeAuSWc2PqPBZUInUZYF
> h
> SCx4UtY6rd5CwuHVFKKek4acxvD4K+ABxkxfqD6EkurHohZ/ZlQ7qA0v/u3crDf0
> IP0emagOdDHOPl+jhqMam2RhTn743YHjsd/H4562DYHXI2j/2pkvWi7NguC+BY2
> q
> MZNo9j6kQ3YZqIFqdI+X/7NZvUE7vINn2kUku1qSVot9ekgx70Pb4fhl+77GP/8S
> b9bSVojaLozGpshjHAtm4TjMGydFuiLYKqDROUAKNNiV3HXDX4mySIW01ZvPQ1D
> 3
> oKLC4/U6OE8Yprul+TE1clEeWNUkgAHjOyvSCmNTr5xZ/TnHc6zgvGo4KbyNOqDJ
> c35/3Nvp6c5dkRXUvtTjiE6iE1yN6PaA8ix5qw4XdnMSkP+zPZjsEmRB2Ui6NwM1
> QeB/gkH6k4Ssi2J0oiYb5j/m5alsbybFCYBbObT5+WtjOUmuDb4r1t2GFISa3L1y
> GrJ2EC5HvLXl11PgFLtCYT7MVpTeR8cuNIlzGeqt+HkCXKlyUFVPAWCs7WjJIyBZ
> at7fFtjAMoRNjlpLCwb7wsCuhiJpJ3e/IVujw62O90z+zFbYNAXXKfS4MQWuDlA6
> ivN2bHQmOJIrzilgkD+EaYwShhGB+9nRAC7Lk5KTqs8EMcqTLy2z8iH0MsUGt34o
> JHGzu13esCZXbqV1n/wb
> =zFzt
> -----END PGP SIGNATURE-----