Subject: [precis] SASLprep vs SASLprepbis(Unicode3.2.0)

From: Takahiro Nemoto <[email-masked]>
Date: Tue, 22 Jul 2014 09:52:10 -0400

Dear all,

I drew a comparison between the SASLprep's profile and 
the SASLprepbis' profile (FreeformClass with Unicode3.2.0).
The differences are as followings.

[DISALLOW -> PVALID]
	codepoint		SASLprep		SASLprepbis
	0340		DISALLOWED		PVALID
	0341		DISALLOWED		PVALID
	034F		DISALLOWED		PVALID
- This result is based on the definition of 7.1. LetterDigits(A) in the PRECIS framework.

	codepoint		SASLprep			SASLprepbis
	FF20		DISALLOWED(NFKC)	PVALID(FREE_PVAL)
	FF1F		DISALLOWED(NFKC)	PVALID(FREE_PVAL)
- This result is based on each profile's definition(NFKC vs no width mapping+NFC).

[PVALID -> DISALLOW]
	codepoint		SASLprep		SASLprepbis
	0640		PVALID			DISALLOWED
	302E		PVALID			DISALLOWED
- This result is based on the definition of 7.6. Exceptions (F) in the PRECIS framework.
- This difference is the same as the one between IDNA2003 and IDNA2008.

 [UNASSIGNED -> DISALLOW]
	codepoint		SASLprep		SASLprepbis
	07FA		UNASSIGNED		DISALLOWED
- This result is based on the definition of 7.6. Exceptions (F) in the PRECIS framework.

 [DISALLOWED -> CONTEXTJ]
	codepoint		SASLprep		SASLprepbis
	200C		DISALLOWED		CONTEXTJ
	200D		DISALLOWED		CONTEXTJ
- This result is based on the definition of 7.8. JoinControl (H) in the PRECIS framework.
- This difference is the same as the one between IDNA2003 and IDNA2008.

[PVALID -> CONTEXTO]
	codepoint		SASLprep		SASLprepbis
	00B7		PVALID			CONTEXTO
	0375		PVALID			CONTEXTO
- This result is based on the definition of 7.6. Exceptions (F) in the PRECIS framework.
- This difference is the same as the one between IDNA2003 and IDNA2008.

Conclusion
- It is possible to make a PRECIS profile tables with Unicode3.2.0.
- It is possible to drew a comparison between the SASLprep's profile and the SASLprepbis' profile.

Regards,
Nemo

--
Takahiro Nemoto
[email-masked]

---

From: Takahiro Nemoto <[email-masked]>
Date: Tue, 22 Jul 2014 17:53:41 -0400

I forgot to attach difference files in the previous mail.
Tables in the previous mail show non complete lists of differences 
between SASLprep and SASLprepbis.
If you want to check all of the differences, please make sure attached files.

Regards,
Nemo

2014/07/22 9:52、Takahiro Nemoto <[email-masked]> のメール：

> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis